Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox opens in second monitor but it is not connected

  • 6 trả lời
  • 1 gặp vấn đề này
  • 10 lượt xem
  • Trả lời mới nhất được viết bởi JaxPlanet

more options

At home I have a notebook docking station with 2-monitors. I shutdown and took my notebook to work and opened Firefox. There is an animation showing it opening to the right of my screen were I can see it. I figure this is because I last used Firefox on my secondary monitor and Firefox still thinks the monitor is connected. I have been using the same notebook, docking station, and monitors for several years and the only change I am aware of is that FIrefox updated just prior to this problem.

Thankfully, my notebook has a VGA port so I can temporarily plug an extra monitor in so I can move Firefox to my notebook display. I could also make sure that Firefox is on my primary display before I shutdown and disconnect from my docking station. However these are NOT solutions.

If you don't know how to fix this problem, I would be satisfied with knowing how to roll back to a stable version of Firefox.

Thank you in advance!

Tất cả các câu trả lời (6)

more options

Hi, your running just fine. The issue is the solution you do not want to do.

more options

Pkshadow said

Hi, your running just fine. The issue is the solution you do not want to do.

Firefox opening on a monitor that does not exist is not "fine".

more options

hi, can you test if the problem is still present after updating to firefox 62.0.2?

more options

philipp said

hi, can you test if the problem is still present after updating to firefox 62.0.2?

The problem started after I upgraded to 62.0.2. How do I roll back to a stable version?

more options

hi, 62.0.2 was only released on friday, the day after you posted your question so it wasn't the source of the problem - it contained a fix for windows reopening in the wrong position so that's why i was asking if the update helped...

if it didn't you may want to try if the following step changes things: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.startup.blankWindow. double-click it and change its value to false.

another trick that you could use to get a window into view while it is having focus is hitting the windows-key + left/right repeatedly - that should change the position of windows and also get them onto a different screen...

more options

philipp said

hi, 62.0.2 was only released on friday, the day after you posted your question so it wasn't the source of the problem - it contained a fix for windows reopening in the wrong position so that's why i was asking if the update helped... if it didn't you may want to try if the following step changes things: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.startup.blankWindow. double-click it and change its value to false. another trick that you could use to get a window into view while it is having focus is hitting the windows-key + left/right repeatedly - that should change the position of windows and also get them onto a different screen...

Thank you. This is very helpful. I will recreate the problem, test your solutions, and report back.