Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot share second monitor - both screens always share the same thing.

  • 8 trả lời
  • 1 gặp vấn đề này
  • 19 lượt xem
  • Trả lời mới nhất được viết bởi FFus3r

more options

For the last couple of weeks, I have not been able to share my external monitor. Firefox recognizes that I have two screens, but no matter which screen I choose from the share screen dropdown, it always shares my laptop monitor.

Just to be clear on my problem

1. Choose the option to share my screen (in Google Meet). 2. The native Firefox dialog for choosing which screen to share pops up. 3. In the dialog, Screen 1 will be selected by default. That shows a preview of my laptop screen. 4. In the dialog, switch to Screen 2.

EXPECTED The preview should show my external monitor.

GOT The preview for screen 2 shows the same thing as screen 1 - my laptop monitor.

Below are screenshots showing the same same screen in the preview. (It goes without saying, that when I actually share, it always shares my laptop monitor.)

Screen 1: https://www.evernote.com/l/ATNyksV_eFZHqpDsvtqB0ffqI6lV157Zt-cB/image.png Screen 2: https://www.evernote.com/l/ATMuwvp3LF1Kk4eG8K30DZBW4etLNR4jSIAB/image.png

I'm using Firefox 62.0 (64-bit), on a Mac running High Sierra (10.13.6 (17G65)).

Tất cả các câu trả lời (8)

more options

I realize I swapped the URLs for the two screenshots in my original post. They should be like this:

Screen 1: https://www.evernote.com/l/ATMuwvp3LF1Kk4eG8K30DZBW4etLNR4jSIAB/image.png


Screen 2: https://www.evernote.com/l/ATNyksV_eFZHqpDsvtqB0ffqI6lV157Zt-cB/image.png

Thanks in advance for any help!

more options

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

Thank you for the super-fast response. Unfortunately, that did not fix my problem. I followed all your steps - including shutting down the browser, but I get the same results.

I also double-checked the setting was still deactivated, and it is:

https://www.evernote.com/l/ATOSAjrrV9xJHaCNmH5H9YACyhlpVtqCLSAB/image.png

more options

uncheck remember this decision ,

and try to manage monitors again.

Được chỉnh sửa bởi FFus3r vào

more options

Thanks again for the reply, but the "remember this decision" checkbox was always unchecked for me. In fact, when I try to check it, it says: "Firefox cannot allow permanent access to your screen."

I tried checking and unchecking it just to be sure.

more options
more options

Thanks again for the reply. I'm not bothered by the full screen permission being permanent. I don't mind re-approving it every time. It worked a few weeks ago, I'm just trying to get back to that.

I also don't think I have the same issue as on the Reddit site. That refers to Flash. I'm using the new version of Google Meet, which does not rely on Flash for screen sharing. Again, just to reiterate, this worked perfectly until a few weeks ago.

more options

try to disable tracking protection: