Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox just shows an empty "alert" popup for SSL certificate errors

  • 2 trả lời
  • 1 gặp vấn đề này
  • 510 lượt xem
  • Trả lời mới nhất được viết bởi guywithpants

more options

Whenever I visit a website that has an SSL certificate issue, instead of any kind of actual error page, Firefox just shows a modal "Alert" dialog box with no text.

In the attached screenshot, I visited a page I know has an SSL certificate issue. In Chrome, I get a full-page warning. But in Firefox, just the description-less "Alert" box.

I tried disabling all of my plugins before visiting the site as well and got the same result. I don't seem to have customized any of the SSL or Certificate settings in about:config either.

Does anybody have any idea how I can get something approaching normal behaviour out of Firefox for mac?

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can check xul.error_pages prefs on the about:config page and make sure they are default and not user set (bold). If necessary then reset the pref via the right-click context menu to the default value (true).

  • browser.xul.error_pages.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

You can check xul.error_pages prefs on the about:config page and make sure they are default and not user set (bold). If necessary then reset the pref via the right-click context menu to the default value (true).

  • browser.xul.error_pages.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Thank you, that was absolutely it. browser.xul.error_pages.enabled was set to "false". When I reset it back to the default of "true", I see the error page again.