X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Fonts not looking good on Firefox

Được đăng

I am trying the new gmail in firefox but the fonts both normal and bold look awful. On the contrary if I open it to Chrome they look crisp and overall ok. I am attaching a SS. ANy ideas on how to solve this?

I am trying the new gmail in firefox but the fonts both normal and bold look awful. On the contrary if I open it to Chrome they look crisp and overall ok. I am attaching a SS. ANy ideas on how to solve this?

Giải pháp được chọn

Hi tzic, Firefox's Safe Mode disables some font smoothing because it disables Firefox from using hardware acceleration. You can try running with that disabled for a while (in regular mode) to see whether you lose out on other features important to you. If so, instead you could try to fine-tune Firefox's font smoothing settings.

This articles describes how to disable hardware acceleration: Firefox's performance settings.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 31.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Thông tin chi tiết

Wesley Branton
  • Top 10 Contributor
580 giải pháp 4951 câu trả lời
Được đăng

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
Được đăng

Người tạo câu hỏi

Here you are

Here you are
Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

Hi, I have no problem with what your suggesting is wrong and i do not have my glasses on not did I zoom in.

If you think there is something wrong please try this since we have no information  : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

If so please : Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

Please let us know if this solved your issue or if need further assistance.

Hi, I have no problem with what your suggesting is wrong and i do not have my glasses on not did I zoom in. If you think there is something wrong please try this since we have no information : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Performance > Uncheck to view) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ? If so please : Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then *https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Please let us know if this solved your issue or if need further assistance.
Được đăng

Người tạo câu hỏi

running in safe mode fixes the fonts. But I cant find where is the problem. I only have 3 addons that I use daily. Disabling those does not solve it. So it must be something else

running in safe mode fixes the fonts. But I cant find where is the problem. I only have 3 addons that I use daily. Disabling those does not solve it. So it must be something else
jscher2000
  • Top 10 Contributor
8637 giải pháp 70651 câu trả lời
Được đăng

Giải pháp được chọn

Hi tzic, Firefox's Safe Mode disables some font smoothing because it disables Firefox from using hardware acceleration. You can try running with that disabled for a while (in regular mode) to see whether you lose out on other features important to you. If so, instead you could try to fine-tune Firefox's font smoothing settings.

This articles describes how to disable hardware acceleration: Firefox's performance settings.

Hi tzic, Firefox's Safe Mode disables some font smoothing because it disables Firefox from using hardware acceleration. You can try running with that disabled for a while (in regular mode) to see whether you lose out on other features important to you. If so, instead you could try to fine-tune Firefox's font smoothing settings. This articles describes how to disable hardware acceleration: [[Firefox's performance settings]].
Được đăng

Người tạo câu hỏi

thank you for the reply

thank you for the reply
jscher2000
  • Top 10 Contributor
8637 giải pháp 70651 câu trả lời
Được đăng

The following setting makes some difference. You can try it out and see whether it helps, or whether the only good workaround is disabling hardware acceleration.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_r and pause while the list is filtered

(3) Double-click the gfx.font_rendering.cleartype_params.rendering_mode preference and change the value from -1 to 2 and then click OK

You probably need to exit and start Firefox back up again to see any difference.

Example screenshots attached.


Here's my understanding of what the numbers do (as of Firefox 45):

Font smoothing using sub-pixel anti-aliasing/positioning

//     -1 or 0 = use default for font & size;
//     4 = Natural;
//     5 = Natural Symmetric

GDI emulation (whole pixel rendering)

//     1 = aliased;
//     2 = GDI Classic;
//     3 = GDI Natural Widths;

I don't know which one is closest to Chrome.

The following setting makes some difference. You can try it out and see whether it helps, or whether the only good workaround is disabling hardware acceleration. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_r''' and pause while the list is filtered (3) Double-click the '''gfx.font_rendering.cleartype_params.rendering_mode''' preference and change the value from -1 to 2 and then click OK You probably need to exit and start Firefox back up again to see any difference. Example screenshots attached. ---- Here's my understanding of what the numbers do (as of Firefox 45): Font smoothing using sub-pixel anti-aliasing/positioning // -1 or 0 = use default for font & size; // 4 = Natural; // 5 = Natural Symmetric GDI emulation (whole pixel rendering) // 1 = aliased; // 2 = GDI Classic; // 3 = GDI Natural Widths; I don't know which one is closest to Chrome.