X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

How can I force links to open in the same tab instead of a new one?

Được đăng

I'm fine with multiple tabs and all that, but sometimes I want to keep things in the same tab. But then some web developers don't seem to understand this, and code their pages to force links to open in a new tab (or possibly even a new window, but at least I have that under control). There used to be a perfectly cromulent extension that solved this problem by adding an "open in same tab" option to the context menu, but it has not been updated for FF Quantum and probably never will be. Are there any current extensions that do this? Or is there another way that I can restore this option, and only open new tabs when *I* choose to do so?

I'm fine with multiple tabs and all that, but sometimes I want to keep things in the same tab. But then some web developers don't seem to understand this, and code their pages to force links to open in a new tab (or possibly even a new window, but at least I have that under control). There used to be a perfectly cromulent extension that solved this problem by adding an "open in same tab" option to the context menu, but it has not been updated for FF Quantum and probably never will be. Are there any current extensions that do this? Or is there another way that I can restore this option, and only open new tabs when *I* choose to do so?

Giải pháp được chọn

I can't find a method to give you the Open link in same tab option in the context menu, but I can give you instructions to make Firefox always open a link in the same tab. Then you can just use the Open link in new tab option from the context menu or press the middle mouse button to open a link in a new tab.

To make Firefox open all links in the same tab, follow these instructions:

  1. Type about:config in the Firefox address bar
  2. Bypass the security warning
  3. Find the browser.link.open_newwindow.restriction preference
  4. Double click it to change the value to 0
  5. Find the browser.link.open_newwindow preference
  6. Double click it to change the value to 1

Hope this helps.

NOTE: You may need to restart Firefox for the changes to take effect.
Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 26.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Thông tin chi tiết

Wesley Branton
  • Top 10 Contributor
685 giải pháp 5465 câu trả lời
Được đăng

Giải pháp được chọn

I can't find a method to give you the Open link in same tab option in the context menu, but I can give you instructions to make Firefox always open a link in the same tab. Then you can just use the Open link in new tab option from the context menu or press the middle mouse button to open a link in a new tab.

To make Firefox open all links in the same tab, follow these instructions:

  1. Type about:config in the Firefox address bar
  2. Bypass the security warning
  3. Find the browser.link.open_newwindow.restriction preference
  4. Double click it to change the value to 0
  5. Find the browser.link.open_newwindow preference
  6. Double click it to change the value to 1

Hope this helps.

NOTE: You may need to restart Firefox for the changes to take effect.
I can't find a method to give you the ''Open link in same tab'' option in the context menu, but I can give you instructions to make Firefox always open a link in the same tab. Then you can just use the ''Open link in new tab'' option from the context menu or press the middle mouse button to open a link in a new tab. To make Firefox open all links in the same tab, follow these instructions: #Type <code>about:config</code> in the Firefox address bar #Bypass the security warning #Find the <code>browser.link.open_newwindow.restriction</code> preference #Double click it to change the value to <code>0</code> #Find the <code>browser.link.open_newwindow</code> preference #Double click it to change the value to <code>1</code> Hope this helps. <blockquote>'''NOTE:''' You may need to restart Firefox for the changes to take effect.</blockquote>
Jgreenfi1 0 giải pháp 1 câu trả lời
Được đăng

Wesley,

Thanks very much. It looks like this works. I have been looking for a solution to this problem for years.

I guess if I ever want to change back, I can just set both values back to "2", right?

Thanks again.

Wesley, Thanks very much. It looks like this works. I have been looking for a solution to this problem for years. I guess if I ever want to change back, I can just set both values back to "2", right? Thanks again.
cor-el
  • Top 10 Contributor
  • Moderator
17669 giải pháp 159841 câu trả lời
Được đăng

See also:

For links opened via JavaScript you can look at this pref:

See also: *http://kb.mozillazine.org/browser.link.open_newwindow *1: current tab; 2:new window; 3:new tab; For links opened via JavaScript you can look at this pref: *http://kb.mozillazine.org/browser.link.open_newwindow.restriction