X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

stop videos from automatically playing

Được đăng

How can I stop videos from automatically playing when I open a link to a website.

How can I stop videos from automatically playing when I open a link to a website.

Giải pháp được chọn

HI, try this :

there is also a couple here if just want to be able to click that on or off :

Please let us know if this solved your issue or if need further assistance.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0

Thông tin chi tiết

Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

Giải pháp được chọn

HI, try this :

there is also a couple here if just want to be able to click that on or off :

Please let us know if this solved your issue or if need further assistance.

HI, try this : *https://www.howtogeek.com/341690/how-to-prevent-videos-from-autoplaying-in-firefox/ there is also a couple here if just want to be able to click that on or off : *https://addons.mozilla.org/en-GB/firefox/search/?platform=windows&q=stop+autoplay Please let us know if this solved your issue or if need further assistance.

Người tạo câu hỏi

Thanks. This solved the problem.

Thanks. This solved the problem.
LilBro 0 giải pháp 13 câu trả lời
Được đăng

Not working. Yahoo and AOL still insist on playing their stupid videos automatically.

Not working. Yahoo and AOL still insist on playing their stupid videos automatically.
cor-el
  • Top 10 Contributor
  • Moderator
17541 giải pháp 158607 câu trả lời
Được đăng

Câu trả lời hữu ích

The pref that controls auto-play has been changed in the current Firefox release (63.0.1) to an Integer value.

  • media.autoplay.default = 0

When the first two prefs listed below (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions.

  • media.autoplay.enabled.user-gestures-needed = true
  • media.autoplay.ask-permission = true
  • media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also:

The pref that controls auto-play has been changed in the current Firefox release (63.0.1) to an Integer value. *media.autoplay.default = 0 ---- When the first two prefs listed below (or at least user-gestures-needed) are true then there is also a setting available in "Options/Preferences -> Privacy & Security -> Permissions" and you can inspect and modify the exceptions. *media.autoplay.enabled.user-gestures-needed = true *media.autoplay.ask-permission = true *media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt] You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/en-US/kb/block-autoplay

Được chỉnh sửa bởi cor-el vào

portman 1 giải pháp 3 câu trả lời
Được đăng

This is not working for me.

I just logged onto Reuters and the first article I read had a Video running in it, albeit the audio was off.

Any other ideas?

This is not working for me. I just logged onto Reuters and the first article I read had a Video running in it, albeit the audio was off. Any other ideas?
jscher2000
  • Top 10 Contributor
8776 giải pháp 71744 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi portman, were you using the original solution for Firefox 60?

For Firefox 63

The old preference is obsolete. Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available in this "work in progress."

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

If there is still a problem on Reuters, could you provide a link to the page that autoplays video?

Hi portman, were you using the original solution for Firefox 60? '''''For Firefox 63''''' The old preference is obsolete. Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available in this "work in progress." (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) If there is still a problem on Reuters, could you provide a link to the page that autoplays video?
cor-el
  • Top 10 Contributor
  • Moderator
17541 giải pháp 158607 câu trả lời
Được đăng

See also this extension:

See also this extension: *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/