X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Fonts display as question marks

Được đăng

For about a month Firefox intermittently displays fonts a question marks in boxes. I have used a fix found in one of the discussions on your board but it seems a bit radical. I'm a designer running Suitcase and with a lot of fonts including multi language fonts loaded. Thanks for any suggestions :-) Henry


You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

https://developer.mozilla.org/en/Tools/Page_Inspector/How_to/View_fonts We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character.

You can also try to set this pref to 1 on the about:config page in case there is a problem with the security settings. security.sandbox.content.level = 1

/questions/1178053 Firefox not displaying fonts correctly /questions/1178215 ALL text showed on my screen are [A]


For about a month Firefox intermittently displays fonts a question marks in boxes. I have used a fix found in one of the discussions on your board but it seems a bit radical. I'm a designer running Suitcase and with a lot of fonts including multi language fonts loaded. Thanks for any suggestions :-) Henry -------------------------------------- You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. https://developer.mozilla.org/en/Tools/Page_Inspector/How_to/View_fonts We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character. You can also try to set this pref to 1 on the about:config page in case there is a problem with the security settings. security.sandbox.content.level = 1 [/questions/1178053] Firefox not displaying fonts correctly [/questions/1178215] ALL text showed on my screen are [A] --------------------------------------

Giải pháp được chọn

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues. https://wiki.mozilla.org/Security/Sandbox

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

security.sandbox.content.level = 1

close and restart Firefox to make the change effective.

If '1' still doesn't have an effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4222 giải pháp 58926 câu trả lời
Được đăng

Giải pháp được chọn

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues. https://wiki.mozilla.org/Security/Sandbox

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

security.sandbox.content.level = 1

close and restart Firefox to make the change effective.

If '1' still doesn't have an effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues. https://wiki.mozilla.org/Security/Sandbox You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting. security.sandbox.content.level = 1 close and restart Firefox to make the change effective. If '1' still doesn't have an effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value. Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.