Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why does version 60 ignore userChome.css when I try to move tab bar to bottom?

  • 9 trả lời
  • 1 gặp vấn đề này
  • 1438 lượt xem
  • Trả lời mới nhất được viết bởi JBVic

more options

Just updated to 64-bit Firefox Quantum version 60 today. Like so many other people, I want to move my tab bar so that it's right above the content. I Googled and found directions on how to create a "chrome" folder in my profile, then downloaded the "userChrome-tabs_on_bottom.css", put it in that folder and then renamed the file to "userChrome.css". I restarted Quantum and was disappointed to see that it ignored the file. Does anybody have an idea why this is happening? My OS is Windows 7 SP1, fully updated. I do have a dedicated graphics card too.

Giải pháp được chọn

Hello, today I'm posting from the affected computer which is running Windows 7 Pro SP1 and Firefox ver. 60.0. This morning, I decided to make sure that I had the correct location for my user profile. To that end, I opened a new tab and went to about:support to obtain that info. To my surprise, I discovered that I had been using the wrong location. This kind of points out a what IMHO is a problem with Firefox having too many folders which are also called "Profiles". Not sure why this has to be the case, but in any event once I put the chrome folder in the correct profile location, the tabs moved to the bottom the way I've been wanting them to.

My thanks to everybody who replied and tried to help me, I very much appreciate your patience and efforts! Consider this discussion resolved.

Đọc câu trả lời này trong ngữ cảnh 👍 0

All Replies (9)

more options

Hi, please make sure that under file options you have show hidden and known file types as in some cases people have saved the file with txt at the end. One of the Contributors here has this site : https://www.userchrome.org/

They seem to have moved some stuff around in about:config, some other usserChrome does not work. So it is a relearn time again.

more options

Thanks, but I always show hidden and known file types in Windows Explorer.

more options

Please post the contents of that "userChrome-tabs_on_bottom.css" file to PasteBin and give us the resultant URL (after you "Send" it) so that we can read your Paste.

https://pastebin.mozilla.org/ Make sure you select a month for retention of your Paste; "a day" for the default retention usually isn't long enough.

Chances are there's something in that file which isn't compatible with changes made in Firefox 60, or the code is in error.

Or look for a different version of that CSS modification for the tab-strip location. I have seen multiple versions for that type of modification.

more options

the-edmeister said

Please post the contents of that "userChrome-tabs_on_bottom.css" file to PasteBin and give us the resultant URL (after you "Send" it) so that we can read your Paste. https://pastebin.mozilla.org/ Make sure you select a month for retention of your Paste; "a day" for the default retention usually isn't long enough. Chances are there's something in that file which isn't compatible with changes made in Firefox 60, or the code is in error. Or look for a different version of that CSS modification for the tab-strip location. I have seen multiple versions for that type of modification.

Thanks for replying! Actually, I got the file from a link provided in the discussion to support question 1189654. The direct link to the file is:

https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css

more options

It should still work.

One thing that's bothering me is your Firefox identified itself as Firefox 52 running on Windows XP. Could you check whether your "user agent" string is customized? This article has the steps for that:

How to reset the default user agent on Firefox


The most common reasons for a problem with a new userChrome.css setup are:

(A) chrome folder in the wrong location, or not all lower case

(B) userChrome.css file has an extra extension (e.g., userChrome.css.css or userChrome.css.txt)

For (A), you can retrace your steps from the Troubleshooting Information page.

For (B), change the Windows setting so you can see the true, full file name + extension: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

more options

jscher2000 said

It should still work. One thing that's bothering me is your Firefox identified itself as Firefox 52 running on Windows XP. Could you check whether your "user agent" string is customized? This article has the steps for that: How to reset the default user agent on Firefox

The most common reasons for a problem with a new userChrome.css setup are:

(A) chrome folder in the wrong location, or not all lower case

(B) userChrome.css file has an extra extension (e.g., userChrome.css.css or userChrome.css.txt)

For (A), you can retrace your steps from the Troubleshooting Information page.

For (B), change the Windows setting so you can see the true, full file name + extension: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Well you see, this is what happens when info is collected surreptitiously. I don't know how you managed to get that info. about the computer I'm using and version of FF, but I have five computers and this computer isn't the one I'm asking about.

As for the three possible causes you list:

(A) I put the chrome folder in my profile where the directions said to. I also named it in all small letters.

(B) I always change the settings in Windows Explorer so that I can see all file extensions.

Thanks anyway.

more options

JBVic said

Well you see, this is what happens when info is collected surreptitiously. I don't know how you managed to get that info. about the computer I'm using and version of FF, but I have five computers and this computer isn't the one I'm asking about.

Next to your question, under "Question Details" is your browser's user agent string. I thought that was displayed to you during the process of submitting a question because many users tell us to ignore it when they are asking about a different computer. I guess some screens display a lot of boxes so that could escape notice.

Could you check whether Firefox is loading the file at all? If Firefox is loading the file, it should be listed in a very long list of style sheets in the Browser Toolbox, on the Style Editor tab.

This article describes a settings change you need to make to have the Browser Toolbox show up on your Web Developer menu, and then how it works:

https://developer.mozilla.org/docs/Tools/Browser_Toolbox

I also have it in this video starting about halfway and going for a couple minutes:

https://vimeo.com/242513527#t=345s

(Apologies for the boringness.)

more options

Check that you do not run Firefox in compatibility mode or have "Resist Fingerprinting" enabled. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Được chỉnh sửa bởi cor-el vào

more options

Giải pháp được chọn

Hello, today I'm posting from the affected computer which is running Windows 7 Pro SP1 and Firefox ver. 60.0. This morning, I decided to make sure that I had the correct location for my user profile. To that end, I opened a new tab and went to about:support to obtain that info. To my surprise, I discovered that I had been using the wrong location. This kind of points out a what IMHO is a problem with Firefox having too many folders which are also called "Profiles". Not sure why this has to be the case, but in any event once I put the chrome folder in the correct profile location, the tabs moved to the bottom the way I've been wanting them to.

My thanks to everybody who replied and tried to help me, I very much appreciate your patience and efforts! Consider this discussion resolved.