X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Awesome Bar problem with autofil of sites from history

Được đăng

The problem I have is with the order that firefox provides suggestions based on my browsing history.

At the top of the auto-fill heap as I begin typing in the Awesome Bar (where you type the target URL) comes a site I visited years ago, a maps website provided by a local government of a country I no longer live in, I use maps.google several times a day, yet even though the one I never visit is alphabetically closer to 'Z' than 'Google' it still comes first in the list. Meaning I need to type a lot more of the URL to get where I want to go rather than typing 'M' and 'Return/Enter' in a fraction of a second.

It's just a small niggling thing I've not been able to solve for years that wastes my time and annoys me just a tiny bit every day. I can't find a cookie to delete and ask here if any one knows how to delete all traces of the one I don't want.

Thank you!

The problem I have is with the order that firefox provides suggestions based on my browsing history. At the top of the auto-fill heap as I begin typing in the Awesome Bar (where you type the target URL) comes a site I visited years ago, a maps website provided by a local government of a country I no longer live in, I use maps.google several times a day, yet even though the one I never visit is alphabetically closer to 'Z' than 'Google' it still comes first in the list. Meaning I need to type a lot more of the URL to get where I want to go rather than typing 'M' and 'Return/Enter' in a fraction of a second. It's just a small niggling thing I've not been able to solve for years that wastes my time and annoys me just a tiny bit every day. I can't find a cookie to delete and ask here if any one knows how to delete all traces of the one I don't want. Thank you!

Giải pháp được chọn

This might also be of interest: bookmark keywords. If you have a bookmark for

https://maps.google.com/

Then you can edit its properties to have the keyword m and when you type m in the address bar and press Return, Firefox will know to load that bookmark.

To set a keyword, you can right-click the bookmark on the menu/toolbar and choose Properties. There is a keyword field in the dialog that pops up.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 26.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:58.0) Gecko/20100101 Firefox/58.0

Thông tin chi tiết

Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

Please delete your History as as that is what is coming up. If do yes are starting from scratch in the Address Bar/Awesome Bar/URL Bar.....

Any reason using Firefox 58 and not running the current release 59.0.3 ?

Please update your Flash 26.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please let us know if this solved your issue or if need further assistance.

Please delete your History as as that is what is coming up. If do yes are starting from scratch in the Address Bar/Awesome Bar/URL Bar..... Any reason using Firefox 58 and not running the current release 59.0.3 ? Please update your Flash 26.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Please let us know if this solved your issue or if need further assistance.

Người tạo câu hỏi

Wow.. fast reply. Awesome thank you.

This problem still persists even when my firefox is up to date so that aside,

What say I don't want to reset everything by deleting history? Starting again is more annoying that the small niggling issue I started with and not user friendly.

Is there a way to selectively delete just that URL from my history archives? This would be way less disruptive to my workflow.

Wow.. fast reply. Awesome thank you. This problem still persists even when my firefox is up to date so that aside, What say I don't want to reset everything by deleting history? Starting again is more annoying that the small niggling issue I started with and not user friendly. Is there a way to selectively delete just that URL from my history archives? This would be way less disruptive to my workflow.
jscher2000
  • Top 10 Contributor
8583 giải pháp 70196 câu trả lời
Được đăng

Câu trả lời hữu ích

You could try flushing the site that appears as an "autofill" match in the address bar. Those seems to be in some less logical order such as alphabetical.

In order to remove it, you'll want to get at least one entry in current history. Then open the Library window using:

  • (menu bar) History > Show All History

In the search box at the upper right of the Library window, type or paste enough of the site address to filter out all the important stuff in the list. (This reduces the risk of errors.) Then right-click (on Mac, Ctrl+click) the unwanted entry and choose Forget About This Site. This dangerous command should remove not only history for that site but bookmarks, cookies, and saved preferences.

This set of cleanups happens in the background, so it might take a minute for everything to disappear. After that, the site shouldn't be autofilled in the address bar or suggested in the drop-down.

Success?

You could try flushing the site that appears as an "autofill" match in the address bar. Those seems to be in some less logical order such as alphabetical. In order to remove it, you'll want to get at least one entry in current history. Then open the Library window using: * (menu bar) History > Show All History In the search box at the upper right of the Library window, type or paste enough of the site address to filter out all the important stuff in the list. (This reduces the risk of errors.) Then right-click (on Mac, Ctrl+click) the unwanted entry and choose Forget About This Site. This dangerous command should remove not only history for that site but bookmarks, cookies, and saved preferences. This set of cleanups happens in the background, so it might take a minute for everything to disappear. After that, the site shouldn't be autofilled in the address bar or suggested in the drop-down. Success?
jscher2000
  • Top 10 Contributor
8583 giải pháp 70196 câu trả lời
Được đăng

Giải pháp được chọn

This might also be of interest: bookmark keywords. If you have a bookmark for

https://maps.google.com/

Then you can edit its properties to have the keyword m and when you type m in the address bar and press Return, Firefox will know to load that bookmark.

To set a keyword, you can right-click the bookmark on the menu/toolbar and choose Properties. There is a keyword field in the dialog that pops up.

This might also be of interest: bookmark keywords. If you have a bookmark for https://maps.google.com/ Then you can edit its properties to have the keyword '''m''' and when you type m in the address bar and press Return, Firefox will know to load that bookmark. To set a keyword, you can right-click the bookmark on the menu/toolbar and choose Properties. There is a keyword field in the dialog that pops up.

Người tạo câu hỏi

Yes!!!!!! Success. Thank you very much.

Yes!!!!!! Success. Thank you very much.
Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

Hi,Glad to hear that your problem has been resolved. If you haven't already, *Please select the answer that solves the problem*. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Hi,Glad to hear that your problem has been resolved. If you haven't already, *Please select the answer that solves the problem*. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Người tạo câu hỏi

Will do that now. But if I did that directly from the email telling me I have help with my problem I wouldn't get a chance to thank all involved. They need to do something about that. All the best.

Will do that now. But if I did that directly from the email telling me I have help with my problem I wouldn't get a chance to thank all involved. They need to do something about that. All the best.