Search Support

firefox is eating up memory and laptop's fan is always working because of it

  • 5 trả lời
  • 1 gặp vấn đề này
  • 7 lượt xem
  • Trả lời mới nhất được viết bởi Shadow110

more options

I have been using Firefox for more than 10 years now. it is the best browser out there. However, starting from last year I have been noticing that my computer's fan is almost always working which takes too much of my battery and I figured that Firefox is the main issue (I did so many research and tests %100 sure). Later, I herd about the new Firefox quantum, and decided to wait and not switch to another browser. the new one was released and I installed it the very first day. I was super happy that it's much faster and use less memory than other browsers (that's right). However, lately (about a month) I noticed the same the fan is always working again, so I check the task manager and found my dear Firefox quantum acting up again even though 3 taps are opened.


I really need help with this issue to stay using Firefox, I am tired of this issue and really considering switching to another browser because this is just not good at all. and I could not find any way to fix it. please see the attached pic it's just unbelievable.
Đính kèm ảnh chụp màn hình

All Replies (5)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

more options

Thank you for the reply, I did all of these and didn’t make any difference, issue still there.

more options

I once had a heating issue with my computer. It turned out the vents were plugged. Get a can of compressed air and blow them out.

I called for more help. The overheating is only with Firefox running?

more options

yes, whenever Firefox is running the fan will be working because Firefox is eating up my memory. safe mood, signed out, and logged in with different profile did not make any different. uninstall and reinstall and the issue is still there. I am totally disappointed with Firefox. It's unbelievable that too many users have been experiencing the exact same issue and Firefox has not solved it yet. 2 taps opened in Firefox taking more memory than chrome with 11 taps

more options

Hi, you seem to have a few errors in your Video Card Drivers : featureLog: {u'fallbacks': [{u'message': u'Constant buffer offset binding does not work', Plus a couple more. Suggest reinstall or update your : adapterDescription: Intel(R) HD Graphics 3000 driverDate: 5-19-2016

Please note Win 10 can and will change any and all Hardware Drivers. https://www.howtogeek.com/302595/how-to-stop-windows-10-from-automatically-updating-hardware-drivers/ Please search for Device Manager and check if any has been changed like for sound card and if that is the proper driver date for your video card. https://www.intel.com/content/www/us/en/support/detect.html Old & corrupted Drivers cause a wide range of issues. This maybe one.

Also check : please Copy/Paste about:preferences#privacy into the Address Bar then Enter. Go down to Heading : Permissions and at the bottom of that heading please make sure there is a Check Mark in the box for Prevent accessibility services from accessing your browser.

Check that e10's are turned off as can do it this way also if have not used the about:config directions : please go up to General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please note that extensions use aprox 20megs give or take each so your running 120megs of extensions.

I have 32gig of ram so am running same 7 tabs as you are using 1800+ on this system. My other uses only 800 so it really depends on the system sometimes as to what and how much Firefox uses. Difficult to figure out why. But you can do things like Optimize Windows 10 so more ram left :

Please let us know if this solved your issue or if need further assistance.