X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox 59 can't access my logins

Được đăng

Firefox recently updated to v59 and, as with some other users, it is (a) asking for the master password on starting up rather than on first use, and (b) losing access to my logins (there are about 200 in total). After reading other answers I have deleted two files, secmod and key4. That solves the problem the next time Firefox is used - presumably it reads the logins from key3. However, after restarting the computer and launching Firefox again, a new key4 appears in the profile and the problems above recur. (I back up my complete Firefox profile with my normal data backup, so have a 'good' copy to refer to from before the problems started).

Is there any way of permanently stopping the problem recurring - or at worst, copying the logins and 'reinstalling' them correctly into v59 (without having to write them down physically)?

Firefox recently updated to v59 and, as with some other users, it is (a) asking for the master password on starting up rather than on first use, and (b) losing access to my logins (there are about 200 in total). After reading other answers I have deleted two files, secmod and key4. That solves the problem the next time Firefox is used - presumably it reads the logins from key3. However, after restarting the computer and launching Firefox again, a new key4 appears in the profile and the problems above recur. (I back up my complete Firefox profile with my normal data backup, so have a 'good' copy to refer to from before the problems started). Is there any way of permanently stopping the problem recurring - or at worst, copying the logins and 'reinstalling' them correctly into v59 (without having to write them down physically)?

Giải pháp được chọn

hi, do you have security.enterprise_roots.enabled set to enabled? to check, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.enterprise_roots.enabled. if it's shown in bold, double-click it and change its value to false, restart the browser once and see if you can access your passwords then...

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 29.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4248 giải pháp 59427 câu trả lời
Được đăng

Are you using any password add-ons or programs?.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Are you using any password add-ons or programs?. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Người tạo câu hỏi

Thanks for your suggestion. I'm not using any password add-ons etc., and unfortunately safe mode doesn't make any difference.

Thanks for your suggestion. I'm not using any password add-ons etc., and unfortunately safe mode doesn't make any difference.
philipp
  • Top 25 Contributor
  • Moderator
5306 giải pháp 23424 câu trả lời
Được đăng

Giải pháp được chọn

hi, do you have security.enterprise_roots.enabled set to enabled? to check, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.enterprise_roots.enabled. if it's shown in bold, double-click it and change its value to false, restart the browser once and see if you can access your passwords then...

hi, do you have security.enterprise_roots.enabled set to enabled? to check, enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''security.enterprise_roots.enabled'''. if it's shown in bold, double-click it and change its value to '''false''', restart the browser once and see if you can access your passwords then...
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 157978 câu trả lời
Được đăng

Câu trả lời hữu ích

Key3.db only stores the encryption key and is normally 16 kb. The actual usernames and passwords are stored in logins.json Key4.db is a SQLite database that can store other data. Sometimes the migration to key4.db goes wrong and you lose passwords. I don't know if you have external software (security software or cleanup software) that might be causing issues with file corruption.

Key3.db only stores the encryption key and is normally 16 kb. The actual usernames and passwords are stored in logins.json Key4.db is a SQLite database that can store other data. Sometimes the migration to key4.db goes wrong and you lose passwords. I don't know if you have external software (security software or cleanup software) that might be causing issues with file corruption.

Người tạo câu hỏi

I changed security.enterprise_roots.enabled back to 'false' and the problem has disappeared. I had previously changed it as part of a work-around to get Kaspersky Total Security to work with Firefox (ultimately unsuccessful). Many thanks.

I changed '''security.enterprise_roots.enabled''' back to 'false' and the problem has disappeared. I had previously changed it as part of a work-around to get Kaspersky Total Security to work with Firefox (ultimately unsuccessful). Many thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 157978 câu trả lời
Được đăng

See also:

  • bug 1427248 - security.enterprise_roots.enabled set to true causes password manager to "forget" all usernames & passwords

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

See also: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1427248 bug 1427248] - security.enterprise_roots.enabled set to true causes password manager to "forget" all usernames & passwords (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)