X
Tap here to go to the mobile version of the site.

Diễn đàn trợ giúp

Firefox doesn't drop videocard usage after closing youtube

Được đăng

Hello. So, as the question says, Firefox doesn't drop GPU usage and GPU core frequency (but it drops GPU memory frequency). I tried the other browsers (Chrome, Opera, Edge) and it's fine. I have AMD RX560 graphic card with the latest drivers and I also tried previous versions

Hello. So, as the question says, Firefox doesn't drop GPU usage and GPU core frequency (but it drops GPU memory frequency). I tried the other browsers (Chrome, Opera, Edge) and it's fine. I have AMD RX560 graphic card with the latest drivers and I also tried previous versions

Được chỉnh sửa bởi giindur vào

Giải pháp được chọn

Hmm, I turned off "Use reccomended perfomance settings" in Perfomance, while still using hardware acceleration and everything became fine. Now my GPU doesn't load on 100% in YouTube videos.


UPD: The problem came back so I decided to turn off hardware acceleration.

Read this answer in context 0
Trích dẫn

Additional System Details

Ứng dụng

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.167 Safari/537.36

Thông tin thêm

GFX GoodMorningMusic 2 giải pháp 20 câu trả lời
Được đăng

Similar to chrome Firefox caches pages and leaves them in memory and they're still using resources go to settings and disable whatever is causing that.

Similar to chrome Firefox caches pages and leaves them in memory and they're still using resources go to settings and disable whatever is causing that.
Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

I don't think I get your explanation. What settings? Also, usage & frequency doesn't drop even when I close Firefox. The only thing that helps is restarting the "amddvr.exe" process

I don't think I get your explanation. What settings? Also, usage & frequency doesn't drop even when I close Firefox. The only thing that helps is restarting the "amddvr.exe" process
Bài viết này có hữu ích với bạn không? 0
Trích dẫn
WestEnd
  • Top 10 Contributor
47 giải pháp 2191 câu trả lời
Được đăng

@giindur, what are you doing that the GPU is stuck?

@giindur, what are you doing that the GPU is stuck?

Được chỉnh sửa bởi WestEnd vào

Bài viết này có hữu ích với bạn không? 0
Trích dẫn

Người tạo câu hỏi

@WestEnd, well, nothing. I just open random video on YouTube, then videocard usage and frequency goes up (everything similar to Chrome or other browsers because I use hardware rendering), but when I close video — usage and frequency doesn't drop in Firefox (specifically videocard's core frequency, because GPU memory frequency drops as normal)

@WestEnd, well, nothing. I just open random video on YouTube, then videocard usage and frequency goes up (everything similar to Chrome or other browsers because I use hardware rendering), but when I close video — usage and frequency doesn't drop in Firefox (specifically videocard's core frequency, because GPU memory frequency drops as normal)
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
3653 giải pháp 50115 câu trả lời
Được đăng

Reboot the computer. Then,

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Reboot the computer. Then, [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

It worked, but only once. I guess I should do this shenanigans every time, that's sad. I can also reload this process (screenshot below), but this is not the solution. Anyway, thanks for helping

It worked, but only once. I guess I should do this shenanigans every time, that's sad. I can also reload this process (screenshot below), but this is not the solution. Anyway, thanks for helping
Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
3653 giải pháp 50115 câu trả lời
Được đăng

amddvr.exe is part of AMD ReLive and developed by Advanced Micro Devices

Try removing and re-installing the program using the current installer.

amddvr.exe is part of AMD ReLive and developed by Advanced Micro Devices Try removing and re-installing the program using the current installer.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

I didn't install AMD ReLive. It might be AMD driver's fault generally.

I didn't install AMD ReLive. It might be AMD driver's fault generally.
Bài viết này có hữu ích với bạn không?
Trích dẫn
WestEnd
  • Top 10 Contributor
47 giải pháp 2191 câu trả lời
Được đăng

Only other thing I would say is to get the lasted GPU driver and uninstall and clean out the old GPU drivers and delete that folder as well and reinstall the new GPU and see if that doesn't fix the stuck GPU.

Only other thing I would say is to get the lasted GPU driver and uninstall and clean out the old GPU drivers and delete that folder as well and reinstall the new GPU and see if that doesn't fix the stuck GPU.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Người tạo câu hỏi

I've uninstalled drivers with Driver Display Uninstaler, then tried the newest one and nope, didn't help.

I've uninstalled drivers with Driver Display Uninstaler, then tried the newest one and nope, didn't help.
Bài viết này có hữu ích với bạn không?
Trích dẫn

Giải pháp được chọn

Hmm, I turned off "Use reccomended perfomance settings" in Perfomance, while still using hardware acceleration and everything became fine. Now my GPU doesn't load on 100% in YouTube videos.


UPD: The problem came back so I decided to turn off hardware acceleration.

Hmm, I turned off "Use reccomended perfomance settings" in Perfomance, while still using hardware acceleration and everything became fine. Now my GPU doesn't load on 100% in YouTube videos. UPD: The problem came back so I decided to turn off hardware acceleration.

Được chỉnh sửa bởi giindur vào

Bài viết này có hữu ích với bạn không?
Trích dẫn
FredMcD
  • Top 10 Contributor
3653 giải pháp 50115 câu trả lời
Được đăng

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

If you need hardware acceleration, use it.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. If you need hardware acceleration, use it.
Bài viết này có hữu ích với bạn không?
Trích dẫn
Đặt một câu hỏi

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.