Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Since upgrading to 58.0.2, I get the yellow "page slowing browser" alert bar ALL THE TIME. Can I tweak the alert?

  • 9 trả lời
  • 3 gặp vấn đề này
  • 55 lượt xem
  • Trả lời mới nhất được viết bởi LenG

more options

Since my most recent upgrade of Firefox (to 58.0.2 as stated), I am getting the yellow bar across the top of the page with the "web page is slowing down your browser" message almost any time I load a new page.

I do have a large number of tabs open, but far fewer than I did in previous versions, where I might have had 3 windows open with multiple tabs in each.

I do have a relatively slow PC and extremely slow internet (~300kB/s), which might help explain the problem, but it is definitely noticeable that I am seeing this bar far more often than ever before, even while doing less with the browser.

I use NoScript and I notice that it does tend to happen more often on pages with trusted scripts, making me suspect Java is part of the problem as well. In the past I would occasionally get the message about a script on the page slowing things down - I haven't seen that since, so I guess this is the replacement message for that?

Does anyone have any tips on what to do? If nothing else, can I turn off this alert or tweak how quickly it triggers? I almost never want to hit anything other than Wait.

Thanks in advance for your help!

Tất cả các câu trả lời (9)

more options

What security software do you have?

There have been issues reported with some security software (Avast, AVG).


bug 1438829 - Avast/AVG slowing down JS

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Được chỉnh sửa bởi cor-el vào

more options

Thanks cor-el :)

I do have Avast, but again, had that before the upgrade.

I was getting some slow page load times before but I assumed that was just the narrow pipe. (And it seems as though that alert slows things down itself, though of course that's highly subjective.)

more options

See this thread:

more options

Seems about right. Sorry - using NoScript meant most pages loaded OK, so I didn't think that "all pages" applied.

This has answered my question, but not sure whether it's appropriate to hit the "Solved the problem" button when the problem definitely still exists! Let me know what the etiquette is here.

And I stand by my suggestion of some way to tweak the parameters of that alert bar.

Thanks again!

more options

Using Firefox 58.0.2 64 bit Windows 7 Home Premium The tip to suspect Avast, and Bugzilla's bug 1438829, encouraged me to remove Avast. Also, someone in the bug report noted that disabling Avast would be insufficient. After uninstalling Avast, delays and interference ended. (Now I'm running naked, but eventually I can find an antivirus that doesn't break things.)

Delays : response to clicking on a link in a New York Times video playlist was delayed as much as half a minute, with no network traffic and no CPU. Interference: videos on PBS would skip, with a frame rate of about two or three per second. In Internet Explorer the same video would stutter. These effects showed with only one tab. I was using free Avast.

Được chỉnh sửa bởi angbob vào

more options

My AV is MS Security Essentials. Getting yellow bars more often each day. (Firefox user since 2008 ("year 1")... along with NoScript.)

No correlation with elapsed uptime - I've tried leaving Firefox OFF for over a day and it still happens. My usage pattern is typically 2-4 tabs... never more than 4... on a not-very-fast pipe, and a not-very-fast laptop, with fully-updated Windows 7.

Watching Resource Monitor for any patterns.

Security Essentials is lightweight... but I dare not run with no active AV. Looking for any evidence that an AV would cause this symptom.

BEST PATH would be to find the code that PRODUCES the yellow bar, and "work backwards" to what triggers it.

Since it ONLY happens with Firefox, pointing at other sources is not very productive.

Được chỉnh sửa bởi BillM vào

more options

To BillM: In case you haven't already tried, and at the risk of tiresomely repeating the same old advice... Try safe mode Create an empty Firefox profile. (Start/Run firefox.exe -p) Disable MS Security Essentials. Maybe even uninstall it. Stop NoScript.

Aside: In my post of 18 Feb, I reported that expelling Avast cleared the problem. I am now using TotalAV. So far, no problems.

more options

How about actual software engineering instead of half-educated guesses? I've identified a reproducible scenario. Instead of guesswork... how about Mozilla engineers actually Reading The Code and identifying exactly WHAT conditions trigger the yellow bar to begin with?

The text, "a web page is slowing down your browser" is an obvious attempt to blame the web page rather than the browser. Are there reports of this symptom with any other browser? (None that I've seen, using older Firefox, or current IE or Chrome.)

Is that text ("A web page is slowing down your browser") present anywhere in Mozilla's code base??


Disabling Security Essentials does NOT help. Where's the code that produces the yellow bar??

Được chỉnh sửa bởi BillM vào

more options

I gave up trying to tweak everything in the world and just started using chrome for some sites like my VA medical records. I have stuck with Windows 7 and Microsoft security and had no trouble until recent Firefox upgrades. Chrome works fine on same site.

Obviously the upgrade tweak something that it should let the hell alone. I have had no major issues with Firefox since the beginning but this band yellow bar warning is the straw. I don't have time messing around with the tools to get my work done so chrome solve the problem for me.