Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox spell check doesn't work by default

  • 9 trả lời
  • 11 gặp vấn đề này
  • 3222 lượt xem
  • Trả lời mới nhất được viết bởi Jeenu

more options

I'm running Firefox Quantum on Linux from a downloaded archive (i.e., not one that came with the distribution). My problem is that there's no spell check by default. I had selected en-US language in the preferences, and have also checked "Check spelling as I type" box. Still, no spell check (misspelled words don't have that red, jagged, underline).

As part of experimentation, I installed this dictionary (https://addons.mozilla.org/en-US/firefox/addon/us-english-dictionary/), restarted Firefox, and voila, there I've spell check.

Why did I have to install the add on to get this to work? Should spell check work by default (along with "Check spelling as I type")? Is this expected?

The add on however seems to belong to Firefox 52. So what I now have working, is that just by fluke?

Giải pháp được chọn

OK, it was news to me that I had to explicitly install the dictionary. But now that I have, it's working as expected. Thanks!

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

Page Not Found when I hit the URL. Should be going here :

So no idea what you have.

limitations of built in Firefox Spellchecker as shown.

Please let us know if this solved your issue or if need further assistance.

Được chỉnh sửa bởi Shadow110 vào

more options

The URL is right. Unfortunately, the ")" got appended to the URL; remove that, and it'll work.

I can't find anything regarding the limitations that you mentioned - could you elaborate?

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Make sure you install a dictionary and not a language pack.

You can check the spellchecker.dictionary pref on the about:config page. There might be problems when the name has an underscore and not a hyphen (en_us versus en-us).

more options
  • Not all locales come with a dictionary installed due to licensing reasons.

Above limitation....... So ya if you want a US Dictionary you found it. I do not know why not shipped with it.......... I am in Canada so have to get diff dictionary, also use a GB Firefox. So I never know what goes on if downloaded from the US. All should be as you want now.

more options

jeenuv said

I'm running Firefox Quantum on Linux from a downloaded archive (i.e., not one that came with the distribution). My problem is that there's no spell check by default. I had selected en-US language in the preferences, and have also checked "Check spelling as I type" box. Still, no spell check (misspelled words don't have that red, jagged, underline). As part of experimentation, I installed this dictionary (https://addons.mozilla.org/en-US/firefox/addon/us-english-dictionary/ ), restarted Firefox, and voila, there I've spell check. Why did I have to install the add on to get this to work? Should spell check work by default (along with "Check spelling as I type")? Is this expected? The add on however seems to belong to Firefox 52. So what I now have working, is that just by fluke?

The en-US Firefox Releases from www.mozilla.org/firefox/all/ comes with the en-US dictionary. Most other locales do not except may a couple like fr perhaps.


Btw your Flash Player 11.2.x version is rather outdated and vulnerable as Adobe has been supporting Linux again with NPAPI Flash Player since mid 2016. You can get it from your package manager or from https://get.adobe.com/flashplayer/ (Version 28.0.0.137)

If Firefox was running when you get rid of old version and install new version then either restart Firefox or type about:plugins with a : in the Location (address) bar for Firefox to scan for new Flash Player version.

more options

Giải pháp được chọn

OK, it was news to me that I had to explicitly install the dictionary. But now that I have, it's working as expected. Thanks!

more options

James said Btw your Flash Player 11.2.x version is rather outdated and vulnerable as Adobe has been supporting Linux again with NPAPI Flash Player since mid 2016. You can get it from your package manager or from https://get.adobe.com/flashplayer/ (Version 28.0.0.137) </blockquote>

OK, will do, but how do you know this?!

more options

jeenuv said

OK, will do, but how do you know this?!

In your More System Details on right of your first post.

more options

Ah, I see now. You got me worried a bit there!