X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Why is the memory usage so high with 57.0?

Được đăng

With the new update, I'm getting notifications from my computer that memory resources are low frequently. I'm seeing about 2 GB of memory usage on a consistent basis with only 5 or 6 tabs open. This has only happened since updating to the new 57.0 Firefox. None of my add-ins or plug ins have changed, and I was never getting this system memory usage notification before. Should I go back to the previous version? What else can I do if everything else is the same?

With the new update, I'm getting notifications from my computer that memory resources are low frequently. I'm seeing about 2 GB of memory usage on a consistent basis with only 5 or 6 tabs open. This has only happened since updating to the new 57.0 Firefox. None of my add-ins or plug ins have changed, and I was never getting this system memory usage notification before. Should I go back to the previous version? What else can I do if everything else is the same?

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 27.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Thông tin chi tiết

Mkll 314 giải pháp 1978 câu trả lời
Được đăng

Try turning off multi-process (called e-10s): To disable e10s/multiprocess go to about:config in your location bar. Search for browser.tabs.remote.autostart. There may be multiple results. Set them all to false and restart the browser.

Try turning off multi-process (called e-10s): To disable e10s/multiprocess go to about:config in your location bar. Search for browser.tabs.remote.autostart. There may be multiple results. Set them all to false and restart the browser.

Câu trả lời hữu ích

This does seem to have reduced the memory usage by about 30%. Is that as much as I could expect?

This does seem to have reduced the memory usage by about 30%. Is that as much as I could expect?
Mkll 314 giải pháp 1978 câu trả lời
Được đăng

For now, probably.

For now, probably.
Anonymous83 1 giải pháp 15 câu trả lời
Được đăng

amazz said

With the new update, I'm getting notifications from my computer that memory resources are low frequently. I'm seeing about 2 GB of memory usage on a consistent basis with only 5 or 6 tabs open. This has only happened since updating to the new 57.0 Firefox. None of my add-ins or plug ins have changed, and I was never getting this system memory usage notification before. Should I go back to the previous version? What else can I do if everything else is the same?

I tried doing your workaround and now it says in my task manager than I'm using 97% of my physical memory (8GB's), which is almost all of my computer capacity. I had to turn the value back to "true." I don't know what to do.

''amazz [[#question-1186054|said]]'' <blockquote> With the new update, I'm getting notifications from my computer that memory resources are low frequently. I'm seeing about 2 GB of memory usage on a consistent basis with only 5 or 6 tabs open. This has only happened since updating to the new 57.0 Firefox. None of my add-ins or plug ins have changed, and I was never getting this system memory usage notification before. Should I go back to the previous version? What else can I do if everything else is the same? </blockquote> I tried doing your workaround and now it says in my task manager than I'm using 97% of my physical memory (8GB's), which is almost all of my computer capacity. I had to turn the value back to "true." I don't know what to do.
Anonymous83 1 giải pháp 15 câu trả lời
Được đăng

Mkll said

Try turning off multi-process (called e-10s): To disable e10s/multiprocess go to about:config in your location bar. Search for browser.tabs.remote.autostart. There may be multiple results. Set them all to false and restart the browser.

I tried doing your workaround and now it says in my task manager than I'm using 97% of my physical memory (8GB's), which is almost all of my computer capacity. I had to turn the value back to "true." I don't know what to do.

''Mkll [[#answer-1030916|said]]'' <blockquote> Try turning off multi-process (called e-10s): To disable e10s/multiprocess go to about:config in your location bar. Search for browser.tabs.remote.autostart. There may be multiple results. Set them all to false and restart the browser. </blockquote> I tried doing your workaround and now it says in my task manager than I'm using 97% of my physical memory (8GB's), which is almost all of my computer capacity. I had to turn the value back to "true." I don't know what to do.
MBramnik 0 giải pháp 4 câu trả lời
Được đăng

Câu trả lời hữu ích

This thread may be connected to the one taking place here: https://support.mozilla.org/en-US/questions/1185127

I found both that one and this one at about the same time, as my problems were a combination of the two - much higher memory drain from Firefox Quantum 57.0, and also ~7 different firefox.exe processes in my task manager. Using the above workaround reduced the load slightly, but it still "spikes" sometimes and lags/freezes my system. Thank you in advance for any advice or suggestions.

(Apologies in advance to the moderator(s) if posting in both threads is frowned upon - just trying to cover all bases)

UPDATE: I may have solved my own problem, but didn't want to delete this post in case what I found would be useful to others: https://support.mozilla.org/en-US/questions/1185127#answer-1040011

This thread may be connected to the one taking place here: https://support.mozilla.org/en-US/questions/1185127 I found both that one and this one at about the same time, as my problems were a combination of the two - much higher memory drain from Firefox Quantum 57.0, and also ~7 different firefox.exe processes in my task manager. Using the above workaround reduced the load slightly, but it still "spikes" sometimes and lags/freezes my system. Thank you in advance for any advice or suggestions. (Apologies in advance to the moderator(s) if posting in both threads is frowned upon - just trying to cover all bases) '''UPDATE:''' I may have solved my own problem, but didn't want to delete this post in case what I found would be useful to others: https://support.mozilla.org/en-US/questions/1185127#answer-1040011

Được chỉnh sửa bởi MBramnik vào

Người tạo câu hỏi

That chosen solution really isn't doing anything anymore. I have like 5 or 6 basic website tabs open and Firefox is using 2GB of RAM. What??? How much is going on in the background that I can't control. I'm going back to chrome...

That chosen solution really isn't doing anything anymore. I have like 5 or 6 basic website tabs open and Firefox is using 2GB of RAM. What??? How much is going on in the background that I can't control. I'm going back to chrome...
Mkll 314 giải pháp 1978 câu trả lời
Được đăng

Try a refresh.

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Try a refresh. The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.