X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

57.0 does not work with Intel HD Graphics 4000

Được đăng

Symptoms: Very slow with very frequent freezing of Firefox 57.0 for up to 20 seconds.

Environment: Windows 10 Creators Fall 2017 Edition Intel HD Graphics 4000 Driver 07/04/2017 10.18.10.4653 - latest available.

Fixes tried: Disable HW acceleration webgl.disabled=true Neither worked

Tried MS Driver: Uninstalled device and deleted driver. Windows installed a generic driver.

  • Firefox then worked normally.
  • Generic driver is not an acceptable solution because it does not support the size of my monitor - it is a 4:3 window on a 9:16 display.

Reinstalled latest Intel driver - problem recurred.

Symptoms: Very slow with very frequent freezing of Firefox 57.0 for up to 20 seconds. Environment: Windows 10 Creators Fall 2017 Edition Intel HD Graphics 4000 Driver 07/04/2017 10.18.10.4653 - latest available. Fixes tried: Disable HW acceleration webgl.disabled=true Neither worked Tried MS Driver: Uninstalled device and deleted driver. Windows installed a generic driver. * Firefox then worked normally. * Generic driver is not an acceptable solution because it does not support the size of my monitor - it is a 4:3 window on a 9:16 display. Reinstalled latest Intel driver - problem recurred.

Giải pháp được chọn

one more thing that i have just noticed when looking at your system details - can you please test if the following steps can fix the performance issue you're seeing in firefox 57?: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once.

then please let us know how this goes?

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 27.0 r0

Ứng dụng

  • Firefox 57.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/57.0/WINNT/en-US/

Tiện ích mở rộng

  • IBM Notes Browser Plug-in Extension 9.0.16.16061 (IBMNotesBrowserExtension@ibm.com) (không hoạt động)
  • IBM Security Rapport 1.4 (rapportext@trusteer.com) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0162
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 20328086
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.15
  • driverDate: 4-7-2017
  • driverDate2:
  • driverVersion: 10.18.10.4653
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzTouchInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Có
Tonnes
  • Locale Leader
246 giải pháp 1454 câu trả lời
Được đăng

Can you try setting layers.acceleration.disabled to true in the about:config page and report back? A Firefox restart in required.

If this doesn’t help, create a new profile using the about:profiles page as a test, set that as default, and restart Firefox (you can switch the default profile back later).

Can you try setting ''layers.acceleration.disabled'' to ''true'' in the about:config page and report back? A Firefox restart in required. If this doesn’t help, create a new profile using the ''about:profiles'' page as a test, set that as default, and restart Firefox (you can switch the default profile back later).

Câu trả lời hữu ích

Thanks for your suggestions.

I deleted all versions of Firefox and did a clean installation of 57. Verified problem still present. Set layers.accelleration.disabled to true - problem still present. Set webgl.disabled to true. Problem still present. Verified Use HW accelerator not ticked and process limit set to 1. Still fails. Created a new profile as requested. No difference.

Further suggestion welcome.

Thanks for your suggestions. I deleted all versions of Firefox and did a clean installation of 57. Verified problem still present. Set layers.accelleration.disabled to true - problem still present. Set webgl.disabled to true. Problem still present. Verified Use HW accelerator not ticked and process limit set to 1. Still fails. Created a new profile as requested. No difference. Further suggestion welcome.
smorele 44 giải pháp 310 câu trả lời
Được đăng

Hello, it seems to be a technical issue where only developers can help. I suggest creating a technical ticket on http://bugzilla.mozilla.org/

Hello, it seems to be a technical issue where only developers can help. I suggest creating a technical ticket on [http://bugzilla.mozilla.org/ http://bugzilla.mozilla.org/]

Người tạo câu hỏi

Thank you. I will do so.

Thank you. I will do so.
philipp
  • Top 25 Contributor
  • Moderator
5315 giải pháp 23463 câu trả lời
Được đăng

Giải pháp được chọn

one more thing that i have just noticed when looking at your system details - can you please test if the following steps can fix the performance issue you're seeing in firefox 57?: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once.

then please let us know how this goes?

one more thing that i have just noticed when looking at your system details - can you please test if the following steps can fix the performance issue you're seeing in firefox 57?: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''accessibility.force_disabled'''. double-click it, change its value to '''1''' and restart firefox once. then please let us know how this goes?
James
  • Top 25 Contributor
  • Moderator
1598 giải pháp 11286 câu trả lời
Được đăng

smorele said

Hello, it seems to be a technical issue where only developers can help. I suggest creating a technical ticket on http://bugzilla.mozilla.org/

Though Bugzilla is not really a place for support or discussion like a forum but for reporting and tracking things.

https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines

''smorele [[#answer-1031138|said]]'' <blockquote> Hello, it seems to be a technical issue where only developers can help. I suggest creating a technical ticket on [http://bugzilla.mozilla.org/ http://bugzilla.mozilla.org/] </blockquote> Though Bugzilla is not really a place for support or discussion like a forum but for reporting and tracking things. https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines

Người tạo câu hỏi

Hi,

I followed the advice to try: "enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once."

I don't know why but it seems to have resolved the problem, thank you.

Hi, I followed the advice to try: "enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once." I don't know why but it seems to have resolved the problem, thank you.

Được chỉnh sửa bởi GeorgeJK vào