X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

all text on certain websites appears in question marks

Được đăng

hello,

since today I notice that all text in firefox (56.0 mac-version) on certain sites appears only in question marks (in suqares). looks like that on sites like mozilla support (busy right now in safari) google.com, my banking site, tmobile, gmail and a lot other ones too. all those sites show totally normal in other brouwsers.

did the following troubleshoot 1) view > text encoding > unicode = OK 2) preferences Font & Color > advanced > checked 'allow pages to choose their own font' = OK

any other suggestions? (:

tried to enclose some screenshots (small jpg and png files) but the upload keeps spinning for ever... never mind.

thanks in advance for any help on the questionmark problem.

hello, since today I notice that all text in firefox (56.0 mac-version) on certain sites appears only in question marks (in suqares). looks like that on sites like mozilla support (busy right now in safari) google.com, my banking site, tmobile, gmail and a lot other ones too. all those sites show totally normal in other brouwsers. did the following troubleshoot 1) view > text encoding > unicode = OK 2) preferences Font & Color > advanced > checked 'allow pages to choose their own font' = OK any other suggestions? (: tried to enclose some screenshots (small jpg and png files) but the upload keeps spinning for ever... never mind. thanks in advance for any help on the questionmark problem.

Giải pháp được chọn

This bug might be relevant:

Fonts don't display correctly since update due to content-process sandboxing on macOS (#1404919)

Key points:

(A) One workaround is to reduce sandboxing as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and reduce the value from its default value of 3 to 1 and click OK

This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac

That won't take effect until the next time you quit and restart Firefox.

(B) One possible reason for the problem is fonts in a "suitcase" or "Postscript Type 1" format

According to a comment in the bug, Firefox currently will only load fonts with certain file extensions (.otf, .ttf, .ttc, .otc, and .dfont). Other fonts will not load and Firefox will need to use a fallback fonts. There may need to be a change in a future version of Firefox to handle other common font extensions, or to do a better job choosing a fallback font.

Đọc câu trả lời này trong ngữ cảnh 11

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

uBlock origin noscript https everywhere browsing protection savefromnet helper

all enabled since the problem appeared

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4224 giải pháp 58943 câu trả lời
Được đăng

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Mac You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 Mac You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Câu trả lời hữu ích

hi,

thanks for reply and help, unfortunately it didn't solve the problem.

I did/checked of all that: – 'allow pages to choose their own font' IS turned on. – flash-player IS up to date – there are NO corrupted, duplicate, damaged fonts or other font issues found on my Mac

any other suggestions?

all sites/texts show properly in brouwsers (safari, opera). as soon as I downgrade firefox from 56.0 to an older version (at the moment vs54.01) everything works fine again.

could it be possible that the problem simply lies within the newest version of firefox (a bug!?) and waiting for a decent update on this issue would be the only solution?

(:

hi, thanks for reply and help, unfortunately it didn't solve the problem. I did/checked of all that: – 'allow pages to choose their own font' IS turned on. – flash-player IS up to date – there are NO corrupted, duplicate, damaged fonts or other font issues found on my Mac any other suggestions? all sites/texts show properly in brouwsers (safari, opera). as soon as I downgrade firefox from 56.0 to an older version (at the moment vs54.01) everything works fine again. could it be possible that the problem simply lies within the newest version of firefox (a bug!?) and waiting for a decent update on this issue would be the only solution? (:
philipp
  • Top 25 Contributor
  • Moderator
5289 giải pháp 23366 câu trả lời
Được đăng

could you try attaching the screenshots again?

could you try attaching the screenshots again?
Enigma 26 giải pháp 184 câu trả lời
Được đăng

When you get question marks in boxes, it's possible that the server sends the file with a 'Windows' or ' Western' encoding instead of with 'Unicode'.

You could check the encoding :

Press the Alt key, and in the upper left corner click View => Text Encoding

When you get question marks in boxes, it's possible that the server sends the file with a 'Windows' or ' Western' encoding instead of with 'Unicode'. You could check the encoding : Press the Alt key, and in the upper left corner click View => Text Encoding

Người tạo câu hỏi

ok, for new screenshots I just upgraded firefox again to vs 56.0. luckily they seem to upload well here in firefox (didn't work while I was using safari yesterday.)

see screenshots

interesting... I just noticed that for all text on the mozilla support site it does matter whether the add-on 'NoScript' is enabled or disabled! the moment I disable the add-on all text is appears readable.

for the other sites tho ist doesn't seem to matter. all text there stays in question-marks while add ons are enabled or disabled.

any more clues from that?

ok, for new screenshots I just upgraded firefox again to vs 56.0. luckily they seem to upload well here in firefox (didn't work while I was using safari yesterday.) see screenshots interesting... I just noticed that for all text on the mozilla support site it does matter whether the add-on 'NoScript' is enabled or disabled! the moment I disable the add-on all text is appears readable. for the other sites tho ist doesn't seem to matter. all text there stays in question-marks while add ons are enabled or disabled. any more clues from that?

Được chỉnh sửa bởi slaws2 vào

Người tạo câu hỏi

additional to what I just posted:

the moment I select the screenshots, the 'x' to close the image again at the above right corner is shown as question mark! see screenshot detail form earlier uploaded forth screenshot. so there are texts at the mozilla forum site left that show as questionmarks regardless the add-on NoScript is en- or disabled...

might provide another detail to fix the problem...

additional to what I just posted: the moment I select the screenshots, the 'x' to close the image again at the above right corner is shown as question mark! see screenshot detail form earlier uploaded forth screenshot. so there are texts at the mozilla forum site left that show as questionmarks regardless the add-on NoScript is en- or disabled... might provide another detail to fix the problem...

Được chỉnh sửa bởi slaws2 vào

Người tạo câu hỏi

Enigma said

You could check the encoding : Press the Alt key, and in the upper left corner click View => Text Encoding

@enigma Thanxs! I checked that in the beginning, Unicode was/is turned 'on'.

''Enigma [[#answer-1011956|said]]'' <blockquote> You could check the encoding : Press the Alt key, and in the upper left corner click View => Text Encoding </blockquote> @enigma Thanxs! I checked that in the beginning, Unicode was/is turned 'on'.

Được chỉnh sửa bởi slaws2 vào

Charyut 0 giải pháp 3 câu trả lời
Được đăng

I have this problem, too. Firefox updated itself this afternoon to 56.0 (64-bit) (iMac OS 10.12.6) . Following the update, I restored the tabs from the previous session. All of the google sites show up as question marks. Also, text on Amazon, Audible, Making Marks and my local library do the same thing. I have never in all the years I've used Firefox had this happen following an update. Luckily I have other browsers, which do not have the problem, which to me ties it directly to the update. Nothing else has changed on my computer. Also, note that the new FF followed a planned restart of my computer and then FF. Images attached.

I have this problem, too. Firefox updated itself this afternoon to 56.0 (64-bit) (iMac OS 10.12.6) . Following the update, I restored the tabs from the previous session. All of the google sites show up as question marks. Also, text on Amazon, Audible, Making Marks and my local library do the same thing. I have never in all the years I've used Firefox had this happen following an update. Luckily I have other browsers, which do not have the problem, which to me ties it directly to the update. Nothing else has changed on my computer. Also, note that the new FF followed a planned restart of my computer and then FF. Images attached.

Được chỉnh sửa bởi Charyut vào

cor-el
  • Top 10 Contributor
  • Moderator
17415 giải pháp 157316 câu trả lời
Được đăng

It is possible there is a problem with the (default) used on web pages.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

It is possible there is a problem with the (default) used on web pages. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/en/Tools/Page_Inspector *https://developer.mozilla.org/en/Tools/Page_Inspector/How_to/View_fonts
Enigma 26 giải pháp 184 câu trả lời
Được đăng

More users have reported this and they all have two things in common :

1) It happened after the latest update. 2) They all are on Mac OS.

Anybody want to file a bug report  ?

https://bugzilla.mozilla.org/

More users have reported this and they all have two things in common : 1) It happened after the latest update. 2) They all are on Mac OS. Anybody want to file a bug report ? https://bugzilla.mozilla.org/
cor-el
  • Top 10 Contributor
  • Moderator
17415 giải pháp 157316 câu trả lời
Được đăng

It is quite likely that this is an issues with some fonts or with rendering this specific font.

Can anybody on Mac check what font is used as shown on the Font tab (not the font-family rule)?

A while back we had an issue (unresolved) where the boxes showed a capital 'A' character and this might be something similar.

It is quite likely that this is an issues with some fonts or with rendering this specific font. Can anybody on Mac check what font is used as shown on the Font tab (not the font-family rule)? A while back we had an issue (unresolved) where the boxes showed a capital 'A' character and this might be something similar. *[/questions/1158016]

Người tạo câu hỏi

thanks for all feedback on this issue! @enigma the link/the site to file a bug looked so 'complicated' that I decided to let that go for now... @ cor-el I'm not sure I looked properly with the 'Inspect element' for the right thing you asked. check the screenshots. unfortunately, myself I have no clue at all how to interprete all that data. @ charyut for the time being I just downgraded firefox, because I vlaue the add-ons running there.

Directory Listing: /pub/firefox/releases/55.0.3/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/55.0.3/mac/en-US/

thanks for all feedback on this issue! @enigma the link/the site to file a bug looked so 'complicated' that I decided to let that go for now... @ cor-el I'm not sure I looked properly with the 'Inspect element' for the right thing you asked. check the screenshots. unfortunately, myself I have no clue at all how to interprete all that data. @ charyut for the time being I just downgraded firefox, because I vlaue the add-ons running there. Directory Listing: /pub/firefox/releases/55.0.3/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/55.0.3/mac/en-US/

Được chỉnh sửa bởi slaws2 vào

Enigma 26 giải pháp 184 câu trả lời
Được đăng

@ slaw2 : I understand why you decided to downgrade - I wish you wouldn't have had to, though. This needs to be fixed. Research tells me that this 'question mark' issue has been going on for years now (no bug report was filed as far as I can tell). I have absolutely no clue what's going on here (sorry  !) 'Feel kind of ashamed of my avatar now ......

@ slaw2 : I understand why you decided to downgrade - I wish you wouldn't have had to, though. This needs to be fixed. Research tells me that this 'question mark' issue has been going on for years now (no bug report was filed as far as I can tell). I have absolutely no clue what's going on here (sorry !) 'Feel kind of ashamed of my avatar now ......
jonahleewalker 0 giải pháp 5 câu trả lời
Được đăng

I am having the same issue. This is with Firefox Developers edition 57.0b5 (64 bit) as well as the recently updated Firefox 56 (64 Bit) and I am running MacOS Sierra version 10.12.6. I didn't happen with any previous version of Firefox.

I checked the fonts and this image shows the response on bing.com. .LastResort system Used as 'Arial.'

I am having the same issue. This is with Firefox Developers edition 57.0b5 (64 bit) as well as the recently updated Firefox 56 (64 Bit) and I am running MacOS Sierra version 10.12.6. I didn't happen with any previous version of Firefox. I checked the fonts and this image shows the response on bing.com. .LastResort system Used as 'Arial.'
jonahleewalker 0 giải pháp 5 câu trả lời
Được đăng

As for Fonts. I do run Suitcase Fusion, but I did run Font Doctor and I am having no issues with any of my fonts. And all of my Arial fonts are turned on.

As for Fonts. I do run Suitcase Fusion, but I did run Font Doctor and I am having no issues with any of my fonts. And all of my Arial fonts are turned on.
jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

slaws2 said

I just noticed that for all text on the mozilla support site it does matter whether the add-on 'NoScript' is enabled or disabled! the moment I disable the add-on all text is appears readable.

This is a useful clue: NoScript may block the Open Sans font from being downloaded, and then Firefox would use one of the fonts the site specifies as a "fall back" in that case.

'Open Sans',Arial,Helvetica,sans-serif;

Arial not working on this site is consistent with your Google screenshot.

We had another thread this morning about Firefox on Mac using LastResort in place of 'Helvetica Neue', so this seems to be going around for some reason yet to be determined (or yet to be known to me, at least).

It's certain possible to work around a bad font or two with custom style rules, but it would be preferable to get to the bottom of it.

Please Try:

On a page with LastResort substitution showing in the Inspector, try this:

(1) Select and copy the following style rule:

 font-family: Helvetica !important;

(2) Change from the Fonts panel to the Rules panel.

(3) Click in the "element" area to get a little box (see attached screenshot example) and paste the custom style rule. You can press Enter/Return or click away to complete the addition.

Does Firefox display Helvetica correctly?

''slaws2 [[#answer-1011957|said]]'' <blockquote>I just noticed that for all text on the mozilla support site it does matter whether the add-on 'NoScript' is enabled or disabled! the moment I disable the add-on all text is appears readable. </blockquote> This is a useful clue: NoScript may block the Open Sans font from being downloaded, and then Firefox would use one of the fonts the site specifies as a "fall back" in that case. 'Open Sans',Arial,Helvetica,sans-serif; Arial not working on this site is consistent with your Google screenshot. We had another thread this morning about Firefox on Mac using LastResort in place of 'Helvetica Neue', so this seems to be going around for some reason yet to be determined (or yet to be known to me, at least). It's certain possible to work around a bad font or two with custom style rules, but it would be preferable to get to the bottom of it. '''Please Try:''' On a page with LastResort substitution showing in the Inspector, try this: (1) Select and copy the following style rule: font-family: Helvetica !important; (2) Change from the Fonts panel to the Rules panel. (3) Click in the "element" area to get a little box (see attached screenshot example) and paste the custom style rule. You can press Enter/Return or click away to complete the addition. Does Firefox display Helvetica correctly?
jonahleewalker 0 giải pháp 5 câu trả lời
Được đăng

I attempted to submit a bug on Mozilla for this problem. Bug 1405459.

I attempted to submit a bug on Mozilla for this problem. Bug 1405459.
jonahleewalker 0 giải pháp 5 câu trả lời
Được đăng

Yes if I do that Mozilla displays Helvetica Correctly.

Yes if I do that Mozilla displays Helvetica Correctly.
jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

Giải pháp được chọn

This bug might be relevant:

Fonts don't display correctly since update due to content-process sandboxing on macOS (#1404919)

Key points:

(A) One workaround is to reduce sandboxing as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and reduce the value from its default value of 3 to 1 and click OK

This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac

That won't take effect until the next time you quit and restart Firefox.

(B) One possible reason for the problem is fonts in a "suitcase" or "Postscript Type 1" format

According to a comment in the bug, Firefox currently will only load fonts with certain file extensions (.otf, .ttf, .ttc, .otc, and .dfont). Other fonts will not load and Firefox will need to use a fallback fonts. There may need to be a change in a future version of Firefox to handle other common font extensions, or to do a better job choosing a fallback font.

This bug might be relevant: '''Fonts don't display correctly since update due to content-process sandboxing on macOS''' ([https://bugzilla.mozilla.org/show_bug.cgi?id=1404919 #1404919]) Key points: '''(A) One workaround is to reduce sandboxing''' as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sand''' and pause while the list is filtered (3) Double-click the '''security.sandbox.content.level''' preference and reduce the value from its default value of 3 to '''1''' and click OK ''This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac'' That won't take effect until the next time you quit and restart Firefox. '''(B) One possible reason for the problem is fonts in a "suitcase" or "Postscript Type 1" format''' According to a comment in the bug, Firefox currently will only load fonts with certain file extensions (.otf, .ttf, .ttc, .otc, and .dfont). Other fonts will not load and Firefox will need to use a fallback fonts. There may need to be a change in a future version of Firefox to handle other common font extensions, or to do a better job choosing a fallback font.

Được chỉnh sửa bởi jscher2000 vào

jonahleewalker 0 giải pháp 5 câu trả lời
Được đăng

Yes that does fix the issue.

Should I attempt to update the bug report? How can we get this issue fixed without a workaround?

Yes that does fix the issue. Should I attempt to update the bug report? How can we get this issue fixed without a workaround?