X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox will not open.

Được đăng

I have uninstalled and reinstalled, but have the same problem. Chrome opens, no problem. What else can I do?

I have uninstalled and reinstalled, but have the same problem. Chrome opens, no problem. What else can I do?

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

What's your computer system and Firefox version?

Please explain the problem in detail. What happens? Error messages?


Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

What's your computer system and Firefox version? Please explain the problem in detail. What happens? Error messages? ------------------ Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ '''Do Not''' remove the profiles folder. Look for, and rename any '''Mozilla''' or '''Firefox''' program folders by adding '''.old''' to them. Do not rename the '''Mozilla Thunderbird''' folder if there is one. After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

If you are using Windows XP,

As of Firefox 53 in March 2017, WinXP and Vista won't be supported any longer. http://www.ghacks.net/2016/09/27/firefox-53-no-support-for-windows-xp-or-vista/

https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista?cache=no

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

If you are using Windows XP, As of Firefox 53 in March 2017, WinXP and Vista won't be supported any longer. http://www.ghacks.net/2016/09/27/firefox-53-no-support-for-windows-xp-or-vista/ https://support.mozilla.org/en-US/kb/end-support-windows-xp-and-vista?cache=no [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Người tạo câu hỏi

I use Windows XP and had a recent version of FIrefox working perfectly OK until this happened. I cannot run the reinstall program because it tells me Firefox is open and I need to close it though there are NO ERROR MESSAGES to confirm this. All I get when I click on the Firefox icon is the hourglass for a few seconds and then NOTHING. Chrome works fine, but I much prefer Firefox, which had all my bookmarks.

I use Windows XP and had a recent version of FIrefox working perfectly OK until this happened. I cannot run the reinstall program because it tells me Firefox is open and I need to close it though there are NO ERROR MESSAGES to confirm this. All I get when I click on the Firefox icon is the hourglass for a few seconds and then NOTHING. Chrome works fine, but I much prefer Firefox, which had all my bookmarks.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

Reboot the computer, then run the installer.

Reboot the computer, then run the installer.

Người tạo câu hỏi

Exactly the same result, hourglass runs for a few seconds, then nothing. If I look at the task manager it tells me there are no applications running, and the only relevant process is firefox.exe.

Exactly the same result, hourglass runs for a few seconds, then nothing. If I look at the task manager it tells me there are no applications running, and the only relevant process is firefox.exe.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

Start your Computer in safe mode. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Người tạo câu hỏi

Firefox opened in safe mode (thank you for the link to Linux on how to do this - you assumed correctly that I am computer illiterate) but when I restarted in normal mode the problem was exactly the same.

Firefox opened in safe mode (thank you for the link to Linux on how to do this - you assumed correctly that I am computer illiterate) but when I restarted in normal mode the problem was exactly the same.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Người tạo câu hỏi

According to Firefox I have only 2 extensions, both of which have been deactivated as incompatible with Firefox. All the addons have "ask to activate/always activate/never activate" as options and all are set to ask to activate.

I am having to reboot every time, switching from normal to safe mode, as safe has no internet connection

According to Firefox I have only 2 extensions, both of which have been deactivated as incompatible with Firefox. All the addons have "ask to activate/always activate/never activate" as options and all are set to ask to activate. I am having to reboot every time, switching from normal to safe mode, as safe has no internet connection
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Người tạo câu hỏi

I can only open Firefox in safe mode

When I open the options menu under general are options for scrolling and under advanced are selecting home page. Nothing about display.

I am having to close the computer and restart every time, switching from safe to normal, as only in normal can I open email, using a horrible clunky version of Chrome.

I suspect because I can only view the internet in normal, and open Firefox in safe that most of he information you require is not displayed. I am at the point of giving up and looking for another browser.

I can only open Firefox in safe mode When I open the options menu under general are options for scrolling and under advanced are selecting home page. Nothing about display. I am having to close the computer and restart every time, switching from safe to normal, as only in normal can I open email, using a horrible clunky version of Chrome. I suspect because I can only view the internet in normal, and open Firefox in safe that most of he information you require is not displayed. I am at the point of giving up and looking for another browser.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

I called for more help.

Start the Computer in Safe Mode. Open the Programs Folder and remove the Mozilla and Firefox folders.

Windows: C:\Program Files C:\Program Files (x86)

After, reboot the computer.

I called for more help. Start the '''Computer''' in '''Safe Mode.''' Open the '''Programs Folder''' and remove the '''Mozilla''' and '''Firefox''' folders. Windows: C:\Program Files C:\Program Files (x86) After, reboot the computer.

Người tạo câu hỏi

Done that. Now do I download Firefox or what? This presupposes that the problem was something in the (now deleted) old FIrefox

Done that. Now do I download Firefox or what? This presupposes that the problem was something in the (now deleted) old FIrefox
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

Now install Firefox. If it works, great.

If there is still a problem,

Use these links to create a new profile. Use this new profile as is. Is the problem still there?

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible


Type about:profiles<enter> in the address bar.

Now install Firefox. If it works, great. If there is still a problem, Use these links to create a new profile. Use this new profile '''as is. ''' Is the problem still there? http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible Type '''about:profiles'''<enter> in the address bar.

Người tạo câu hỏi

This is all too much for a bear of very little brain. I could not even find "windows login" in Documents and settings!

This is all too much for a bear of very little brain. I could not even find "windows login" in Documents and settings!
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

farang9 said

I could not even find "windows login" in Documents and settings!

Windows login is when you log onto Windows.

Have you reinstalled Firefox? What happens?

''farang9 [[#answer-1008180|said]]'' <blockquote> I could not even find "windows login" in Documents and settings! </blockquote> Windows login is when you log onto Windows. Have you reinstalled Firefox? What happens?

Người tạo câu hỏi

Exactly the same as before - hourglass runs for a few seconds, then nothing. If I use WIndows task manager to check processes it shows firefox.exe is running, but that's all.

Exactly the same as before - hourglass runs for a few seconds, then nothing. If I use WIndows task manager to check processes it shows firefox.exe is running, but that's all.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59583 câu trả lời
Được đăng

I'm out of ideas.

I'm out of ideas.

Người tạo câu hỏi

Sadly I have uninstalled Firefox and am running Opera instead. Lost all my bookmarks, so it will be "fun" trying to remember them. Google search will be working overtime!

Sadly I have uninstalled Firefox and am running Opera instead. Lost all my bookmarks, so it will be "fun" trying to remember them. Google search will be working overtime!
smorele 44 giải pháp 310 câu trả lời
Được đăng

It may be related to your profile. Can you try to manage your data as exlained in this page and then reinstall Firefox ?

It may be related to your profile. Can you try to manage your data as exlained [https://support.mozilla.org/en-US/kb/firefox-already-running-not-responding in this page] and then reinstall Firefox ?