Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox v 55.0 crashes my tabs upon loading a video

  • 11 trả lời
  • 4 gặp vấn đề này
  • 268 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

Alright, so first the story, then the specifics.

Story: I updated to Firefox 55.0 a few weeks ago, presumably when it came out, as I had auto-updates enabled. Immediately after doing so, the large majority of videos would crash my tab. I'd get what I can only assume is the standard message of "Gah, My tab crashed!" etc. Anyways, I did some digging around, these forums and others, none of the solutions worked. I settled for the quick n dirty solution, and rolled back to firefox 54.0, which worked fine. Until today. Today, 54.0 was experiencing the issue as well, so I naturally decided to try 55.0 - which didn't work either. That leaves me where I'm at now.

Specific details: Tabs crash upon trying to load a video, presumably of a different format. It crashes occasionally on youtube videos, but is for the most part OK with them. Scrolling through a facebook feed however, will give you videos from lots of different sources, and I can reliably crash my tab within 10s if I load up facebook and just scroll down.

Potential fixes I have tried (of which, none solved my issue):

  • Going into About:config and changing the browser.tabs.autorestart and browser.tabs.autorestart2 both to be false. This is following the recommendation of another thread, given to a different user with a similar problem, found here: ( https://support.mozilla.org/en-US/questions/1159697 ).
  • Booting the browser up into safe mode
  • Updating any/all drivers. Specifically I can for sure, without a doubt, say that my gfx card drivers are up to date.
  • Creating a new firefox profile, and using it instead.

At this point the only thing that comes to mind is the idea that the plugin loading these videos isn't working correctly? But is it even a plugin?

Worth noting, if I change the about:config file pieces I listed above to both be false, instead of crashing a tab it will crash the entire browser. A crash report of that specific incident can be found using bp-92e3bbb7-9388-4412-9573-504010170905 .

The normal issue happening can be found using bp-a8e33356-c344-4159-889b-b330a0170905 .

Thank you for any/all help you can provide.

Giải pháp được chọn

I don't know enough about the problem. I called for more help.

Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (11)

more options

Many users are reporting video crashes.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

Unfortunately that did not solve my issue.

I tried: Disabling hardware acceleration, as per your prompt. Following it up by restarting firefox. --No dice.

I then tried: Uninstalling flash player. It still crashes, even with flash player uninstalled (I confirmed using Adobe's tools that flash player was indeed uninstalled correctly).

I then: Reinstalled the newest version of flash player. Still crashes.

I then re-disabled hardware acceleration per your suggestion (I reinstalled, so it turned back on). I then rebooted my PC. Still crashes.

If it helps, I pinpointed a specific video that demonstrates a crash: https://www.facebook.com/PowerliftingMotivation/videos/1413489915387367/ However, I couldn't pinpoint *what* was being used to actually play the video. All I know is it crashes firefox, but not chrome. Loading that page specifically is fine, but if I hit play on the video, then the firefox tab crashes.

Được chỉnh sửa bởi Juicearific vào

more options

The player does not identify itself.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

more options

Safe mode did not solve the problem. I followed up safe mode by changing both of the browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 to false (both were true in safe mode). This did not solve the problem. I rebooted firefox in safe mode (again). Problem still occurs. I tried in normal mode, just to see. By default browser.tabs.remote.autostart is set to false, but browser.tabs.remote.autostart.2 is set to true. I changed then both to false. Problem still occurs.

Worth noting that any time I disabled browser.tabs.remote.autostart and browser.tabs.remote.autostart.2, instead of a tab crashing all of firefox crashes.

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx29

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

more options

bp-c07ce3c9-2c10-45e9-8086-f7a320170906 9/5/2017 5:49 PM bp-09c51b95-f22b-4fa9-9983-140230170906 9/5/2017 5:49 PM bp-8f8e4cb1-8e6a-4f66-a83b-4a5660170906 9/5/2017 5:49 PM bp-1a0241fe-8a69-48cf-a099-782a30170906 9/5/2017 5:48 PM bp-4427faff-d03e-4d71-a829-d3cbc0170906 9/5/2017 5:48 PM bp-a7b1c946-ee7a-4647-9c21-fb5ce0170906 9/5/2017 5:48 PM bp-9295ae88-0f1e-48a0-a216-f991b0170906 9/5/2017 5:48 PM bp-ca90db29-fed7-42f9-8a22-c2d820170906 9/5/2017 5:48 PM bp-a3105e61-6240-486b-84fd-a51f70170906 9/5/2017 5:48 PM bp-76f001fd-ee64-444a-888a-3dd7a0170906 9/5/2017 5:48 PM bp-a8e33356-c344-4159-889b-b330a0170905 9/4/2017 9:05 PM bp-92e3bbb7-9388-4412-9573-504010170905 9/4/2017 6:20 PM

Many weren't submitted before (some were). They're all submitted now.

more options

bp-c07ce3c9-2c10-45e9-8086-f7a320170906 Signature: nvwgf2um.dll | BaseThreadInitThunk

Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation

This is for Sumo's Related Bugs 1310600 RESOLVED FIXED Spike in crashes with Nvidia driver DLLs in Firefox 50

1292273 REOPENED --- Crash in nvwgf2um.dll | BaseThreadInitThunk


The NVIDIA Drivers have been causing problems of late.

more options

I am currently running NVidia driver 385.41 (which my software assures me is up to date). I can try rolling back, but before I do I was wondering if you have a specific version you know has been working? If you do I can roll back to it.

Được chỉnh sửa bởi Juicearific vào

more options

Giải pháp được chọn

I don't know enough about the problem. I called for more help.

Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

I tried a few different versions of the NVidia drivers to find that they all have the issue, so it must be with the way firefox interfaces with the graphics software. I'll sit on Chrome for a bit until the next update hits. Thanks for your help, FredMcD.

--P.S. when I had tried 54.0 before it worked, but eventually it fell under this problem too. I'm like 98% sure I checked and it was still 54, but maybe I somehow accidentally told it to update (I had disabled them). Regardless, for anyone else that sees the thread, it *should* work. Just remember older versions means more security vulnerabilities.

I'll use Chrome and hope the next version comes soon.

more options

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Also turn off Use a background service to install updates