X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Stream video loads CPU

Được đăng

What has happened with Mozilla? A month ago, there were no problems when watching stream video 1080p 60fps. But now it is impossible to do it: constant and long freezes. I have noticed that CPU load is almost 100% when watching stream. I have recorded the system parameters for 10 minutes for the same stream via Mozilla and Edge and the difference is great (see the attached files). I do not know what parameters were a month ago for Mozilla but definitely I never noticed any problems. Hope this info will be helpful to fix the problem.

What has happened with Mozilla? A month ago, there were no problems when watching stream video 1080p 60fps. But now it is impossible to do it: constant and long freezes. I have noticed that CPU load is almost 100% when watching stream. I have recorded the system parameters for 10 minutes for the same stream via Mozilla and Edge and the difference is great (see the attached files). I do not know what parameters were a month ago for Mozilla but definitely I never noticed any problems. Hope this info will be helpful to fix the problem.
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

It has happened to solve the problem easily! Sometimes you must ask a simplier question to start solving the problem. Q: “When a stream video was watched without problems the last time?” A: “At the end of July.” Q: “What changes to Firefox has taken place since?” A: “A new version Firefox 55 has been released.” Q: “Are there any changes affecting performance in Firefox 55?” A: “Sure. Option to set/modify the number of concurrent content processes for faster page loading and more responsive tab switching is added.” I do not know how it affects a PC performance when streaming video, but I have just marked “Use recommended performance settings”, reset Firefox and everything went smoothly (see the attached file). Surely, I tried to switch off this parameter again but the problems with video streaming has not come back. I tried to set different “Content process limit” number but every time Firefox continued to work perfectly. Maybe it was some bug and I triggered it by marking “Use recommended performance settings”. I do not know exactly. Anyway, I may continue to enjoy Firefox. Thanks to all the developers!

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Firefox 55.0.3
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/55.0.3/WINNT/ru/

Tiện ích mở rộng

  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: NVIDIA GeForce GTX 980
  • adapterDescription2:
  • adapterDeviceID: 0x13c0
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 4096
  • adapterRAM2:
  • adapterSubsysID: 36851458
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.413
  • driverDate: 5-1-2017
  • driverDate2:
  • driverVersion: 22.21.13.8205
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Not using GPU Process since D3D11 is unavailable', u'type': u'env'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 980 Direct3D9Ex vs_3_0 ps_3_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000b80f) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
FredMcD
  • Top 10 Contributor
4246 giải pháp 59404 câu trả lời
Được đăng

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Người tạo câu hỏi

In Safe Mode it is even worth. When not in Safe Mode, only video freezes while audio continues with no video load symbol – a spinning ring in the centre of the player. When in Safe Mode, all sticks, a video load symbol appears for a much longer time just as very slow internet. But there is no problem with internet speed. It is 25 Mb/sec. And when again not in Safe Mode, everything reverts to the discussed problem. And the other browser confirms that internet connection is not the matter.

In Safe Mode it is even worth. When not in Safe Mode, only video freezes while audio continues with no video load symbol – a spinning ring in the centre of the player. When in Safe Mode, all sticks, a video load symbol appears for a much longer time just as very slow internet. But there is no problem with internet speed. It is 25 Mb/sec. And when again not in Safe Mode, everything reverts to the discussed problem. And the other browser confirms that internet connection is not the matter.
FredMcD
  • Top 10 Contributor
4246 giải pháp 59404 câu trả lời
Được đăng
See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Người tạo câu hỏi

We are not trying to solve the problem with the latest VR game. It is just a stream video. I use NVIDIA drivers dated the 1st of May 2017. I believe neither NVIDIA nor AMD optimize their drivers for different browsers. I think it is evident that graphics drivers are not the reason of the problem. Please do not try to solve the issue as if I am the only person who has encountered the problem. Find some HD stream, for an example, on Twitch, record your system parameters, try another browser. If there is no difference on your system then it is my personal problem. I compare Firefox with another browser only because I have no Firefox stream video parameters dated a month and a half ago, because Edge is the only browser I have besides Firefox and because it streams video with no problems just as Firefox did before. But I must attract your attention that I have i7-6700K locked at 1,600 MHz and GeForce GTX 980 GPU locked at 178/279 MHz. Let us consider it as a simulation of a computer with lower performance which was able to stream video via Firefox a month and a half ago but not anymore. Any problem is much more evident on such a computer. If you have overclocked i9-7900X, probably you will not notice any difference. And please do not propose to unlock the hardware.

We are not trying to solve the problem with the latest VR game. It is just a stream video. I use NVIDIA drivers dated the 1st of May 2017. I believe neither NVIDIA nor AMD optimize their drivers for different browsers. I think it is evident that graphics drivers are not the reason of the problem. Please do not try to solve the issue as if I am the only person who has encountered the problem. Find some HD stream, for an example, on Twitch, record your system parameters, try another browser. If there is no difference on your system then it is my personal problem. I compare Firefox with another browser only because I have no Firefox stream video parameters dated a month and a half ago, because Edge is the only browser I have besides Firefox and because it streams video with no problems just as Firefox did before. But I must attract your attention that I have i7-6700K locked at 1,600 MHz and GeForce GTX 980 GPU locked at 178/279 MHz. Let us consider it as a simulation of a computer with lower performance which was able to stream video via Firefox a month and a half ago but not anymore. Any problem is much more evident on such a computer. If you have overclocked i9-7900X, probably you will not notice any difference. And please do not propose to unlock the hardware.

Được chỉnh sửa bởi Aleksei vào

cor-el
  • Top 10 Contributor
  • Moderator
17475 giải pháp 157940 câu trả lời
Được đăng

Try to set this pref to false on the about:config page.

  • media.windows-media-foundation.allow-d3d11-dxva = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Try to set this pref to false on the <b>about:config</b> page. *media.windows-media-foundation.allow-d3d11-dxva = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Giải pháp được chọn

It has happened to solve the problem easily! Sometimes you must ask a simplier question to start solving the problem. Q: “When a stream video was watched without problems the last time?” A: “At the end of July.” Q: “What changes to Firefox has taken place since?” A: “A new version Firefox 55 has been released.” Q: “Are there any changes affecting performance in Firefox 55?” A: “Sure. Option to set/modify the number of concurrent content processes for faster page loading and more responsive tab switching is added.” I do not know how it affects a PC performance when streaming video, but I have just marked “Use recommended performance settings”, reset Firefox and everything went smoothly (see the attached file). Surely, I tried to switch off this parameter again but the problems with video streaming has not come back. I tried to set different “Content process limit” number but every time Firefox continued to work perfectly. Maybe it was some bug and I triggered it by marking “Use recommended performance settings”. I do not know exactly. Anyway, I may continue to enjoy Firefox. Thanks to all the developers!

It has happened to solve the problem easily! Sometimes you must ask a simplier question to start solving the problem. Q: “When a stream video was watched without problems the last time?” A: “At the end of July.” Q: “What changes to Firefox has taken place since?” A: “A new version Firefox 55 has been released.” Q: “Are there any changes affecting performance in Firefox 55?” A: “Sure. Option to set/modify the number of concurrent content processes for faster page loading and more responsive tab switching is added.” I do not know how it affects a PC performance when streaming video, but I have just marked “Use recommended performance settings”, reset Firefox and everything went smoothly (see the attached file). Surely, I tried to switch off this parameter again but the problems with video streaming has not come back. I tried to set different “Content process limit” number but every time Firefox continued to work perfectly. Maybe it was some bug and I triggered it by marking “Use recommended performance settings”. I do not know exactly. Anyway, I may continue to enjoy Firefox. Thanks to all the developers!
FredMcD
  • Top 10 Contributor
4246 giải pháp 59404 câu trả lời
Được đăng

That was very good work. Well done. .

That was very good work. Well done. .