X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

I can't make Firefox my default browser

Được đăng

Recently I installed Chrome, and made it my default browser. I had intended it to be temporary, but now I can't change it back to Firefox. If go to the general settings and click "Make Default," it doesn't change anything - still says "Firefox is not your default browser."

I used to go back and forth between Firefox and IE, no problem. Could Chrome be causing this?

Thanks.

Recently I installed Chrome, and made it my default browser. I had intended it to be temporary, but now I can't change it back to Firefox. If go to the general settings and click "Make Default," it doesn't change anything - still says "Firefox is not your default browser." I used to go back and forth between Firefox and IE, no problem. Could Chrome be causing this? Thanks.

Giải pháp được chọn

Try to reinstall Firefox to see if that allows to set Firefox as the default browser.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 26.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4269 giải pháp 59864 câu trả lời
Được đăng

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Open Windows Internet Explorer. Have it declared as the default browser, But turn off the option to check this when the browser opens (If you want).

Now do the same thing using Firefox.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. ------------------ Open Windows Internet Explorer. Have it declared as the default browser, But turn off the option to check this when the browser opens (If you want). Now do the same thing using Firefox.

Người tạo câu hỏi

Hi, I tried doing this - made IE the default, and turned off checking in IE. Then restarted Firefox and tried to do the same, but when I click "Make default" it automatically checks the "Always check if Firefox is your default browser" box, and it still says "Firefox is not your default browser."

I'm not familiar with programs like Advanced System Care. (That one in particular is not on my computer.) What other ones are there, or is there a place I can find a list of the most common ones? What would you call this type of software - "surfing protection"?

One thing that might be relevant is that I recently found the i-beta malware on my system. I ran a malware-cleanup program (Malwarebytes' "Adwcleaner") which got rid of i-beta, but might not have undone all the damage. So that might be part of the problem, although I seem to have had i-beta for quite a while, and only when I installed Chrome about 10 days ago did I start having problems with the FF default browser issue. I have uninstalled Chrome, but the problem is still there.

Thanks for any more suggestions you might have.

Hi, I tried doing this - made IE the default, and turned off checking in IE. Then restarted Firefox and tried to do the same, but when I click "Make default" it automatically checks the "Always check if Firefox is your default browser" box, and it still says "Firefox is not your default browser." I'm not familiar with programs like Advanced System Care. (That one in particular is not on my computer.) What other ones are there, or is there a place I can find a list of the most common ones? What would you call this type of software - "surfing protection"? One thing that might be relevant is that I recently found the i-beta malware on my system. I ran a malware-cleanup program (Malwarebytes' "Adwcleaner") which got rid of i-beta, but might not have undone all the damage. So that might be part of the problem, although I seem to have had i-beta for quite a while, and only when I installed Chrome about 10 days ago did I start having problems with the FF default browser issue. I have uninstalled Chrome, but the problem is still there. Thanks for any more suggestions you might have.
FredMcD
  • Top 10 Contributor
4269 giải pháp 59864 câu trả lời
Được đăng

Start your Computer in safe mode. Then start Firefox. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode. Then start Firefox. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Người tạo câu hỏi

I started Windows in safe mode, opened Firefox, and the problem is still there.

I started Windows in safe mode, opened Firefox, and the problem is still there.
FredMcD
  • Top 10 Contributor
4269 giải pháp 59864 câu trả lời
Được đăng

Câu trả lời hữu ích

I called for more help.

I called for more help.
cor-el
  • Top 10 Contributor
  • Moderator
17575 giải pháp 158975 câu trả lời
Được đăng

Giải pháp được chọn

Try to reinstall Firefox to see if that allows to set Firefox as the default browser.

Try to reinstall Firefox to see if that allows to set Firefox as the default browser. *download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ *start the installation with a double-click on the desktop icon

Người tạo câu hỏi

Seems to be back to normal now, thank you!!

Seems to be back to normal now, thank you!!
dexrek 3 giải pháp 39 câu trả lời
Được đăng

cor-el said

Try to reinstall Firefox to see if that allows to set Firefox as the default browser.

Would I have to uninstall the existing Firefox or do this install on top of the existing program.?

''cor-el [[#answer-984840|said]]'' <blockquote> Try to reinstall Firefox to see if that allows to set Firefox as the default browser. *download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ *start the installation with a double-click on the desktop icon </blockquote> Would I have to uninstall the existing Firefox or do this install on top of the existing program.?
FredMcD
  • Top 10 Contributor
4269 giải pháp 59864 câu trả lời
Được đăng

If you have no other problems, you can install on top.

If you have no other problems, you can install on top.
dexrek 3 giải pháp 39 câu trả lời
Được đăng

That did it Thanks. It needs to be noted that Firefox does not like Chrome. My problem started from a download and I missed that it installs Chrome as well.

That did it Thanks. It needs to be noted that Firefox does not like Chrome. My problem started from a download and I missed that it installs Chrome as well.

Được chỉnh sửa bởi dexrek vào

pslane 0 giải pháp 2 câu trả lời
Được đăng

I have this same problem. I go back and forth between IE and Firefox and just lately I noticed the Firefox default button will not work. I have tried the tips advised on this thread but just opened Firefox after re-installing and it's the same thing. The default button is inactive. What else can I do?

I have this same problem. I go back and forth between IE and Firefox and just lately I noticed the Firefox default button will not work. I have tried the tips advised on this thread but just opened Firefox after re-installing and it's the same thing. The default button is inactive. What else can I do?
dexrek 3 giải pháp 39 câu trả lời
Được đăng

I used the reinstall method as you can see above but one thing that was not completely obvious is that at the start of my trouble shooting I removed Chrome from the computer. Also, the re-installing has to be done from the desktop. Like you I tried other re-load options that didn't work. Good luck.

I used the reinstall method as you can see above but one thing that was not completely obvious is that at the start of my trouble shooting I removed Chrome from the computer. Also, the re-installing has to be done from the desktop. Like you I tried other re-load options that didn't work. Good luck.
FredMcD
  • Top 10 Contributor
4269 giải pháp 59864 câu trả lời
Được đăng

pslane https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

'''pslane''' https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
pslane 0 giải pháp 2 câu trả lời
Được đăng

I followed the directions from the provided link and uninstalled Firefox, then re-installed it. It is now the default, but when opening a URL link in my email, I get this;

The main thing I wanted to do was have my links open with FF. This is getting very annoying. So I'm still in the same boat!

I followed the directions from the provided link and uninstalled Firefox, then re-installed it. It is now the default, but when opening a URL link in my email, I get this; The main thing I wanted to do was have my links open with FF. This is getting very annoying. So I'm still in the same boat!
cor-el
  • Top 10 Contributor
  • Moderator
17575 giải pháp 158975 câu trả lời
Được đăng
See: *https://support.microsoft.com/en-us/help/310049/hyperlinks-are-not-working-in-outlook