X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Chủ đề này đã đóng và được lưu lại. Vui lòng hỏi một câu hỏi mới nếu bạn cần giúp đỡ.

Within minutes [sometimes seconds], Firefox starts using more and more cpu time - up to 95% or more. We have no viruses or other malicious programs running.

Được đăng

I have run multiple virus checkers, cleared caches and cookies, checked for other malware, adware, keyloggers, and have not found anything malicious at all.

Rebooting doesn't stop the CPU hogging. In fact, if you kill Firefox in Task Manager, and the click on "Restore Previous Session", a lot of the time it immediately starts hogging the CPU. Sometimes even with only ONE open tab. Why can't you give us control over active content on a page by page [tab] basis? The universal shut off all active content is NOT a good solution.

Can you not keep active content on a page locked until the user decides to play it [and only have the top tab content be allowed to be active]? Maybe have a specific icon indicating an item wants to run. It's bad enough when the audio from an ad starts playing over the music you were listening to, but this resource hogging, lockup situation has gotten out of hand.

Running all active content on all pages does nothing but diminish the experience for users.

Firefox is my preferred browser, but at this point it runs slower than Explorer, which is beyond sad. It does appear now to have one big similarity to Explorer -- you have been throwing so many patches at it that you have degraded the performance of the program by many orders of magnitude. Some of these patches are probably like Explorer's too -- fixing a problem with a patch that creates other problems that need to be patched which creates other issues, etc, etc, etc.

When I first started using Firefox, it was head and shoulders better than the other browsers. Then you introduced the "plug in container" that really tied resources up -- and still does now from time to time, on top of the other resource hogging. Now you have two instances of Firefox running in Task Manager and both instances want to grab as much CPU time as possible - and in between them they get all available time.

At the very least, give us a way to find and kill off the particular script that is eating the CPU time.

In case you need some system info from us, we are running Windows 7, have a 64bit operating system using an Intel Duo processor at 2.8Ghz, with 4.0Gb RAM.

Any help on how to resolve this would be welcome.

I have run multiple virus checkers, cleared caches and cookies, checked for other malware, adware, keyloggers, and have not found anything malicious at all. Rebooting doesn't stop the CPU hogging. In fact, if you kill Firefox in Task Manager, and the click on "Restore Previous Session", a lot of the time it immediately starts hogging the CPU. Sometimes even with only ONE open tab. Why can't you give us control over active content on a page by page [tab] basis? The universal shut off all active content is NOT a good solution. Can you not keep active content on a page locked until the user decides to play it [and only have the top tab content be allowed to be active]? Maybe have a specific icon indicating an item wants to run. It's bad enough when the audio from an ad starts playing over the music you were listening to, but this resource hogging, lockup situation has gotten out of hand. Running all active content on all pages does nothing but diminish the experience for users. Firefox is my preferred browser, but at this point it runs slower than Explorer, which is beyond sad. It does appear now to have one big similarity to Explorer -- you have been throwing so many patches at it that you have degraded the performance of the program by many orders of magnitude. Some of these patches are probably like Explorer's too -- fixing a problem with a patch that creates other problems that need to be patched which creates other issues, etc, etc, etc. When I first started using Firefox, it was head and shoulders better than the other browsers. Then you introduced the "plug in container" that really tied resources up -- and still does now from time to time, on top of the other resource hogging. Now you have two instances of Firefox running in Task Manager and both instances want to grab as much CPU time as possible - and in between them they get all available time. At the very least, give us a way to find and kill off the particular script that is eating the CPU time. In case you need some system info from us, we are running Windows 7, have a 64bit operating system using an Intel Duo processor at 2.8Ghz, with 4.0Gb RAM. Any help on how to resolve this would be welcome.

Được chỉnh sửa bởi Noah_SUMO vào

Giải pháp được chọn

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Thông tin chi tiết

Tonnes
  • Locale Leader
246 giải pháp 1454 câu trả lời
Được đăng

Hello,

That’s a lot of questions, out of which some of them can be answered by "oh, but you can". However, the formatting is a bit bad so could you please edit your message for better readability, also for others? I can understand the frustration but please clearly state your questions - we could answer them later.

With regards to the biggest issue (and a quick solution), which is probably performance, I suggest you create a new profile first as explained here, or by simply adding -p to your existing startup shortcut, or by entering about:profiles in the location bar (which is similar to clicking that link in Help > Troubleshooting Information) and pressing the Create a New Profile button, and following the steps. Since the Launch profile in new browser button you see there does not work in release versions yet as far as I'm aware, restart Firefox and make sure the new profile is used by selecting it in the profile selection dialog that should appear. Then make sure all is well (and enjoy its speed for a bit, if all seems fine) and copy all important files from the old profile folder as described in this article when Firefox is closed. I would advise to do so one by one and make sure everything works as expected by starting Firefox in between each copy step.

Given that you have been using Firefox for so long, I think these steps will be no problem for you but report back if they will.

I would also strongly advise not to upgrade Firefox to 53 yet, but make sure all is working well first.

Hello, That’s a lot of questions, out of which some of them can be answered by "oh, but you can". However, the formatting is a bit bad so could you please edit your message for better readability, also for others? I can understand the frustration but please clearly state your questions - we could answer them later. With regards to the biggest issue (and a quick solution), which is probably performance, I suggest you create a new profile first as explained [[Use the Profile Manager to create and remove Firefox profiles|here]], or by simply adding ''-p'' to your existing startup shortcut, or by entering ''about:profiles'' in the location bar (which is similar to clicking that link in Help > Troubleshooting Information) and pressing the Create a New Profile button, and following the steps. Since the Launch profile in new browser button you see there does not work in release versions yet as far as I'm aware, restart Firefox and make sure the new profile is used by selecting it in the profile selection dialog that should appear. Then make sure all is well (and enjoy its speed for a bit, if all seems fine) and copy all important files from the old profile folder as described in [[Recovering important data from an old profile|this article]] when Firefox is closed. I would advise to do so one by one and make sure everything works as expected by starting Firefox in between each copy step. Given that you have been using Firefox for so long, I think these steps will be no problem for you but report back if they will. I would also strongly advise not to upgrade Firefox to 53 yet, but make sure all is working well first.
FredMcD
  • Top 10 Contributor
4248 giải pháp 59425 câu trả lời
Được đăng

Giải pháp được chọn

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------ Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 157978 câu trả lời
Được đăng

Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile to test if your current profile is causing the problem.


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release. *download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software. *do NOT remove "personal data" when you uninstall the current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *it is important to delete the Firefox program folder to remove all the files and make sure there are no problems with files that were leftover after uninstalling *http://kb.mozillazine.org/Uninstalling_Firefox Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then create a new profile to test if your current profile is causing the problem. <hr> *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Người tạo câu hỏi

FredMcD & cor-el, I have been having this issue across multiple versions of Firefox. Rather than straight updating, I uninstalled Firefox and did a clean install of the latest version. And yes, after uninstalling the old version, I made sure to root out and delete any other Firefox/Mozilla folders and files that I could find, before I installed the latest version. I did backup my history and bookmarks before doing the uninstall of the older version.

Fred, there is no memory hogging in safe mode but I didn't try safe mode with networking as I don't care to go online in safe mode.

Once in a great while, when Firefox freezes up [seems to anyway, when it has better than 90% of CPU time], a message will come up saying a script is waiting for a response -- but NO indication whatsoever what script or page or tab -- not one little shred of information to help determine anything about the offending script. Is it a Java-script that is the problem? If there is a way to find that out, I would love to know -- it would be much better to close an offending page than to have to kill Firefox in Task Manager. I have toggled those tab settings in about:config [making sure to record which ones I changed], and will see if that keeps it from hogging the resources. Thank you both for your helpful suggestions.

<!-- Tonnes --- Wow you think a lot of yourself. You're the only one that does. Your comment "However, the formatting is a bit bad so could you please edit your message for better readability, also for others?" is less than helpful. I hit "return" after every paragraph but when I submitted it, the system automatically dropped those returns and ran it all together as one sentence. I edited, using the underscore to help separate the pieces to try and make it more readable. However, if that is all you are going to focus on, then please don't bother to "help" me as giving me grief about something that I don't have control of, does NOT help in the least little bit. Frankly, look at the run-together mess of your main reply paragraph and cogitate why you do something that you rag on another person for? Then your comment "Given that you have been using Firefox for so long, I think these steps will be no problem for you but report back if they will." Really? You help by making smartmouth, belittling comments? Really? Please don't ever bother "helping" me again, Tonnes since insults and smartmouth comments are NOT helpful. Frankly all it does is give someone a very low opinion of you. ********************************************************************* --> FredMcD & cor-el, I have been having this issue across multiple versions of Firefox. Rather than straight updating, I uninstalled Firefox and did a clean install of the latest version. And yes, after uninstalling the old version, I made sure to root out and delete any other Firefox/Mozilla folders and files that I could find, before I installed the latest version. I did backup my history and bookmarks before doing the uninstall of the older version. Fred, there is no memory hogging in safe mode but I didn't try safe mode with networking as I don't care to go online in safe mode. Once in a great while, when Firefox freezes up [seems to anyway, when it has better than 90% of CPU time], a message will come up saying a script is waiting for a response -- but NO indication whatsoever what script or page or tab -- not one little shred of information to help determine anything about the offending script. Is it a Java-script that is the problem? If there is a way to find that out, I would love to know -- it would be much better to close an offending page than to have to kill Firefox in Task Manager. I have toggled those tab settings in about:config [making sure to record which ones I changed], and will see if that keeps it from hogging the resources. Thank you both for your helpful suggestions.

Được chỉnh sửa bởi Noah_SUMO vào

rhhardin 0 giải pháp 35 câu trả lời
Được đăng

If you're running AdBlock plus, try disabling it; install ublock origin for ad suppression (you can keep both but enable only one).

Adblock plus has gotten extremely hoggy recently.

If you're running AdBlock plus, try disabling it; install ublock origin for ad suppression (you can keep both but enable only one). Adblock plus has gotten extremely hoggy recently.
FredMcD
  • Top 10 Contributor
4248 giải pháp 59425 câu trả lời
Được đăng

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Người tạo câu hỏi

FredMcD, it didn't gobble the resources in safe mode but after toggling those tab related items in about:config, Firefox seems to have stopped the hogging CPU time for the moment. I am very optimistic as this is the longest Firefox has run without consuming all the CPU time and I haven't have any problems with the sites I visit. Thank you very much for your suggestions, FredMcD. This is great.

cor-el, thank you as well. I appreciate the information related to the uninstall. Turns out I may not have found and deleted all old version files when I did the uninstall. Now I have this info backed up in my tips folder in case there is a next time for me to have to do it.

rhhardin, I didn't have that program but I had wondered about getting it. I may change my mind now. Thanks for the heads-up.

FredMcD, it didn't gobble the resources in safe mode but after toggling those tab related items in about:config, Firefox seems to have stopped the hogging CPU time for the moment. I am very optimistic as this is the longest Firefox has run without consuming all the CPU time and I haven't have any problems with the sites I visit. Thank you very much for your suggestions, FredMcD. This is great. cor-el, thank you as well. I appreciate the information related to the uninstall. Turns out I may not have found and deleted all old version files when I did the uninstall. Now I have this info backed up in my tips folder in case there is a next time for me to have to do it. rhhardin, I didn't have that program but I had wondered about getting it. I may change my mind now. Thanks for the heads-up.

Được chỉnh sửa bởi StopAdobeFlash1 vào

FredMcD
  • Top 10 Contributor
4248 giải pháp 59425 câu trả lời
Được đăng

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.