X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox stalls showing "connecting" after clean re-installation - any help appreciated!

Được đăng

I am running Firefox 52.0.2 under Windows 10 Pro. The PC has two user accounts, and Norton Security, Trusteer Rapport (and others!)

Up until a few days ago, everything was fine. A classic case of nothing had changed and then ….

I had a problem with the Rapport icon "going missing" on the standard user account, and checked the admin account where Firefox didn't launch.

After looking at the wealth of info/FAQ on this website (and trying lots of the options) I am in the position where after reinstalling Firefox (and deleting the profiles etc) it now stalls with “connecting” showing when first launched immediately after installation. If you then go to trouble shooting and Refresh Firefox it then works fine, and any other instances of Firefox launched with the first instance still open also work fine.

However, once these instances are all closed, when you next launch Firefox, it’s back to stalling with the timer going ad infinitum and showing “Connecting”. The close doesn’t work and you have to use the Menu Exit to close Firefox.

I have at various stages, and in multiple instances, uninstalled and reinstalled Firefox, having removed the two accounts profiles, and tried many combinations of restarting in Safe Mode with add-ons disabled (stalls) and Refresh ….. the latter being the only time it works.

Looking at the settings after Refresh, there are no active Extensions - just Logitech SetPoint and Norton Security Toolbar, both of which are disabled. The plug-ins I guess are required by Firefox being Shockwave Flash, Widevine Content Decryption and OpenH264 Video Codec. Appearance is the default theme. Opening the Profile Folder from the Troubleshooting page, shows no Extensions folder.

It’s very frustrating and even worse, although I am a massive fan of Firefox, I’ve had to install Chrome to continue working!

I’m really confused as to what changes between closing the “Refreshed” Firefox, which has set up a new profile, and then ten seconds later starting Firefox and it doesn’t work.

Any help would be much appreciated, as I am far from an expert on this!!! ..... and I want to uninstall Chrome at the earliest opportunity. Many thanks.

I am running Firefox 52.0.2 under Windows 10 Pro. The PC has two user accounts, and Norton Security, Trusteer Rapport (and others!) Up until a few days ago, everything was fine. A classic case of nothing had changed and then …. I had a problem with the Rapport icon "going missing" on the standard user account, and checked the admin account where Firefox didn't launch. After looking at the wealth of info/FAQ on this website (and trying lots of the options) I am in the position where after reinstalling Firefox (and deleting the profiles etc) it now stalls with “connecting” showing when first launched immediately after installation. If you then go to trouble shooting and Refresh Firefox it then works fine, and any other instances of Firefox launched with the first instance still open also work fine. However, once these instances are all closed, when you next launch Firefox, it’s back to stalling with the timer going ad infinitum and showing “Connecting”. The close doesn’t work and you have to use the Menu Exit to close Firefox. I have at various stages, and in multiple instances, uninstalled and reinstalled Firefox, having removed the two accounts profiles, and tried many combinations of restarting in Safe Mode with add-ons disabled (stalls) and Refresh ….. the latter being the only time it works. Looking at the settings after Refresh, there are no active Extensions - just Logitech SetPoint and Norton Security Toolbar, both of which are disabled. The plug-ins I guess are required by Firefox being Shockwave Flash, Widevine Content Decryption and OpenH264 Video Codec. Appearance is the default theme. Opening the Profile Folder from the Troubleshooting page, shows no Extensions folder. It’s very frustrating and even worse, although I am a massive fan of Firefox, I’ve had to install Chrome to continue working! I’m really confused as to what changes between closing the “Refreshed” Firefox, which has set up a new profile, and then ten seconds later starting Firefox and it doesn’t work. Any help would be much appreciated, as I am far from an expert on this!!! ..... and I want to uninstall Chrome at the earliest opportunity. Many thanks.

Giải pháp được chọn

I suspect it's something that's been going around this month: several users with this combination --

Recent Windows 10 update + Norton security + Malwarebytes Premium

-- have reported being unable to connect to any sites and the upper right "X" button not working. After a Refresh, Firefox works normally until it is closed and started again. It appears to be a conflict between Firefox's multiprocess feature and the Malwarebytes Exploit Protection feature.

As a workaround, you can either: (1) turn off Exploit Protection in Malwarebytes (either completely or for Firefox (firefox.exe)), or (2) turn off multiprocess in Firefox.

Multiprocess. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Firefox assess whether your current configuration is compatible during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Could you investigate:

Are you using Multiprocess (e10s)?

Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing problems, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Đọc câu trả lời này trong ngữ cảnh 2

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

The plug-ins I guess are required by Firefox being Shockwave Flash, Widevine Content Decryption and OpenH264 Video Codec.

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Giải pháp được chọn

I suspect it's something that's been going around this month: several users with this combination --

Recent Windows 10 update + Norton security + Malwarebytes Premium

-- have reported being unable to connect to any sites and the upper right "X" button not working. After a Refresh, Firefox works normally until it is closed and started again. It appears to be a conflict between Firefox's multiprocess feature and the Malwarebytes Exploit Protection feature.

As a workaround, you can either: (1) turn off Exploit Protection in Malwarebytes (either completely or for Firefox (firefox.exe)), or (2) turn off multiprocess in Firefox.

Multiprocess. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Firefox assess whether your current configuration is compatible during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Could you investigate:

Are you using Multiprocess (e10s)?

Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing problems, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

<p>I suspect it's something that's been going around this month: several users with this combination --</p> <p>Recent Windows 10 update + Norton security + Malwarebytes Premium</p> <p>-- have reported being unable to connect to any sites and the upper right "X" button not working. After a Refresh, Firefox works normally until it is closed and started again. It appears to be a conflict between Firefox's multiprocess feature and the Malwarebytes Exploit Protection feature.</p> <p>As a workaround, you can either: (1) turn off Exploit Protection in Malwarebytes (either completely or for Firefox (firefox.exe)), or (2) turn off multiprocess in Firefox.</p> <p><em><strong>Multiprocess</strong></em>. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Firefox assess whether your current configuration is compatible during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Could you investigate:</p> <p><em>Are you using Multiprocess (e10s)?</em></p> <p>Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:</p> <ul> <li>"3-bar" menu button &gt; "?" button &gt; Troubleshooting Information</li> <li>(menu bar) Help &gt; Troubleshooting Information</li> <li>type or paste about:support in the address bar and press Enter/Return</li> </ul> <p>In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.</p> <p><em>If you are using e10s:</em></p> <p>To help evaluate whether that feature is causing problems, you could turn it off as follows:</p> <p>(1) In a new tab, type or paste <strong>about:config</strong> in the address bar and press Enter/Return. Click the button promising to be careful.</p> <p>(2) In the search box above the list, type or paste <strong>autos</strong> and pause while the list is filtered</p> <p>(3) Double-click the <strong>browser.tabs.remote.autostart.2</strong> preference to switch the value from true to false</p> <p><em>Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart</em></p> <p>At your next Firefox startup, it should run in the traditional way. Any difference?</p>

Người tạo câu hỏi

Hi, and thank you so much for your detailed reply. Yes, you are correct - I do have Malwarebytes as well (a great product I think!).

I logged on this evening keen to work through your email - only to find out that Firefox 53 had installed itself and all (at least on my PC) now worked fine!

That being said, I did follow through on your notes. I didn't realize you could turn Exploit Protection off for specifics apps, so that is really useful to know.

I had seen a little about Multiprocess, and had noticed the Multiprocess Windows setting, albeit didn't understand what this was. In my case it was "0/1 (Disabled by add-ons)" so it was not using this (which was also the setting prior to 53 install).

Your final notes re: about:config also checked out.

So, once again , very many thanks for your time and help!

One final issue remains though, which is although Firefox is now looking great, the Trusteer Rapport icon still doesn't show, and thus is not enabled. I did notice it appear and become active for a second or two, and then disappeared when Firefox flashed up a message saying something like "checking plug-in compatibility" .... presumably as part of the 53 version upgrade. It has not been seen since.

In Chrome, I noticed Rapport is an add-on, but I am not sure exactly how it integrates with Firefox, and whether we have any control over that? I also don't know whether Rapport supports Firefox 53.

Sorry to be a nuisance, but you don't happen to have any insight or thoughts on this as well?

Kind regards, David

Hi, and '''thank you so much for your detailed reply'''. Yes, you are correct - I do have Malwarebytes as well (a great product I think!). I logged on this evening keen to work through your email - only to find out that Firefox 53 had installed itself and all (at least on my PC) now worked fine! That being said, I did follow through on your notes. I didn't realize you could turn Exploit Protection off for specifics apps, so that is really useful to know. I had seen a little about Multiprocess, and had noticed the Multiprocess Windows setting, albeit didn't understand what this was. In my case it was "0/1 (Disabled by add-ons)" so it was not using this (which was also the setting prior to 53 install). Your final notes re: '''about:config''' also checked out. So, once again , very many thanks for your time and help! One final issue remains though, which is although Firefox is now looking great, '''the Trusteer Rapport icon still doesn't show''', and thus is not enabled. I did notice it appear and become active for a second or two, and then disappeared when Firefox flashed up a message saying something like "checking plug-in compatibility" .... presumably as part of the 53 version upgrade. It has not been seen since. In Chrome, I noticed Rapport is an add-on, but I am not sure exactly how it integrates with Firefox, and whether we have any control over that? I also don't know whether Rapport supports Firefox 53. Sorry to be a nuisance, but you don't happen to have any insight or thoughts on this as well? Kind regards, David
jscher2000
  • Top 10 Contributor
8695 giải pháp 71066 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi David, there was apparently a delay in releasing a version of Trusteer Rapport compatible with Firefox 53. As of right now, they only list Firefox 50-52 as compatible: https://www.trusteer.com/support/supported-platforms

For the time being, I think you may need to do your banking in another browser until they update it. Alternately, you could consider switching to the "Extended Support Release" version of Firefox 52. "ESR" was first developed to meet the needs of large organizations that wanted Firefox to change much more slowly -- it gets security updates but no feature changes for about a year at a time -- but anyone is free to use it.

Note: When you get to the ESR installer list, choose the "Windows" not the "Windows (64-bit)" installer. Trusteer only supports 32-bit Firefox according to their support page.

Hi David, there was apparently a delay in releasing a version of Trusteer Rapport compatible with Firefox 53. As of right now, they only list Firefox 50-52 as compatible: https://www.trusteer.com/support/supported-platforms For the time being, I think you may need to do your banking in another browser until they update it. Alternately, you could consider switching to the "Extended Support Release" version of Firefox 52. "ESR" was first developed to meet the needs of large organizations that wanted Firefox to change much more slowly -- it gets security updates but no feature changes for about a year at a time -- but anyone is free to use it. Note: When you get to [https://www.mozilla.org/firefox/organizations/all/ the ESR installer list], choose the "Windows" not the "Windows (64-bit)" installer. Trusteer only supports 32-bit Firefox according to their support page.

Người tạo câu hỏi

Hi again, and thanks for the further update.

I had wondered about a delay with Trusteer Rapport and Firefox 53, so thanks for the link.

My problem is that having reluctantly installed Chrome because of the original Firefox issues, I then found there is a conflict between Rapport and the Norton Toolbar on Chrome, which Trusteer are also looking into!!

I'll see what Trusteer support say about their update timetables (they seem very helpful) and depending on this may well take up your ESR version - useful to know about this going forward.

With kind regards David

Hi again, and thanks for the further update. I had wondered about a delay with Trusteer Rapport and Firefox 53, so thanks for the link. My problem is that having reluctantly installed Chrome because of the original Firefox issues, I then found there is a conflict between Rapport and the Norton Toolbar on Chrome, which Trusteer are also looking into!! I'll see what Trusteer support say about their update timetables (they seem very helpful) and depending on this may well take up your ESR version - useful to know about this going forward. With kind regards David