X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox scrolling and video laggy when maximized at 4K on KDE Plasma Archlinux

Được đăng

I'm currently using KDE Plasma on Archlinux and Firefox windows are very laggy when maximized. I have a 4K screen and running Firefox at full 4K causes scrolling to be very choppy and makes YouTube almost unresponsive. If I make the window smaller (about a quarter of the screen or the size of typical 1080p), it speeds up and works normally. I've tried the nightly build, Icecat, and Waterfox and none of them have made any difference.

I use a AMD Radeon R9 Fury X GPU and have the latest version of xf86-video-amdgpu installed and have hardware acceleration enabled in Firefox settings.

EDIT: I've now tried Firefox in Cinnamon Desktop as well as KDE Plasma and they are both equally laggy.

I'm currently using KDE Plasma on Archlinux and Firefox windows are very laggy when maximized. I have a 4K screen and running Firefox at full 4K causes scrolling to be very choppy and makes YouTube almost unresponsive. If I make the window smaller (about a quarter of the screen or the size of typical 1080p), it speeds up and works normally. I've tried the nightly build, Icecat, and Waterfox and none of them have made any difference. I use a AMD Radeon R9 Fury X GPU and have the latest version of xf86-video-amdgpu installed and have hardware acceleration enabled in Firefox settings. EDIT: I've now tried Firefox in Cinnamon Desktop as well as KDE Plasma and they are both equally laggy.

Được chỉnh sửa bởi Isvvc vào

Giải pháp được chọn

Setting all of: layers.acceleration.force-enabled webgl.force-enabled media.hardware-video-decoding.force-enabled browser.tabs.remote.autostart to `true` fixed the issues.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Ứng dụng

  • Firefox 52.0.2
  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/52.0.2/Linux/en-US/

Tiện ích mở rộng

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Decentraleyes 1.3.8 (jid1-BoFifL9Vbdl2zQ@jetpack)
  • Instapaper 1.0.2 ({d0210f13-a970-4f1e-8322-0f76ec80adde})
  • Multi-process staged rollout 1.9 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Site Deployment Checker 1.0 (deployment-checker@mozilla.org)
  • The Camelizer - Price Tracker 2.9.2 (izer@camelcamelcamel.com)
  • uBlock Origin 1.12.1 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Zoom Page 15.7 (zoompage@DW-dev)
  • Reverso Translate in Context (beta) 1.1.93 (context@reverso.net) (không hoạt động)
  • uMatrix 0.9.3.6 (uMatrix@raymondhill.net) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: X.Org -- Gallium 0.4 on AMD FIJI (DRM 3.9.0 / 4.10.10-1-ARCH, LLVM 4.0.0)
  • adapterDeviceID: Gallium 0.4 on AMD FIJI (DRM 3.9.0 / 4.10.10-1-ARCH, LLVM 4.0.0)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 17.0.4
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'name': u'OPENGL_COMPOSITING', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}]}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No
  • webgl2Renderer: X.Org -- Gallium 0.4 on AMD FIJI (DRM 3.9.0 / 4.10.10-1-ARCH, LLVM 4.0.0)
  • webglRenderer: X.Org -- Gallium 0.4 on AMD FIJI (DRM 3.9.0 / 4.10.10-1-ARCH, LLVM 4.0.0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không

Giải pháp được chọn

Setting all of: layers.acceleration.force-enabled webgl.force-enabled media.hardware-video-decoding.force-enabled browser.tabs.remote.autostart to `true` fixed the issues.

Setting all of: layers.acceleration.force-enabled webgl.force-enabled media.hardware-video-decoding.force-enabled browser.tabs.remote.autostart to `true` fixed the issues.