Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

White Icons instead of FIREFOX ICONS

  • 15 trả lời
  • 3 gặp vấn đề này
  • 20398 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

I'm on the latest version 50.1.0 and all my icons are WHITE, not the FIREFOX ICONS.

Can you tell me what to reset?

Thank you.

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Took another shot and FOUND IconCache.db file and deleted it.

Rebooted, etc. and still FIREFOX shortcuts are white.

Thanks for all the suggestions.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (15)

more options

Make sure that Firefox is your default web browser. Type about:preferences#general<enter> in the address bar.

If you want, turn on Always Check Firefox Default Browser.


Right-click one of the shortcuts and select Properties. Under Web Document, press the Change Icon button.

Find and select Firefox from the Programs Folders.

more options

Thank you for your reply.

All of your suggestions were already in place.

If I should switch to IE, CHROME, or CHROMIUM, all the icons change to that program as they should.

Only FIREFOX remains WHITE blocks.

Thanks again for the effort.

more options

You can check for issues with the Windows icon cache.

Try to rebuild the icon cache (IconCache.db).

  1. Open the Task Manager (Shift+Ctrl+ESC)
  2. In the Process tab, right-click on the Explorer.exe process and select End Process.
  3. Open the file picker via "File > New Task (Run)" and click the Browse button.
  4. Type or Paste %USERPROFILE%\AppData\Local or %LocalAppData% in the File name field (AppData is a hidden folder).
  5. Select the IconCache.db file and use "Delete" in the right-click context menu to delete the file.
  6. After the IconCache.db file has been deleted, start a new explorer.exe process via "File > New Task" to get the desktop and Taskbar back.

Note that IconCache.db is a hidden file, so make sure you can see hidden files.

more options

I tried this and I can't find the ICONCACHE.db for the life of me. I've checked don't hide files in explorer and followed the steps but I can't find that file. Tried it AGAIN this morning (1/1/17) and no luck.

If i type *.db in the search box I get a lot of thumb.db but no iconcache

UGH!

THANKS.

Được chỉnh sửa bởi FOXYSTORMIN vào

more options

I continue to try everything and anything.

As you can see from SCREENSHOT, even in the DEFAULT PROGRAMS list there are WHITE icons because the system things I haven't assigned a program to those situations even those FIREFOX "IS" assigned.

Thanks for any further suggestions.

Được chỉnh sửa bởi FOXYSTORMIN vào

more options
more options

Did you look in %LocalAppData%?

This is the same location that Firefox uses for the disk cache.

  • C:\Users\<user>\AppData\Local\

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.

more options

Yes and as you can see they are all greyed out.

TXS

more options

Giải pháp được chọn

Took another shot and FOUND IconCache.db file and deleted it.

Rebooted, etc. and still FIREFOX shortcuts are white.

Thanks for all the suggestions.

more options

Did you follow the instructions and ended the explorer process before deleting the IconCache.db file?

more options

cor-el said

Did you follow the instructions and ended the explorer process before deleting the IconCache.db file?

1st, I am following your instructions to the letter. I even double-checked to make sure HIDDEN FILES were visible.

I can see the iconcache.db file before I start your process in the list (it appears greyed out but with a FIREFOX icon); however, when I work through your steps, when I get to the LOCALAPP data screen and scroll to the bottom to look for it, it doesn't appear.

I assume that deleting the .db file WITHOUT closing explorer first will not solve the issue?

At the moment, there is no cache file to be found, but I know it will show up again soon.

Thanks.

more options

It is not very likely that deleting the file while the explorer process that controls the desktop is still running works. Otherwise the instructions wouldn't mention it explicitly. Ending the Explorer process via the Windows Task Manager is easier than previously proposed steps that used a command window to enter all commands manually via a command line.

If the location of the file isn't correct in your case then you only need to modify this part of the instructions.

more options

I DON'T UNDERSTAND; EVERYTHING IS WORKING AGAIN!!!!!!!

So I came across another POST from a couple of years ago who did EVERYTHING we discussed and nothing worked. Finally, they said "screw-it" and uninstalled and reinstalled FIREFOX.

WAH-LAH! Icons are back to normal! Go figure!

Then, I noticed I was seeing thumbnails instead of previews, but I solved that problem with a check mark in windows explorer. How it got changed, I don't know, but, hey, it keeps life interesting.

THANK YOU AGAIN for all your suggestions.

more options

One additional note:

When I open the REINSTALLED version of FF, it remembered my tabs, history and all my bookmarks were there.

Amazing!

more options

That was very good work. Well done. Please flag your https://support.mozilla.org/en-US/questions/1153574#answer-955655 post as Solved Problem so others will know.


Firefox comes in two or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And one folder in the profile of each user on the computer.

If you remove the Firefox folder, the user folders would not be affected.