X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Text Font and Spacing in Drop Down Menu is Wierd

Được đăng

Hi all,

So about a week and a half ago I formatted my PC as it was running slowly and just generally not performing well. I want to say I had no issues with Firefox before that and I never really changed any settings in Firefox. Maybe a couple about browsing/data storage, but that's it. The only Addons I had ever installed were AdBlock Plus, uBlock Origin, Privacy Badger and I forget the name of it, but it was a Flash Player blocking addon. Still no issues though.

Anyway, after formatting I reinstalled everything, Firefox being first, and things were going along nicely. However, a few days passed and I noticed that the text in all of my drop down menus looked off. I had a closer look and noticed the font was different and the spacing was weird. Not only that, but I was seeing fewer items in longer drop down lists. At the time of writing this, my uploaded image still hasn't successfully loaded in, so here's a link to what I mean. http://i.imgur.com/qwodW7Z.png (The correct look of the text is on the left, while the odd one is on the right.)

I don't know what caused this. I didn't change any settings at all after reinstalling Firefox. I asked a friend who uses it, and I even went to the Firefox Subreddit for some help but nothing worked. I checked my display settings and text was at 100%, I checked internet options but the default text was set to Times New Roman, just as it is in Firefox itself - it's all default. I disabled hardware acceleration and that didn't work, I was told to try setting "gfx.content.azure.enabled" to 0 (which I assume is "false"), but I couldn't see that in my about:config page, so I added it as boolean. I was then told to add it and try it at 0 and at 1, but if nothing works leave it at 1 (which I assume is "true"). I tried all of that but still nothing. It has been like this for several days and the problem is still persisting.

Here's the weird part though. I've refreshed Firefox in the Troubleshooting Information section, and after doing that the text goes back to normal (how it looks on the left side of the picture), BUT when I close and open Firefox the next time, the text has gone weird in drop down menus again. I removed and reinstalled Firefox but it still persisted. I removed all files and folders of Firefox/Mozilla from my machine, reinstalled and the text went back to normal... only for it to go weird after I closed and reopened Firefox.

I have no idea what the problem is. I've even tried changing the font in Firefox but it did nothing! I've tried Internet Explorer, Edge, and even Chrome to see if the problem persists there but it doesn't. I open it, try the same website across all browsers and I see the text looking fine. I close and reopen all of them and the text looks the exact same. Why is it that Firefox decides to change that text? Is this part of a new update? Did I just not have the latest version of Firefox before my format? If this IS part of an update, why does the text look one way after I refresh, but a different way when I open Firefox any time afterwards?

This isn't a huge issue, but seeing the text looking totally wrong in my drop down menu multiple times a day slowly annoys me more and more each time. It's almost like I'm being taunted because I don't know how to fix it or what's causing it. I don't want to change browser just for peace of mind, I'd never know what was causing the problem if I do that! My machine and my graphics card drivers are all up to date. I don't want to have to format my PC again just for a slight chance it might fix the problem, especially when it's not guaranteed to fix the problem!

I use Windows 10 and I have the very latest version of Firefox, 49.0. Graphics card is a Radeon HD 5770 and I run a 64 bit OS. I don't know why this is a problem. I never had this problem before my format and I've never had any other problems with Firefox, so what gives? I can't find anyone else with this problem online at ALL. Am I just crazy, and this is all part of an update but for some reason the first time I refresh Firefox it doesn't load properly, or what?

Any help would be appreciated. I'm all out of ideas, I don't want to format and I don't really like any other browsers except Firefox. Yes, I'm sure I can try to live with it, but it annoys me every time I see it.

(Please tell me there's something in my troubleshooting information that solves this problem).

QUICK NOTE: The ONLY place that drop down menus look totally normal is the Firefox Options page itself.

Hi all, So about a week and a half ago I formatted my PC as it was running slowly and just generally not performing well. I want to say I had no issues with Firefox before that and I never really changed any settings in Firefox. Maybe a couple about browsing/data storage, but that's it. The only Addons I had ever installed were AdBlock Plus, uBlock Origin, Privacy Badger and I forget the name of it, but it was a Flash Player blocking addon. Still no issues though. Anyway, after formatting I reinstalled everything, Firefox being first, and things were going along nicely. However, a few days passed and I noticed that the text in all of my drop down menus looked off. I had a closer look and noticed the font was different and the spacing was weird. Not only that, but I was seeing fewer items in longer drop down lists. At the time of writing this, my uploaded image still hasn't successfully loaded in, so here's a link to what I mean. http://i.imgur.com/qwodW7Z.png (The correct look of the text is on the left, while the odd one is on the right.) I don't know what caused this. I didn't change any settings at all after reinstalling Firefox. I asked a friend who uses it, and I even went to the Firefox Subreddit for some help but nothing worked. I checked my display settings and text was at 100%, I checked internet options but the default text was set to Times New Roman, just as it is in Firefox itself - it's all default. I disabled hardware acceleration and that didn't work, I was told to try setting "gfx.content.azure.enabled" to 0 (which I assume is "false"), but I couldn't see that in my about:config page, so I added it as boolean. I was then told to add it and try it at 0 and at 1, but if nothing works leave it at 1 (which I assume is "true"). I tried all of that but still nothing. It has been like this for several days and the problem is still persisting. Here's the weird part though. I've refreshed Firefox in the Troubleshooting Information section, and after doing that the text goes back to normal (how it looks on the left side of the picture), BUT when I close and open Firefox the next time, the text has gone weird in drop down menus again. I removed and reinstalled Firefox but it still persisted. I removed all files and folders of Firefox/Mozilla from my machine, reinstalled and the text went back to normal... only for it to go weird after I closed and reopened Firefox. I have no idea what the problem is. I've even tried changing the font in Firefox but it did nothing! I've tried Internet Explorer, Edge, and even Chrome to see if the problem persists there but it doesn't. I open it, try the same website across all browsers and I see the text looking fine. I close and reopen all of them and the text looks the exact same. Why is it that Firefox decides to change that text? Is this part of a new update? Did I just not have the latest version of Firefox before my format? If this IS part of an update, why does the text look one way after I refresh, but a different way when I open Firefox any time afterwards? This isn't a huge issue, but seeing the text looking totally wrong in my drop down menu multiple times a day slowly annoys me more and more each time. It's almost like I'm being taunted because I don't know how to fix it or what's causing it. I don't want to change browser just for peace of mind, I'd never know what was causing the problem if I do that! My machine and my graphics card drivers are all up to date. I don't want to have to format my PC again just for a slight chance it might fix the problem, especially when it's not guaranteed to fix the problem! I use Windows 10 and I have the very latest version of Firefox, 49.0. Graphics card is a Radeon HD 5770 and I run a 64 bit OS. I don't know why this is a problem. I never had this problem before my format and I've never had any other problems with Firefox, so what gives? I can't find anyone else with this problem online at ALL. Am I just crazy, and this is all part of an update but for some reason the first time I refresh Firefox it doesn't load properly, or what? Any help would be appreciated. I'm all out of ideas, I don't want to format and I don't really like any other browsers except Firefox. Yes, I'm sure I can try to live with it, but it annoys me every time I see it. (Please tell me there's something in my troubleshooting information that solves this problem). QUICK NOTE: The ONLY place that drop down menus look totally normal is the Firefox Options page itself.

Giải pháp được chọn

Hmm, that seems inaccurate. So much for the Fonts panel.

Could you check someone else? One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. Some kinks are still being discovered and worked out, and I wonder whether it might be a factor here.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Đọc câu trả lời này trong ngữ cảnh 2

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

uBlock Origin

Ứng dụng

  • Firefox 49.0.2
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-GB/

Tiện ích mở rộng

  • Asynchronous Plugin Rendering 2.0 (asyncrendering@mozilla.org)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • uBlock Origin 1.9.16 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: AMD Radeon HD 5700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x68b8
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 29911682
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.351
  • driverDate: 11-4-2015
  • driverDate2:
  • driverVersion: 15.201.1151.1008
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5700 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
FredMcD
  • Top 10 Contributor
4246 giải pháp 59390 câu trả lời
Được đăng

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Người tạo câu hỏi

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Running Firefox in Safe Mode doesn't fix the problem, unfortunately. If I start my computer in Safe Mode, what do you mean by safe websites? The internet doesn't work in Safe Mode so I'm not really sure what to do there.

''FredMcD [[#answer-933095|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' </blockquote> Running Firefox in Safe Mode doesn't fix the problem, unfortunately. If I start my computer in Safe Mode, what do you mean by safe websites? The internet doesn't work in Safe Mode so I'm not really sure what to do there.
FredMcD
  • Top 10 Contributor
4246 giải pháp 59390 câu trả lời
Được đăng

FredMcD said

Start your Computer in safe mode with networking

Go only to safe sites like Mozilla and see if the problem is still there.

''FredMcD [[#answer-933095|said]]'' <blockquote> Start your '''Computer''' in safe mode '''with networking''' </blockquote> Go only to safe sites like Mozilla and see if the problem is still there.
Happy112 561 giải pháp 5694 câu trả lời
Được đăng

Just in case you don't know how to do that :
https://www.cnet.com/how-to/how-to-boot-into-safe-mode-in-windows-10/

Just in case you don't know how to do that :<BR> https://www.cnet.com/how-to/how-to-boot-into-safe-mode-in-windows-10/

Người tạo câu hỏi

FredMcD said

FredMcD said
Start your Computer in safe mode with networking

Go only to safe sites like Mozilla and see if the problem is still there.

Happy112 said

Just in case you don't know how to do that :
https://www.cnet.com/how-to/how-to-boot-into-safe-mode-in-windows-10/

Ah my bad. I didn't notice that. I tried it that way but the issue with drop down menus was still present. Both in computer safe mode and Firefox safe mode.

''FredMcD [[#answer-933286|said]]'' <blockquote> ''FredMcD [[#answer-933095|said]]'' <blockquote> Start your '''Computer''' in safe mode '''with networking''' </blockquote> Go only to safe sites like Mozilla and see if the problem is still there. </blockquote> ''Happy112 [[#answer-933293|said]]'' <blockquote> Just in case you don't know how to do that :<BR> https://www.cnet.com/how-to/how-to-boot-into-safe-mode-in-windows-10/ </blockquote> Ah my bad. I didn't notice that. I tried it that way but the issue with drop down menus was still present. Both in computer safe mode and Firefox safe mode.
FredMcD
  • Top 10 Contributor
4246 giải pháp 59390 câu trả lời
Được đăng

Okay, good. This is probably an issue with one of your settings. But I don't know which one.

I can call for more help, or you can refresh Firefox.

Refresh Firefox {web link} is a LAST RESORT ! !

Refresh Firefox - reset add-ons and settings

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

Okay, good. This is probably an issue with one of your settings. But I don't know which one. I can call for more help, or you can refresh Firefox. '''[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refresh Firefox]''' {web link} is a '''LAST RESORT ! !''' Refresh Firefox - reset add-ons and settings If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

Người tạo câu hỏi

FredMcD said

Okay, good. This is probably an issue with one of your settings. But I don't know which one. I can call for more help, or you can refresh Firefox. Refresh Firefox {web link} is a LAST RESORT ! ! Refresh Firefox - reset add-ons and settings If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

I just refreshed Firefox, and I have actually done so twice before. This does fix the problem, however it seems to only be a temporary fix. The next time I open Firefox, the problem comes straight back. Sure, I don't need to close Firefox for the rest of the evening, but when I turn my computer on tomorrow and open Firefox again, it'l come back.

At the very least, this means refreshing Firefox does indeed fix the problem, but I'm not sure why it comes straight back on the next time I open it.

''FredMcD [[#answer-933332|said]]'' <blockquote> Okay, good. This is probably an issue with one of your settings. But I don't know which one. I can call for more help, or you can refresh Firefox. '''[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refresh Firefox]''' {web link} is a '''LAST RESORT ! !''' Refresh Firefox - reset add-ons and settings If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs. </blockquote> I just refreshed Firefox, and I have actually done so twice before. This does fix the problem, however it seems to only be a temporary fix. The next time I open Firefox, the problem comes straight back. Sure, I don't need to close Firefox for the rest of the evening, but when I turn my computer on tomorrow and open Firefox again, it'l come back. At the very least, this means refreshing Firefox does indeed fix the problem, but I'm not sure why it comes straight back on the next time I open it.
FredMcD
  • Top 10 Contributor
4246 giải pháp 59390 câu trả lời
Được đăng

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

'''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Người tạo câu hỏi

FredMcD said

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

So I'm in the process of trying these options. Refreshing Firefox fixes the problem temporarily but it comes back. I have no user.js file in my folder, I deleted the prefs.js file but it didn't fix the issue, and 'read-only' is not checked. I've reinstalled Firefox after completely removing all folders from my system, but the problem returns after I close Firefox for the first time, so does that mean it's software causing this minor but annoying issue?

I can't actually seem to find any of these third-party softwares on my system when I search my drive. Am I searching for them in the right way? Like Advanced SystemCare. I can't seem to find that on my system at all.

I'd like to think this isn't a malware issue. Firefox doesn't seem to load slowly, I don't have any extra tabs opening, my home page is still the same, I don't have any extra toolbars. I haven't actually downloaded many things at all since I formatted my PC, and the things I have downloaded are the same things I had before the format, and Firefox didn't have any issues back then.

However, the one thing that also temporarily works is the SearchReset addon (https://addons.mozilla.org/en-GB/firefox/addon/searchreset/). But as I said, the problem comes straight back after I close and reopen Firefox, just like refreshing and reinstalling do. Does this help you figure out what the problem may be? I suppose it could be third-party software but I'm not actually sure what it is.

''FredMcD [[#answer-933492|said]]'' <blockquote> '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. </blockquote> So I'm in the process of trying these options. Refreshing Firefox fixes the problem temporarily but it comes back. I have no user.js file in my folder, I deleted the prefs.js file but it didn't fix the issue, and 'read-only' is not checked. I've reinstalled Firefox after completely removing all folders from my system, but the problem returns after I close Firefox for the first time, so does that mean it's software causing this minor but annoying issue? I can't actually seem to find any of these third-party softwares on my system when I search my drive. Am I searching for them in the right way? Like Advanced SystemCare. I can't seem to find that on my system at all. I'd like to think this isn't a malware issue. Firefox doesn't seem to load slowly, I don't have any extra tabs opening, my home page is still the same, I don't have any extra toolbars. I haven't actually downloaded many things at all since I formatted my PC, and the things I have downloaded are the same things I had before the format, and Firefox didn't have any issues back then. However, the one thing that also temporarily works is the SearchReset addon (https://addons.mozilla.org/en-GB/firefox/addon/searchreset/). But as I said, the problem comes straight back after I close and reopen Firefox, just like refreshing and reinstalling do. Does this help you figure out what the problem may be? I suppose it could be third-party software but I'm not actually sure what it is.

Người tạo câu hỏi

Small Update: Just scanned my system with Windows Defender, Microsoft Safety Scanner and Malwarebytes' Anti-Malware Free and none of them have found anything malicious on my system.

A friend suggested it could be a graphics card/driver issue, but all of that was the same in my PC before the format. It seems like it probably is a third-party software, since refreshing Firefox fixes the problem, only for it to come straight back. If that is the case, I have no idea what software is causing this. Again, Firefox was fine before the format on my system. I originally ran Windows 7 Professional, then upgraded to Windows 10 last year. When I formatted, it was a fresh install of Windows 10, so perhaps some software that was installed is causing this issue?

I really don't understand what this is. I don't want to format my computer a second time for a chance at fixing this.

Small Update: Just scanned my system with Windows Defender, Microsoft Safety Scanner and Malwarebytes' Anti-Malware Free and none of them have found anything malicious on my system. A friend suggested it could be a graphics card/driver issue, but all of that was the same in my PC before the format. It seems like it probably is a third-party software, since refreshing Firefox fixes the problem, only for it to come straight back. If that is the case, I have no idea what software is causing this. Again, Firefox was fine before the format on my system. I originally ran Windows 7 Professional, then upgraded to Windows 10 last year. When I formatted, it was a fresh install of Windows 10, so perhaps some software that was installed is causing this issue? I really don't understand what this is. I don't want to format my computer a second time for a '''chance''' at fixing this.
FredMcD
  • Top 10 Contributor
4246 giải pháp 59390 câu trả lời
Được đăng

I want to try an experiment.

Start your Computer in safe mode with networking. Then start Firefox. Change the settings to what you want them bo be. Then Close Firefox.

Wait for a slow count of 30. Then restart Firefox. Check the settings. Are they still the way you left them?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

I want to try an experiment. Start your '''Computer''' in safe mode with networking. Then start Firefox. Change the settings to what you want them bo be. Then '''Close Firefox.''' Wait for a slow count of 30. Then restart Firefox. Check the settings. Are they still the way you left them? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
jscher2000
  • Top 10 Contributor
8692 giải pháp 71045 câu trả lời
Được đăng

What is your default sans-serif font? One way to check is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste .sans and pause while the list is filtered

Are any of these font name preferences bolded and marked as "user set"? Those would be the first thing to consider.

By the way, the most commonly used default fonts for English speakers are toward the end:

  • font.name.sans-serif.x-unicode (Arial)
  • font.name.sans-serif.x-western (Arial)

Alternately, if the drop-downs appear in sites that primarily use other languages, one of the other preferences may be applied.

What is your default sans-serif font? One way to check is: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''.sans''' and pause while the list is filtered Are any of these font name preferences bolded and marked as "user set"? Those would be the first thing to consider. By the way, the most commonly used default fonts for English speakers are toward the end: * font.name.sans-serif.x-unicode (Arial) * font.name.sans-serif.x-western (Arial) Alternately, if the drop-downs appear in sites that primarily use other languages, one of the other preferences may be applied.

Người tạo câu hỏi

FredMcD said

I want to try an experiment. Start your Computer in safe mode with networking. Then start Firefox. Change the settings to what you want them bo be. Then Close Firefox. Wait for a slow count of 30. Then restart Firefox. Check the settings. Are they still the way you left them? Starting The Computer In Safe Mode;
Free Online Encyclopedia

I refreshed Firefox in my computer safe mode, closed it, waited 45 seconds then opened it to see the problem still came back after the refreshed fixed it temporarily.

jscher2000 said

What is your default sans-serif font? One way to check is: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste .sans and pause while the list is filtered Are any of these font name preferences bolded and marked as "user set"? Those would be the first thing to consider. By the way, the most commonly used default fonts for English speakers are toward the end:
  • font.name.sans-serif.x-unicode (Arial)
  • font.name.sans-serif.x-western (Arial)
Alternately, if the drop-downs appear in sites that primarily use other languages, one of the other preferences may be applied.

Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that. I'm pretty sure I'm only using English sites. I've tried multiple ones, such as my bank site, job sites, and more.

Perhaps there is an issue in there that is still causing this? I'm not sure.

This only seems to happen on websites where I need to click the drop down menu. Whether I refresh Firefox, or completely remove and reinstall it, the issue is fixed until the next time I open it. When that happens, the issue comes back. I don't know what it is, all I know is that it's not normal.

Since it was still present while my computer was in safe mode, I doubt it's a third-party software. I suppose it is possible it's my graphics card/drivers but I never had this issue before, and since my graphics card is old, I always made sure to keep it up-to-date. Maybe there's something in my system that also loads in safe mode, that is messing with drop down menu font only? I really have no idea.

I feel so defeated by such a small problem. Thank you as always for your help.

''FredMcD [[#answer-933556|said]]'' <blockquote> I want to try an experiment. Start your '''Computer''' in safe mode with networking. Then start Firefox. Change the settings to what you want them bo be. Then '''Close Firefox.''' Wait for a slow count of 30. Then restart Firefox. Check the settings. Are they still the way you left them? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' </blockquote> I refreshed Firefox in my computer safe mode, closed it, waited 45 seconds then opened it to see the problem still came back after the refreshed fixed it temporarily. ''jscher2000 [[#answer-933596|said]]'' <blockquote> What is your default sans-serif font? One way to check is: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''.sans''' and pause while the list is filtered Are any of these font name preferences bolded and marked as "user set"? Those would be the first thing to consider. By the way, the most commonly used default fonts for English speakers are toward the end: * font.name.sans-serif.x-unicode (Arial) * font.name.sans-serif.x-western (Arial) Alternately, if the drop-downs appear in sites that primarily use other languages, one of the other preferences may be applied. </blockquote> Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that. I'm pretty sure I'm only using English sites. I've tried multiple ones, such as my bank site, job sites, and more. Perhaps there is an issue in there that is still causing this? I'm not sure. This only seems to happen on websites where I need to click the drop down menu. Whether I refresh Firefox, or completely remove and reinstall it, the issue is fixed until the next time I open it. When that happens, the issue comes back. I don't know what it is, all I know is that it's not normal. Since it was still present while my computer was in safe mode, I doubt it's a third-party software. I suppose it is possible it's my graphics card/drivers but I never had this issue before, and since my graphics card is old, I always made sure to keep it up-to-date. Maybe there's something in my system that also loads in safe mode, that is messing with drop down menu font only? I really have no idea. I feel so defeated by such a small problem. Thank you as always for your help.
jscher2000
  • Top 10 Contributor
8692 giải pháp 71045 câu trả lời
Được đăng

KSpin said

jscher2000 said
What is your default sans-serif font?

Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that.

I should have said: please wait until the problem returns and then check.

''KSpin [[#answer-933600|said]]'' <blockquote> ''jscher2000 [[#answer-933596|said]]'' <blockquote> What is your default sans-serif font? </blockquote> Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that. </blockquote> I should have said: please wait until the problem returns and ''then'' check.

Người tạo câu hỏi

jscher2000 said

KSpin said
jscher2000 said
What is your default sans-serif font?

Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that.

I should have said: please wait until the problem returns and then check.

It is there, unfortunately. Which is why this is so confusing to me.

''jscher2000 [[#answer-933603|said]]'' <blockquote> ''KSpin [[#answer-933600|said]]'' <blockquote> ''jscher2000 [[#answer-933596|said]]'' <blockquote> What is your default sans-serif font? </blockquote> Nope, none of them are bolded or marked as "user set", and the two you showed are exactly like that. </blockquote> I should have said: please wait until the problem returns and ''then'' check. </blockquote> It is there, unfortunately. Which is why this is so confusing to me.
jscher2000
  • Top 10 Contributor
8692 giải pháp 71045 câu trả lời
Được đăng

Can you give a link to a site where this problem occurs? Or is it everywhere, for example, the version drop-downs in the Editing Tools panel on the left side of this article:

How do I create a screenshot of my problem?

The page has this rule:

font-family: 'Open Sans',Arial,Helvetica,sans-serif;

So the first preference is the downloadable font Open Sans, then Arial, which is standard on Windows, then Helvetica, which may not be present on Windows, and finally the default sans-serif font which normally also is Arial.

If the Options in the drop-down use a different font, you can right-click > Inspect Element to open the Inspector in the lower part of the tab. (Example screenshot attached.) On the right side, the Fonts section should show the actual font Firefox is using for that text. Is yours using Segoe UI or some other menu-ish font?

Can you give a link to a site where this problem occurs? Or is it everywhere, for example, the version drop-downs in the Editing Tools panel on the left side of this article: [[How do I create a screenshot of my problem?]] The page has this rule: font-family: 'Open Sans',Arial,Helvetica,sans-serif; So the first preference is the downloadable font Open Sans, then Arial, which is standard on Windows, then Helvetica, which may not be present on Windows, and finally the default sans-serif font which normally also is Arial. If the Options in the drop-down use a different font, you can right-click > Inspect Element to open the Inspector in the lower part of the tab. (Example screenshot attached.) On the right side, the Fonts section should show the actual font Firefox is using for that text. Is yours using Segoe UI or some other menu-ish font?

Người tạo câu hỏi

jscher2000 said

Can you give a link to a site where this problem occurs? Or is it everywhere, for example, the version drop-downs in the Editing Tools panel on the left side of this article: How do I create a screenshot of my problem? The page has this rule: font-family: 'Open Sans',Arial,Helvetica,sans-serif; So the first preference is the downloadable font Open Sans, then Arial, which is standard on Windows, then Helvetica, which may not be present on Windows, and finally the default sans-serif font which normally also is Arial. If the Options in the drop-down use a different font, you can right-click > Inspect Element to open the Inspector in the lower part of the tab. (Example screenshot attached.) On the right side, the Fonts section should show the actual font Firefox is using for that text. Is yours using Segoe UI or some other menu-ish font?

Yeah, it happens everywhere if I need to click on the drop down menu to select an item.

It seems like I have all the same information as in your screenshot, yet clearly the font is different.

''jscher2000 [[#answer-933606|said]]'' <blockquote> Can you give a link to a site where this problem occurs? Or is it everywhere, for example, the version drop-downs in the Editing Tools panel on the left side of this article: [[How do I create a screenshot of my problem?]] The page has this rule: font-family: 'Open Sans',Arial,Helvetica,sans-serif; So the first preference is the downloadable font Open Sans, then Arial, which is standard on Windows, then Helvetica, which may not be present on Windows, and finally the default sans-serif font which normally also is Arial. If the Options in the drop-down use a different font, you can right-click > Inspect Element to open the Inspector in the lower part of the tab. (Example screenshot attached.) On the right side, the Fonts section should show the actual font Firefox is using for that text. Is yours using Segoe UI or some other menu-ish font? </blockquote> Yeah, it happens everywhere if I need to click on the drop down menu to select an item. It seems like I have all the same information as in your screenshot, yet clearly the font is different.

Người tạo câu hỏi

I realised I had accidentally clicked the drop down menu for the OS instead of the version of Firefox, but both say the same thing.

I realised I had accidentally clicked the drop down menu for the OS instead of the version of Firefox, but both say the same thing.
jscher2000
  • Top 10 Contributor
8692 giải pháp 71045 câu trả lời
Được đăng

Giải pháp được chọn

Hmm, that seems inaccurate. So much for the Fonts panel.

Could you check someone else? One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. Some kinks are still being discovered and worked out, and I wonder whether it might be a factor here.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Hmm, that seems inaccurate. So much for the Fonts panel. Could you check someone else? One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. Some kinks are still being discovered and worked out, and I wonder whether it might be a factor here. ''Are you using e10s?'' You can check whether you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference?

Người tạo câu hỏi

jscher2000 said

Hmm, that seems inaccurate. So much for the Fonts panel. Could you check someone else? One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. Some kinks are still being discovered and worked out, and I wonder whether it might be a factor here. Are you using e10s? You can check whether you have this feature turned on as follows. Either:
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. If you are using e10s: To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste autos and pause while the list is filtered (3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart At your next Firefox startup, it should run in the traditional way. Any difference?

Oh my goodness, I think you've just solved the problem! I'm checking all the sites where the problem was present and it's no longer there.

My "Multiprocess windows" was set at "1/1", and after setting the 'browser.tabs.remote.autostart.2' pre to false, I closed and reopened Firefox, and the drop down menu font was fixed.

Thank you for helping me with this! I'm not great when it comes to this type of information, so I really appreciate it. I hope anyone else that has this problem will come across this.

Though I do wonder why refreshing Firefox seemed to disable this, only for it to be enabled once Firefox was reopened. That preference said it was user set, but I think it's obvious I didn't touch anything.

''jscher2000 [[#answer-933617|said]]'' <blockquote> Hmm, that seems inaccurate. So much for the Fonts panel. Could you check someone else? One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. Some kinks are still being discovered and worked out, and I wonder whether it might be a factor here. ''Are you using e10s?'' You can check whether you have this feature turned on as follows. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart'' At your next Firefox startup, it should run in the traditional way. Any difference? </blockquote> Oh my goodness, I think you've just solved the problem! I'm checking all the sites where the problem was present and it's no longer there. My "Multiprocess windows" was set at "1/1", and after setting the '''browser.tabs.remote.autostart.2' pre'' to false, I closed and reopened Firefox, and the drop down menu font was fixed. Thank you for helping me with this! I'm not great when it comes to this type of information, so I really appreciate it. I hope anyone else that has this problem will come across this. Though I do wonder why refreshing Firefox seemed to disable this, only for it to be enabled once Firefox was reopened. That preference said it was user set, but I think it's obvious I didn't touch anything.