Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Twitter web player embed doesn't work on certain site

  • 26 trả lời
  • 3 gặp vấn đề này
  • 1186 lượt xem
  • Trả lời mới nhất được viết bởi Techno769

more options

Just a forewarning, I'm kindly asking to not have any political arguments or time-wasting here. On this page http://www.infowars.com/pathetic-hardly-anyone-shows-up-to-tim-kaine-florida-rally, there are multiple embedded HTML5 videos from Twitter. I am able to view the videos fine other ways, but not as they are embedded on that specific URL for me. I already tried safe mode, and the videos on that page would still not display. What I get instead is in the attached screenshot. Clicking the play or any other buttons in that blank white box does nothing.

Unfortunately, the videos embedded in the page play as intended on Google Chrome, and they even work on my Firefox only IF I go to the respective pages on twitter.com and play them.

I tried comparing the inspect element tool between both Chrome and Firefox, and I can only tell that Chrome has a LOT more coding for that 'player container' as it's called.

I do use both AdBlock Plus and NoScript, and disabling both (along with all other add-ons) surprisingly didn't fix the issue.

I'm running FF 49.0.2.

Thank you to anyone who might have the same issue or be able to help.


Once again, this is not an error with the way the specific site or page is encoded, because the page's player works on Google Chrome. Just not Firefox.

Also, I have noticed this same issue with other videos from Twitter on the same site (infowars.com) on my Firefox.

Được chỉnh sửa bởi Techno769 vào

Giải pháp được chọn

Techno769 said

jscher2000 said
That's hard to read... The only thing I know to be related to framed pages is network.auth.allow-subresource-auth but I don't know why that would affect Twitter. You could try the half-at-a-time method: delete the first half of the preferences in prefs.js and see whether the problem goes away. If it does, try putting half of those back. If not, delete half of the remaining preferences. And so on.


Yaayyyy!!! After much trial and error (with my dummy profile of course), I found the culprit: *drum roll please...*

user_pref("network.cookie.cookieBehavior", 3);

It looks like I'll have to accept all cookies from all sites for this to work. Let's see.

That was it. I have to "Always" accept cookies from third-party sites for the players to work.

Thank you so much for pointing me in the right directions.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

jscher2000 said

vidadblocker sounds like an extension, but it's weird that they are not under extension.vidadblocker. ?? Anyway, if you delete them and they turn out to be important, you can restore them from the other copy. The fullscreen warning shouldn't be a factor with the initial load/play in the frame. What about customized security settings?

I tried removing those, it didn't change anything. I agree with the fullscreen warning. What set of values am I looking for here? Sorry for so many questions, and I really appreciate your support.

more options

Techno769 said

What set of values am I looking for here?

If I knew that, I would have told before. ;-)

more options

jscher2000 said

Techno769 said
What set of values am I looking for here?

If I knew that, I would have told before. ;-)

Lol I hear ya. I just went ahead and took screenshots of all of my preferences. Hopefully you'll be able to better sort through them and rule out potential culprits than I am!

more options

That's hard to read...

The only thing I know to be related to framed pages is network.auth.allow-subresource-auth but I don't know why that would affect Twitter.

You could try the half-at-a-time method: delete the first half of the preferences in prefs.js and see whether the problem goes away. If it does, try putting half of those back. If not, delete half of the remaining preferences. And so on.

more options

jscher2000 said

That's hard to read... The only thing I know to be related to framed pages is network.auth.allow-subresource-auth but I don't know why that would affect Twitter. You could try the half-at-a-time method: delete the first half of the preferences in prefs.js and see whether the problem goes away. If it does, try putting half of those back. If not, delete half of the remaining preferences. And so on.


Yaayyyy!!! After much trial and error (with my dummy profile of course), I found the culprit: *drum roll please...*

user_pref("network.cookie.cookieBehavior", 3);

It looks like I'll have to accept all cookies from all sites for this to work. Let's see.

more options

Giải pháp được chọn

Techno769 said

jscher2000 said
That's hard to read... The only thing I know to be related to framed pages is network.auth.allow-subresource-auth but I don't know why that would affect Twitter. You could try the half-at-a-time method: delete the first half of the preferences in prefs.js and see whether the problem goes away. If it does, try putting half of those back. If not, delete half of the remaining preferences. And so on.


Yaayyyy!!! After much trial and error (with my dummy profile of course), I found the culprit: *drum roll please...*

user_pref("network.cookie.cookieBehavior", 3);

It looks like I'll have to accept all cookies from all sites for this to work. Let's see.

That was it. I have to "Always" accept cookies from third-party sites for the players to work.

Thank you so much for pointing me in the right directions.

  1. 1
  2. 2