X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Restore previous scrollbar behavior in Firefox 46.0

Được đăng

Firefox 46.0 Xubuntu 15.10

Prior to 46.0, I could make a B2 click in the scrollbar gutter and have the content jump to that position directly. As of 46.0, this no longer works and it is very annoying. How can I restore the old behavior?

Firefox 46.0 Xubuntu 15.10 Prior to 46.0, I could make a B2 click in the scrollbar gutter and have the content jump to that position directly. As of 46.0, this no longer works and it is very annoying. How can I restore the old behavior?

Giải pháp được chọn

Looks like this is a known bug related to use of the GTK+ 3.0 library. See:

https://bugzilla.mozilla.org/show_bug.cgi?id=1197590

Workaround solution by Jim Rees, from that Bugzilla bug report:

Create/edit: ~/.config/gtk-3.0/settings.ini

Add following to this file:

[Settings] gtk-primary-button-warps-slider = false

Restart Firefox and scrollbar clicking works as it always has.

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Shockwave Flash 11.2 r202

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17874 giải pháp 161723 câu trả lời
Được đăng

That would be a middle-click with the mouse scroll wheel. You can check the middlemouse.scrollbarPosition pref on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

That would be a middle-click with the mouse scroll wheel. You can check the <b>middlemouse.scrollbarPosition</b> pref on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Người tạo câu hỏi

Thanks for the suggestion, but this is set to True and always has been. From MozillaZine:

> Middlemouse.scrollbarPosition > > True: Center the scroll position on the location of the middle click. > (Default for Linux/Unix.) > > False: Do nothing. (Default for all but Linux/Unix.)

This has always worked up until 46.0. Now, it has no effect of you set it to True or False. But I did notice that B1 is now operating the way B2 used to work. It positions the scrollbar at the cursor location rather than scrolling a page at a time.

This looks like something that has been broken in this release. Can anyone else confirm this on a Linux system? I will report it as a bug.

Thanks for the suggestion, but this is set to True and always has been. From MozillaZine: > Middlemouse.scrollbarPosition > > True: Center the scroll position on the location of the middle click. > (Default for Linux/Unix.) > > False: Do nothing. (Default for all but Linux/Unix.) This has always worked up until 46.0. Now, it has no effect of you set it to True or False. But I did notice that B1 is now operating the way B2 used to work. It positions the scrollbar at the cursor location rather than scrolling a page at a time. This looks like something that has been broken in this release. Can anyone else confirm this on a Linux system? I will report it as a bug.

Giải pháp được chọn

Looks like this is a known bug related to use of the GTK+ 3.0 library. See:

https://bugzilla.mozilla.org/show_bug.cgi?id=1197590

Workaround solution by Jim Rees, from that Bugzilla bug report:

Create/edit: ~/.config/gtk-3.0/settings.ini

Add following to this file:

[Settings] gtk-primary-button-warps-slider = false

Restart Firefox and scrollbar clicking works as it always has.

Looks like this is a known bug related to use of the GTK+ 3.0 library. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1197590 Workaround solution by Jim Rees, from that Bugzilla bug report: Create/edit: '''~/.config/gtk-3.0/settings.ini''' Add following to this file: '''[Settings]''' '''gtk-primary-button-warps-slider = false''' Restart Firefox and scrollbar clicking works as it always has.

Được chỉnh sửa bởi cjsmall vào