X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Fixing font rendering for Firefox 45

Được đăng

Hello there

I do have a problem with some of the the fonts' rendering without antialiasing, as I think, and that makes them pretty ugly. The problem appears to be only with Firefox; the same fonts on Chrome, Internet Explorer, Brave browser or even Pale Moon does not exist. When it comes to Pale Moon, it required some setting to be changed in about:config but eventually, everything rendered neatly.

As far as Firefox in concerned, I have tried to use numerous different solutions but none seemed to work. I'll try to list the tutorials that I have tried. My system is Windows 7 x64 Home Premium, Firefox is the latest version from the stable releases, 45.0.1 right now, I think. Laptop is Acer Aspire 5749Z with Intel Pentium B960 and Intel GMA 2000 graphics. I do have the latest drivers for the graphics card installed. Windows' ClearType is on. Hardware Acceleration is currently on, tried turning if off, nothing helped.

Here is an exaple of a badly rendered font: https://i.imgur.com/70uGPQm.png ("Grids") and here is the link to the page: http://purecss.io/grids/

I have tried the following: https://www.reddit.com/r/firefox/comments/3gtnnq/font_rendering_issues_ff40/ http://www.askvg.com/how-to-disable-hardware-acceleration-gpu-rendering-in-mozilla-firefox-4-0-to-fix-font-problem/ https://support.mozilla.org/pl/questions/1111253 — I have the Windows Updates mentioned here installed. Rest of the tutorials concerned pretty much the same things, i.e. turning the Direct2D on or off.

My thanks and regards Greg

Hello there I do have a problem with some of the the fonts' rendering without antialiasing, as I think, and that makes them pretty ugly. The problem appears to be only with Firefox; the same fonts on Chrome, Internet Explorer, Brave browser or even Pale Moon does not exist. When it comes to Pale Moon, it required some setting to be changed in about:config but eventually, everything rendered neatly. As far as Firefox in concerned, I have tried to use numerous different solutions but none seemed to work. I'll try to list the tutorials that I have tried. My system is Windows 7 x64 Home Premium, Firefox is the latest version from the stable releases, 45.0.1 right now, I think. Laptop is Acer Aspire 5749Z with Intel Pentium B960 and Intel GMA 2000 graphics. I do have the latest drivers for the graphics card installed. Windows' ClearType is on. Hardware Acceleration is currently on, tried turning if off, nothing helped. Here is an exaple of a badly rendered font: https://i.imgur.com/70uGPQm.png ("Grids") and here is the link to the page: http://purecss.io/grids/ I have tried the following: https://www.reddit.com/r/firefox/comments/3gtnnq/font_rendering_issues_ff40/ http://www.askvg.com/how-to-disable-hardware-acceleration-gpu-rendering-in-mozilla-firefox-4-0-to-fix-font-problem/ https://support.mozilla.org/pl/questions/1111253 — I have the Windows Updates mentioned here installed. Rest of the tutorials concerned pretty much the same things, i.e. turning the Direct2D on or off. My thanks and regards Greg

Được chỉnh sửa bởi Gregoric vào

Giải pháp được chọn

Thanks for the huge screenshot. Could you reset this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_r and pause while the list is filtered

(3) Right-click the gfx.font_rendering.cleartype_params.rendering_mode preference and choose Reset (the last option)

You probably need to exit and start Firefox back up again to see any difference.

Here's my understanding of what the numbers do:

//     -1 or 0 = use default for font & size;
//     4 = Natural;
//     5 = Natural Symmetric
=> Sub-pixel anti-aliasing/positioning
//     1 = aliased;
//     2 = GDI Classic;
=> GDI emulation (whole pixel rendering)
//     3 = GDI Natural Widths;
=> GDI emulation with natural widths (?)
Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Thông tin chi tiết

jscher2000
  • Top 10 Contributor
8837 giải pháp 72221 câu trả lời
Được đăng

Câu trả lời hữu ích

Firefox definitely needs hardware acceleration (on Windows, using Direct2D) enabled for best results in font smoothing.

(Attached is how I think it is supposed to look. In the heading, the site is halving the font weight as downloaded, which makes it more fragile than usual.)

Is your Firefox willing/capable of using hardware acceleration with your graphics driver software? If you have restarted Firefox since you finished making changes -- Direct2D changes take effect after a restart -- could you copy/paste the graphics section of the support information page into a reply? Here's how:

Open the support information page using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics header and select from there through the end of the table that follows, then copy (e.g., Ctrl+c) and paste into a reply. (It's normal to lose the formatting, don't worry about that.)


From the other thread, this Microsoft update from 2013 was a good find: https://support.mozilla.org/questions/1111253#answer-847637

Firefox definitely needs hardware acceleration (on Windows, using Direct2D) enabled for best results in font smoothing. ''(Attached is how I think it is supposed to look. In the heading, the site is halving the font weight as downloaded, which makes it more fragile than usual.)'' Is your Firefox willing/capable of using hardware acceleration with your graphics driver software? If you have restarted Firefox since you finished making changes -- Direct2D changes take effect after a restart -- could you copy/paste the graphics section of the support information page into a reply? Here's how: Open the support information page using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter Scroll down to the Graphics header and select from there through the end of the table that follows, then copy (e.g., Ctrl+c) and paste into a reply. (It's normal to lose the formatting, don't worry about that.) ---- From the other thread, this Microsoft update from 2013 was a good find: https://support.mozilla.org/questions/1111253#answer-847637

Được chỉnh sửa bởi jscher2000 vào

Người tạo câu hỏi

Here's the graphics section. It's in Polish but I guess you can easily deduct what everything means. http://pastebin.com/4RtWtbw1

Full screenshot: http://i.imgur.com/K014P70.png

Also, I've set the font weight to 200. The font's thickness indeed changed but the rendering does not look any better. Should it look better immediately, or should the weight be set properly before rendering the whole page? http://imgur.com/tBfFfqA


Edit: about the Windows updates, I have downloaded both of them. One says it's installed, the other one says it cannot be installed on this system; I guess it is installed already as well.

Here's the graphics section. It's in Polish but I guess you can easily deduct what everything means. http://pastebin.com/4RtWtbw1 Full screenshot: http://i.imgur.com/K014P70.png Also, I've set the font weight to 200. The font's thickness indeed changed but the rendering does not look any better. Should it look better immediately, or should the weight be set properly before rendering the whole page? http://imgur.com/tBfFfqA Edit: about the Windows updates, I have downloaded both of them. One says it's installed, the other one says it cannot be installed on this system; I guess it is installed already as well.

Được chỉnh sửa bởi Gregoric vào

jscher2000
  • Top 10 Contributor
8837 giải pháp 72221 câu trả lời
Được đăng

Giải pháp được chọn

Thanks for the huge screenshot. Could you reset this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_r and pause while the list is filtered

(3) Right-click the gfx.font_rendering.cleartype_params.rendering_mode preference and choose Reset (the last option)

You probably need to exit and start Firefox back up again to see any difference.

Here's my understanding of what the numbers do:

//     -1 or 0 = use default for font & size;
//     4 = Natural;
//     5 = Natural Symmetric
=> Sub-pixel anti-aliasing/positioning
//     1 = aliased;
//     2 = GDI Classic;
=> GDI emulation (whole pixel rendering)
//     3 = GDI Natural Widths;
=> GDI emulation with natural widths (?)
Thanks for the huge screenshot. Could you reset this preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_r''' and pause while the list is filtered (3) Right-click the '''gfx.font_rendering.cleartype_params.rendering_mode''' preference and choose Reset (the last option) You probably need to exit and start Firefox back up again to see any difference. Here's my understanding of what the numbers do: // -1 or 0 = use default for font & size; // 4 = Natural; // 5 = Natural Symmetric => Sub-pixel anti-aliasing/positioning // 1 = aliased; // 2 = GDI Classic; => GDI emulation (whole pixel rendering) // 3 = GDI Natural Widths; => GDI emulation with natural widths (?)

Người tạo câu hỏi

Finally! Thank you a great bunch, jscher. That issue with font rendering has been a real pain for me for a quite some time, as I like to use Google Web fonts in my web projects and in many cases (including my... portfolio (sic)), the fonts, although I haven't changed the weight (as it is visible in the case of "Grids" word), were rendered badly in my Firefox.

Well. I have reset the parameter you mentioned, nothing changed. Then, I tried to set it to something other than "2", as "2" has always popped up when I restarted Firefox. I thought whether it wasn't some add-on. I checked... and there was an addon that seemingly influenced that parameter, setting it to "2" all the time. It had something with font rendering in its name, but can't really remember the exact name as it disappeared after disablng it and restarting Firefox (probably have misclicked and removed it).

It is my fault I forgot that addon but I have installed it very recently, like a week ago, I think, as a result of several attempts to fix the font rendering issue (that has existed for several months already).

Anyways, I have it fixed thank to you, as I haven't seen the parameter you have told me to reset in any other guides. Resetting it and removing the addon fixed the issue. Finally! Thank you again, my best regards, have a happy easter and a great spring this year!

Finally! Thank you a great bunch, jscher. That issue with font rendering has been a real pain for me for a quite some time, as I like to use Google Web fonts in my web projects and in many cases (including my... portfolio (sic)), the fonts, although I haven't changed the weight (as it is visible in the case of "Grids" word), were rendered badly in my Firefox. Well. I have reset the parameter you mentioned, nothing changed. Then, I tried to set it to something other than "2", as "2" has always popped up when I restarted Firefox. I thought whether it wasn't some add-on. I checked... and there was an addon that seemingly influenced that parameter, setting it to "2" all the time. It had something with font rendering in its name, but can't really remember the exact name as it disappeared after disablng it and restarting Firefox (probably have misclicked and removed it). It is my fault I forgot that addon but I have installed it very recently, like a week ago, I think, as a result of several attempts to fix the font rendering issue (that has existed for several months already). Anyways, I have it fixed thank to you, as I haven't seen the parameter you have told me to reset in any other guides. Resetting it and removing the addon fixed the issue. Finally! Thank you again, my best regards, have a happy easter and a great spring this year!
jscher2000
  • Top 10 Contributor
8837 giải pháp 72221 câu trả lời
Được đăng

Thank you for reporting back. If you remember the extension's name, feel free to name and shame it.

Thank you for reporting back. If you remember the extension's name, feel free to name and shame it.
benztirf 0 giải pháp 4 câu trả lời
Được đăng

I have the same symptom (the artifacts on the fonts look nearly identical) on https://keeweb.info/ and some other sites.

I tried the about:config section suggested in the accepted solution, but all my values were already at the default. I tried 4 and 5 in gfx.font_rendering.cleartype_params.rendering_mode (the default value is -1) but none of those three settings make any difference. I tried clearing the entire string in gfx.font_rendering.cleartype_params.force_gdi_classic_for_families thinking maybe Firefox was forcing "GDI Classic" on that font, but that made no difference either. Everything back at default now, and I'm still seeing the issue.

I have the same symptom (the artifacts on the fonts look nearly identical) on https://keeweb.info/ and some other sites. I tried the about:config section suggested in the accepted solution, but all my values were already at the default. I tried 4 and 5 in gfx.font_rendering.cleartype_params.rendering_mode (the default value is -1) but none of those three settings make any difference. I tried clearing the entire string in gfx.font_rendering.cleartype_params.force_gdi_classic_for_families thinking maybe Firefox was forcing "GDI Classic" on that font, but that made no difference either. Everything back at default now, and I'm still seeing the issue.
jscher2000
  • Top 10 Contributor
8837 giải pháp 72221 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi benztirf, is your Firefox using hardware acceleration? Please see the first reply above: https://support.mozilla.org/questions/1115938#answer-860565

Firefox 48 changed the Graphics table a bit. Look for Direct2D and DirectWrite to be true.

Hi benztirf, is your Firefox using hardware acceleration? Please see the first reply above: https://support.mozilla.org/questions/1115938#answer-860565 Firefox 48 changed the Graphics table a bit. Look for Direct2D and DirectWrite to be true.
benztirf 0 giải pháp 4 câu trả lời
Được đăng

Thanks for the suggestion to look for DirectWrite. I found gfx.font_rendering.directwrite.force-enabled and set it to "true", because I noticed in "about:support" that "DirectWrite Enabled" was false. It makes the fonts look a whole lot better! Is this the correct fix, or were you suggesting something else?

Thanks for the suggestion to look for DirectWrite. I found gfx.font_rendering.directwrite.force-enabled and set it to "true", because I noticed in "about:support" that "DirectWrite Enabled" was false. It makes the fonts look a whole lot better! Is this the correct fix, or were you suggesting something else?
jscher2000
  • Top 10 Contributor
8837 giải pháp 72221 câu trả lời
Được đăng

Hi benztirf, if DirectWrite has to be forced, it may have been prophylactically disabled due to known stability issues with your current version graphics card driver software. If you haven't already: Upgrade your graphics drivers to use hardware acceleration and WebGL.

Hi benztirf, if DirectWrite has to be forced, it may have been prophylactically disabled due to known stability issues with your current version graphics card driver software. If you haven't already: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]].
benztirf 0 giải pháp 4 câu trả lời
Được đăng

It wouldn't be surprising. I'm on the most recent driver available for my system from the manufacturer, however my system is running Windows Vista at the moment (hoping to upgrade soon) so it's not really supported by anybody anyway.

I'll try to remember I have that option set if I have issues. :-)

It wouldn't be surprising. I'm on the most recent driver available for my system from the manufacturer, however my system is running Windows Vista at the moment (hoping to upgrade soon) so it's not really supported by anybody anyway. I'll try to remember I have that option set if I have issues. :-)