Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can't Access my Web Server with HTTP

  • 4 trả lời
  • 1 gặp vấn đề này
  • 345 lượt xem
  • Trả lời mới nhất được viết bởi Dean Weimer

more options

I have my own web server, and suddenly I can only access the site with HTTPS from Firefox on my home PC. I have tried adjusting the autofill settings clearing cache, even added a link on the page to click and load it as HTTP instead. Nothing works it always comes up with HTTPS. The page does load with Firefox on other machines as HTTP. So I suspect that at some point an error page loaded with a secure transport header in it (perhaps while doing maintenance on my firewall with uses NAT reflection to direct local machines to the web server) and Firefox has cached that in some method that it is not letting me clear it. I appreciate that there is some effort going into making the web more secure. But the site contains nothing that requires security and being the sites maintainer I need to be able to test it with both HTTP and HTTPS.

Giải pháp được chọn

you could also try to edit the "SiteSecurityServiceState.txt" file in your profile while firefox is closed - it holds the sites which sent the hsts flag in the past...

Profiles - Where Firefox stores your bookmarks, passwords and other user data

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

hi, you can use the https://addons.mozilla.org/firefox/addon/force-tls/ addon in order to edit/clear sites which are stored with a HSTS flag.

more options

This Add-On Appears to be broken in recent versions of Firefox.

XML Parsing Error: undefined entity Location: chrome://forcetls/content/forcedsites.xul Line Number 125, Column 7: <button oncommand="close();" icon="close" <="" p="">


^</button>

more options

Giải pháp được chọn

you could also try to edit the "SiteSecurityServiceState.txt" file in your profile while firefox is closed - it holds the sites which sent the hsts flag in the past...

Profiles - Where Firefox stores your bookmarks, passwords and other user data

more options

This fixed it, thanks for the help.