X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

A certain web page doesn't work in Firefox

Được đăng

When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working.

When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working.

Giải pháp được chọn

Hmm, okay. Three things Safe Mode does that might be relevant are:

(1) Disable all extensions, not just Adblock. Possibly one of your other ones is causing this issue.

(2) Disable Firefox from using hardware acceleration. This works around possible incompatibilities with your graphics card/chipset driver software. To test whether this is the issue, you can try turning it off in Options:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available".

This takes effect the next time you exit Firefox and start it up again normally. Any difference?

(3) Disables page style customizations in any userContent.css file you might have in your settings folder. This file doesn't exist by default, so if you do not recall creating it, this probably is not applicable to your Firefox.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Amazon MP3 Downloader Plugin 1.0.17
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 20.0 r0
  • 5.1.40416.0
  • NPWLPG

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Thông tin chi tiết

Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

tiptonhr said

When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working.

I have no problem viewing the page/s You may want to look through your add-ons and disable them and try site again. Let us know how you make out and if solves issue please mark as solved. G'luck

''tiptonhr [[#question-1113318|said]]'' <blockquote> When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working. </blockquote> I have no problem viewing the page/s You may want to look through your add-ons and disable them and try site again. Let us know how you make out and if solves issue please mark as solved. G'luck
Shadow110 1072 giải pháp 14836 câu trả lời
Được đăng

tiptonhr said

When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working.

Just noticed your using FF 45 Developer could that be the issue as there are bugs ?

''tiptonhr [[#question-1113318|said]]'' <blockquote> When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working. </blockquote> Just noticed your using FF 45 Developer could that be the issue as there are bugs ?

Người tạo câu hỏi

Pkshadow said

tiptonhr said
When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working.

Just noticed your using FF 45 Developer could that be the issue as there are bugs ?

Maybe that's it. How do I check and see?

''Pkshadow [[#answer-853046|said]]'' <blockquote> ''tiptonhr [[#question-1113318|said]]'' <blockquote> When I try to access a certain web page (http://www.cbssports.com/), it loads at first but then just goes blank. I have noticed this problem other times browsing specific cbssports.com addresses as well. The site works fine in Explorer so I know the site is working. </blockquote> Just noticed your using FF 45 Developer could that be the issue as there are bugs ? </blockquote> Maybe that's it. How do I check and see?
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Firefox 45 just came out today as a final release, so you might not have a test version if you just updated.

To see whether this is a problem with Firefox "painting" the tab, try zooming out and zooming back in: hold down Ctrl and press - twice, then + twice.

Do you use any ad blockers? Some sites present an obnoxious whole window pop-up with an opaque background to force you to pay attention to their message. Ad blockers sometimes remove the message -- and the close button to get rid of the overlay -- but don't effectively get rid of the overlay. If you think that could be what's happening, try temporarily suspending ad blocking on the site and reload the page, and dismiss the overlay. Usually a site will set a cookie so it doesn't show that same overlay over and over to someone who has already seen it. Once that cookie is set, you can try turning the ad blocker on again.

Firefox 45 just came out today as a final release, so you might not have a test version if you just updated. To see whether this is a problem with Firefox "painting" the tab, try zooming out and zooming back in: hold down Ctrl and press - twice, then + twice. Do you use any ad blockers? Some sites present an obnoxious whole window pop-up with an opaque background to force you to pay attention to their message. Ad blockers sometimes remove the message -- and the close button to get rid of the overlay -- but don't effectively get rid of the overlay. If you think that could be what's happening, try temporarily suspending ad blocking on the site and reload the page, and dismiss the overlay. Usually a site will set a cookie so it doesn't show that same overlay over and over to someone who has already seen it. Once that cookie is set, you can try turning the ad blocker on again.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Actually, Firefox 45 is ready to release today but I don't think it "pushed" yet. You can install Firefox 44.0.2 right now if you like.

Actually, Firefox 45 is ''ready'' to release today but I don't think it "pushed" yet. You can install Firefox 44.0.2 right now if you like.

Người tạo câu hỏi

jscher2000 said

Firefox 45 just came out today as a final release, so you might not have a test version if you just updated. To see whether this is a problem with Firefox "painting" the tab, try zooming out and zooming back in: hold down Ctrl and press - twice, then + twice. Do you use any ad blockers? Some sites present an obnoxious whole window pop-up with an opaque background to force you to pay attention to their message. Ad blockers sometimes remove the message -- and the close button to get rid of the overlay -- but don't effectively get rid of the overlay. If you think that could be what's happening, try temporarily suspending ad blocking on the site and reload the page, and dismiss the overlay. Usually a site will set a cookie so it doesn't show that same overlay over and over to someone who has already seen it. Once that cookie is set, you can try turning the ad blocker on again.

I use Ad-Block Plus and thought that might be the problem, but I turned it off and refreshed and had the same issue. I will try the zooming trick. Thank you for your help.

''jscher2000 [[#answer-853063|said]]'' <blockquote> Firefox 45 just came out today as a final release, so you might not have a test version if you just updated. To see whether this is a problem with Firefox "painting" the tab, try zooming out and zooming back in: hold down Ctrl and press - twice, then + twice. Do you use any ad blockers? Some sites present an obnoxious whole window pop-up with an opaque background to force you to pay attention to their message. Ad blockers sometimes remove the message -- and the close button to get rid of the overlay -- but don't effectively get rid of the overlay. If you think that could be what's happening, try temporarily suspending ad blocking on the site and reload the page, and dismiss the overlay. Usually a site will set a cookie so it doesn't show that same overlay over and over to someone who has already seen it. Once that cookie is set, you can try turning the ad blocker on again. </blockquote> I use Ad-Block Plus and thought that might be the problem, but I turned it off and refreshed and had the same issue. I will try the zooming trick. Thank you for your help.

Người tạo câu hỏi

The zooming thing did nothing. It is strange - the page will load like normal but when it is finished, it just goes white a split second later.

The zooming thing did nothing. It is strange - the page will load like normal but when it is finished, it just goes white a split second later.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

I can't replicate the problem with my standard setup, which is Flash not activating automatically and NoScript blocking a considerable amount of the advertising. Could you investigate the white page as follows: right-click it, and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab, with an HTML tree diagram on the left side.

Let your eye adjust for a moment, then try clearing the white element by right-clicking the highlighted element and choosing Delete Node. If it doesn't go away, select the next higher element in the tree up and to the left and hover that. Does it select the white area as well? Try Delete Node on that one. At some point, you either will be able to see the page or you'll be at the <body> which means there is nothing left to remove.

Any interesting results?

I can't replicate the problem with my standard setup, which is Flash not activating automatically and NoScript blocking a considerable amount of the advertising. Could you investigate the white page as follows: right-click it, and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab, with an HTML tree diagram on the left side. Let your eye adjust for a moment, then try clearing the white element by right-clicking the highlighted element and choosing Delete Node. If it doesn't go away, select the next higher element in the tree up and to the left and hover that. Does it select the white area as well? Try Delete Node on that one. At some point, you either will be able to see the page or you'll be at the &lt;body> which means there is nothing left to remove. Any interesting results?

Người tạo câu hỏi

jscher2000 said

I can't replicate the problem with my standard setup, which is Flash not activating automatically and NoScript blocking a considerable amount of the advertising. Could you investigate the white page as follows: right-click it, and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab, with an HTML tree diagram on the left side. Let your eye adjust for a moment, then try clearing the white element by right-clicking the highlighted element and choosing Delete Node. If it doesn't go away, select the next higher element in the tree up and to the left and hover that. Does it select the white area as well? Try Delete Node on that one. At some point, you either will be able to see the page or you'll be at the <body> which means there is nothing left to remove. Any interesting results?

I am able to Inspect Element and when I Delete Node on the highlighted element, it doesn't seem to do anything.

''jscher2000 [[#answer-853125|said]]'' <blockquote> I can't replicate the problem with my standard setup, which is Flash not activating automatically and NoScript blocking a considerable amount of the advertising. Could you investigate the white page as follows: right-click it, and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab, with an HTML tree diagram on the left side. Let your eye adjust for a moment, then try clearing the white element by right-clicking the highlighted element and choosing Delete Node. If it doesn't go away, select the next higher element in the tree up and to the left and hover that. Does it select the white area as well? Try Delete Node on that one. At some point, you either will be able to see the page or you'll be at the &lt;body> which means there is nothing left to remove. Any interesting results? </blockquote> I am able to Inspect Element and when I Delete Node on the highlighted element, it doesn't seem to do anything.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Okay, maybe you can share that code to me on a site like Pastebin.

Please reload the page, inspect the element, then look "up" the HTML tree to the left until you get to what might be its main container. Then right-click that and Copy Outer HTML.

You then can paste the HTML code of that part of the document into a new paste on Pastebin:

http://pastebin.com/

Please read down through the code for any personal information and replace that with XYZ before submitting your paste.

Then you can share the URL of your paste back here.

Okay, maybe you can share that code to me on a site like Pastebin. Please reload the page, inspect the element, then look "up" the HTML tree to the left until you get to what might be its main container. Then right-click that and Copy Outer HTML. You then can paste the HTML code of that part of the document into a new paste on Pastebin: http://pastebin.com/ Please read down through the code for any personal information and replace that with XYZ before submitting your paste. Then you can share the URL of your paste back here.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Hmm, one other thing. I've been assuming it's an overlay issue, but there are some pages that use a script to fade the body in and out by manipulating the opacity style rule. For example, this site shows a loading animation then runs a script to fade to the real content:

https://europass.cedefop.europa.eu/editors/en/cv/compose

CBS Sports didn't look that fancy to me, but have you seen it do anything tricky in any other browser?

Hmm, one other thing. I've been assuming it's an overlay issue, but there are some pages that use a script to fade the body in and out by manipulating the opacity style rule. For example, this site shows a loading animation then runs a script to fade to the real content: https://europass.cedefop.europa.eu/editors/en/cv/compose CBS Sports didn't look that fancy to me, but have you seen it do anything tricky in any other browser?

Người tạo câu hỏi

jscher2000 said

Okay, maybe you can share that code to me on a site like Pastebin. Please reload the page, inspect the element, then look "up" the HTML tree to the left until you get to what might be its main container. Then right-click that and Copy Outer HTML. You then can paste the HTML code of that part of the document into a new paste on Pastebin: http://pastebin.com/ Please read down through the code for any personal information and replace that with XYZ before submitting your paste. Then you can share the URL of your paste back here.

I thought I followed your instructions but when I tried to create the paste, it said "You have exceeded the maximum paste size of 512 kilobytes per paste. PRO users don't have this limit!"

I am not sure I am copying the correct thing.

''jscher2000 [[#answer-853157|said]]'' <blockquote> Okay, maybe you can share that code to me on a site like Pastebin. Please reload the page, inspect the element, then look "up" the HTML tree to the left until you get to what might be its main container. Then right-click that and Copy Outer HTML. You then can paste the HTML code of that part of the document into a new paste on Pastebin: http://pastebin.com/ Please read down through the code for any personal information and replace that with XYZ before submitting your paste. Then you can share the URL of your paste back here. </blockquote> I thought I followed your instructions but when I tried to create the paste, it said "You have exceeded the maximum paste size of 512 kilobytes per paste. PRO users don't have this limit!" I am not sure I am copying the correct thing.

Người tạo câu hỏi

jscher2000 said

Hmm, one other thing. I've been assuming it's an overlay issue, but there are some pages that use a script to fade the body in and out by manipulating the opacity style rule. For example, this site shows a loading animation then runs a script to fade to the real content: https://europass.cedefop.europa.eu/editors/en/cv/compose CBS Sports didn't look that fancy to me, but have you seen it do anything tricky in any other browser?

No, it works fine in Explorer.

''jscher2000 [[#answer-853158|said]]'' <blockquote> Hmm, one other thing. I've been assuming it's an overlay issue, but there are some pages that use a script to fade the body in and out by manipulating the opacity style rule. For example, this site shows a loading animation then runs a script to fade to the real content: https://europass.cedefop.europa.eu/editors/en/cv/compose CBS Sports didn't look that fancy to me, but have you seen it do anything tricky in any other browser? </blockquote> No, it works fine in Explorer.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

You might be copying more than necessary, I don't really want to read 512KB of code! That does seem to confirm the content must be there, but is somehow being hidden.

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

You might be copying more than necessary, I don't really want to read 512KB of code! That does seem to confirm the content must be there, but is somehow being hidden. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])

Người tạo câu hỏi

jscher2000 said

You might be copying more than necessary, I don't really want to read 512KB of code! That does seem to confirm the content must be there, but is somehow being hidden. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. If Firefox is not running: Hold down the Shift key when starting Firefox. If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

First, thank you for all of the time and attention you have given me for this.

Second, re-starting in safe mode seems to fix the problem.

''jscher2000 [[#answer-853165|said]]'' <blockquote> You might be copying more than necessary, I don't really want to read 512KB of code! That does seem to confirm the content must be there, but is somehow being hidden. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]]) </blockquote> First, thank you for all of the time and attention you have given me for this. Second, re-starting in safe mode seems to fix the problem.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Giải pháp được chọn

Hmm, okay. Three things Safe Mode does that might be relevant are:

(1) Disable all extensions, not just Adblock. Possibly one of your other ones is causing this issue.

(2) Disable Firefox from using hardware acceleration. This works around possible incompatibilities with your graphics card/chipset driver software. To test whether this is the issue, you can try turning it off in Options:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available".

This takes effect the next time you exit Firefox and start it up again normally. Any difference?

(3) Disables page style customizations in any userContent.css file you might have in your settings folder. This file doesn't exist by default, so if you do not recall creating it, this probably is not applicable to your Firefox.

Hmm, okay. Three things Safe Mode does that might be relevant are: (1) Disable all extensions, not just Adblock. Possibly one of your other ones is causing this issue. (2) Disable Firefox from using hardware acceleration. This works around possible incompatibilities with your graphics card/chipset driver software. To test whether this is the issue, you can try turning it off in Options: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available". This takes effect the next time you exit Firefox and start it up again normally. Any difference? (3) Disables page style customizations in any userContent.css file you might have in your settings folder. This file doesn't exist by default, so if you do not recall creating it, this probably is not applicable to your Firefox.

Người tạo câu hỏi

jscher2000 said

Hmm, okay. Three things Safe Mode does that might be relevant are: (1) Disable all extensions, not just Adblock. Possibly one of your other ones is causing this issue. (2) Disable Firefox from using hardware acceleration. This works around possible incompatibilities with your graphics card/chipset driver software. To test whether this is the issue, you can try turning it off in Options: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available". This takes effect the next time you exit Firefox and start it up again normally. Any difference? (3) Disables page style customizations in any userContent.css file you might have in your settings folder. This file doesn't exist by default, so if you do not recall creating it, this probably is not applicable to your Firefox.

OK, going through Safe Mode I appear to have isolated the problem: I apparently had both AdBlock Plus (which I knew about and had disabled previously) and AdBlock Lite running at the same time. Disabling AdBlock Lite has allowed me to see www.cbssports.com again. Thanks to everyone - particularly jscher2000 - for your time and help. Sorry I am such a n00b.

''jscher2000 [[#answer-853205|said]]'' <blockquote> Hmm, okay. Three things Safe Mode does that might be relevant are: (1) Disable all extensions, not just Adblock. Possibly one of your other ones is causing this issue. (2) Disable Firefox from using hardware acceleration. This works around possible incompatibilities with your graphics card/chipset driver software. To test whether this is the issue, you can try turning it off in Options: "3-bar" menu button (or Tools menu) > Options In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available". This takes effect the next time you exit Firefox and start it up again normally. Any difference? (3) Disables page style customizations in any userContent.css file you might have in your settings folder. This file doesn't exist by default, so if you do not recall creating it, this probably is not applicable to your Firefox. </blockquote> OK, going through Safe Mode I appear to have isolated the problem: I apparently had both AdBlock Plus (which I knew about and had disabled previously) and AdBlock Lite running at the same time. Disabling AdBlock Lite has allowed me to see www.cbssports.com again. Thanks to everyone - particularly jscher2000 - for your time and help. Sorry I am such a n00b.
jscher2000
  • Top 10 Contributor
8684 giải pháp 70998 câu trả lời
Được đăng

Hi tiptonhr, thanks for reporting back!

Hi tiptonhr, thanks for reporting back!