Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I disable web push service connection?

  • 10 trả lời
  • 6 gặp vấn đề này
  • 109 lượt xem
  • Trả lời mới nhất được viết bởi MrToo

more options

In the description of the new web push notifications it says "Firefox maintains an active connection to a push service in order to receive push messages as long as it is open. The connection ends when Firefox is closed. On our server we store a randomized identifier for your browser"

I understand that I can keep Notifications disabled (which is the default), to never actually receive notifications, however, by the above wording (found at https://support.mozilla.org/en-US/kb/push-notifications-firefox?as=u&utm_source=inproduct#w_upgraded-notifications ) I assume that even if I don't enable Notifications, that even though the web push stuff is opt-in per website, even if I never opt in, Firefox will still be phoning home the entire time I'm running it. So it will have a log of every time I start FF, how long I had it on, and when I exited. (Granted it's randomized or whatever, but the concern still stands.)

I don't want that... Is there a way to disable this always-on connection?

Tất cả các câu trả lời (10)

more options

hello, you can set dom.push.enabled to false in about:config.

more options

Thanks,

what about these?

dom.webnotifications.enabled dom.webnotifications.serviceworker.enabled dom.push.connection.enabled

Are they related to web push, and should they be set to false (if one wanted to fully disable web push)

Does Firefox only connect to the push service if you are subscribed to a web push subscription, or does Firefox maintain an active connection to a push service as long as it is open regardless of that?

more options

soundwave said

what about these?

dom.webnotifications.enabled dom.webnotifications.serviceworker.enabled dom.push.connection.enabled

I don't see any harm in disabling those for now. In the future, they may have more features attached, so perhaps down the road disabling them all would break something.

Does Firefox only connect to the push service if you are subscribed to a web push subscription, or does Firefox maintain an active connection to a push service as long as it is open regardless of that?

If you choose to subscribe to a site's notifications, then Firefox would create a "service worker" process to monitor for notifications. Otherwise, I'm pretty sure it won't; that would be very wasteful of system and network resources.

more options

philipp said

hello, you can set dom.push.enabled to false in about:config.

This does not work for me, I still get frequent requests for push

more options

Hi MrToo, can you give a URL to an example page or two where you get the requests?

more options

jscher2000 said

Hi MrToo, can you give a URL to an example page or two where you get the requests?

Every time I go to https://mail.zoho.com. I can collect more if needed

more options

You can try to set dom.push.serverURL to an empty String value. That should prevent Firefox from connecting to the Push server.

more options

Hi MrToo, I don't have a Zoho account to test with.

Turning off the push feature doesn't disable all web notifications. For example, in the attached screenshot, I'm getting a permission panel for a non-push web notification that is only in effect while the site is loaded. To disable all non-push web notifications, there is a different preference to flip:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) Double-click the dom.webnotifications.enabled preference to switch its value from true to false

Note: If you just want to disable notifications on a session-by-session basis, you can turn on "Do Not Disturb" on the Options page. Either:

  • "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Type or paste about:preferences#content in the address bar and press Enter (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

more options

cor-el said

You can try to set dom.push.serverURL to an empty String value. That should prevent Firefox from connecting to the Push server.

Thanks, I like the idea.

more options

jscher2000 said

Hi MrToo, I don't have a Zoho account to test with. Turning off the push feature doesn't disable all web notifications. For example, in the attached screenshot, I'm getting a permission panel for a non-push web notification that is only in effect while the site is loaded. To disable all non-push web notifications, there is a different preference to flip: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste webno and pause while the list is filtered (3) Double-click the dom.webnotifications.enabled preference to switch its value from true to false Note: If you just want to disable notifications on a session-by-session basis, you can turn on "Do Not Disturb" on the Options page. Either:
  • "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Type or paste about:preferences#content in the address bar and press Enter (you can bookmark this for faster future access)
On the right side, under "Notifications", check the "Do not disturb me" box.

This is the solution I will try. If this fails, I will try cor-el's idea next. I was concerned a null url would result in errors.

Update: dom.webnotifications.enabled seems to be a working solution. No pop ups ever since.

Được chỉnh sửa bởi MrToo vào