Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How to stop firefox from saving images as JFIF files?

  • 7 trả lời
  • 1 gặp vấn đề này
  • 23 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Hi,

Recently whenever I save an image in firefox to my desktop or a desired folder, the image is saved as a jfif file. This makes it complicated to upload images to my website and I now need to convert all the files before I can use them. It doesn't matter if I "save as" or drag and drop, the result is the same. How can I stop this from happening? I don't want to switch browsers as I've always used firefox but this issue poses a major inconvenience for me when I'm working.

Tất cả các câu trả lời (7)

more options

Does this occur on all image (JPEG, PNG, GIF, etc.)?

If you save the test image from here, does it save as a JFIF or JPG?


Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Tried safe mode but the problem persists, and yes its with all image types. I saved the sample photo you provided and just the same with all the other images it saved as jfif again. I've also done a refresh to firefox and that has not helped either. Thanks for for your suggestion though, appreciated.

more options

This is a very strange issue that I've never saw before.

This leads me to believe that you may have an infection on your computer that is causing these issues. Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

JFIF is the code as you see in the file header in a JPG file. If the file extension is wrong then you would normally only have to rename the file and give it the correct .jpg file extension.

more options

Wesley Branton said

This is a very strange issue that I've never saw before. This leads me to believe that you may have an infection on your computer that is causing these issues. Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already. Further information can be found in the Troubleshoot Firefox issues caused by malware article. Did this fix your problems? Please report back to us!

I've ran malwarebytes and found nothing, i'm running Windows 10 and the anti-virus is also enabled. I have no clue whats going on.

more options

cor-el said

JFIF is the code as you see in the file header in a JPG file. If the file extension is wrong then you would normally only have to rename the file and give it the correct .jpg file extension.

I tried that but to no avail, I also tested the same images across Firefox and Chrome, the images save as normal with Chrome. When I try to save the same image from the same source with Firefox the file is saved as jfif again. I've also reinstalled the pr0gram after deleting the old data folder and that has not helped either.

more options

How are you converting the files?

Did you compare the two files to see in what way they differ?

With what file extension does the file get saved?

Được chỉnh sửa bởi cor-el vào