Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How to disable on-hover actions?

  • 6 trả lời
  • 4 gặp vấn đề này
  • 70 lượt xem
  • Trả lời mới nhất được viết bởi danokra@frontier.com

more options

How to disable on-hover actions? ..or at least activate them on-click?

some web-pages are really aggressivly open HUGE (almost full screen) menus when i just hover with my mouse above the page not clicking anything. I want to disable this aggressive and annoying behavior. How?

Related: How do I disable moving images on web-page? I do not want anything to move without my command.

All Replies (6)

more options

Hmm, there isn't a simple general way to suppress menus that appear on hover (style-based menus) or mouseover (script-based menus). Have you searched for one or more add-on to tackle these symptoms?

https://addons.mozilla.org/firefox/

For the moving images, some may be animated GIF files, some may be MP4 movies triggered by being scrolled into view, and some may be animations. Websites have gotten very creative in their attempts to get our attention. There are a couple internal settings to consider:

Animated GIF images

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ANIM and pause while the list is filtered

(3) Double-click the image.animation_mode preference and enter the desired value:

  • none - never animates
  • once - animates once only
  • normal - animates based on the internal settings of the file

Note that this can't be overridden within the context of the page, in other words, it isn't paused until want to animate it, it's dead.

Video autoplay

There is an internal setting for this, but you might want to use the Flash Control extension instead: https://addons.mozilla.org/firefox/addon/flash-control/

more options

jscher2000, thanks for your answer!

Searching for "hover" in add-ons does not deliver any good results. Searching in about:config too. I have noflash add-on installed. I guess the images are moved by JavaScript.

Let's look at it from different point of view. If I use smartphone, I use my finger instead of a mouse. I can lift the finger above the screen, but mouse I cannot. How can I emulate a finger using a mouse? In other words, how to tell Firefox to ignore all motions (consider them as happening above the screen) except clicks?

Được chỉnh sửa bởi goldobin vào

more options

Hi goldobin, NoFlash changes the player but doesn't pause it until you approve it playing. That's what Flash Control does.

If I use smartphone, I use my finger instead of a mouse. I can lift the finger above the screen, but mouse I cannot. How can I emulate a finger using a mouse? In other words, how to tell Firefox to ignore all motions (consider them as happening above the screen) except clicks?

I don't know of a way to do that off the top of my head. There are techniques to inject scripts into page to intercept and discard events, but mouseover, mouseout, and mousemove are triggered extremely often and it could really bog things down intercepting them all the time on every page, so I haven't tried to see whether that would even work in this case.

more options

Using the control panel to uncheck the hover function of the mouse had no results. When I try ti reconfigure ELAN for mouse screen function my screen freezes up. Just scrolling over the mouse button freezes up my windows 8.1 devise. I need help with this or this new computer will be a boat anchor.

more options

Hi dano999, the only thing I remember about Elantech is that Firefox has a special preference you can change to prevent Firefox from detecting "gestures":

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ELAN and pause while the list is filtered

(3) Double-click the ui.elantech_gesture_hacks.enabled preference and change the value to 0 (that's a zero) and OK the change

I don't know whether that takes effect immediately or after you exit Firefox and start it up again.

If that doesn't help, could you start a new question, since it seems your situation seems somewhat unique if there are problems outside of Firefox. You can use the "Ask a Question" link at the top of each page on the support site.

more options

I changed the setting on the gesture/hack per your suggestion . It was set at _0 (that is minus zero) originally from the factory setting. I reset it to zero. Some of my hovering issues are solved, the one that automatically deletes the next email message for one. But the cursor still has a mind o And sometimes in the middle of it's own and will jump to a middle of an email if I use the space bar. Sometimes it will jump to the delete message and all my writing is gone. I suspect I will need to look further to fix this. So far I am not liking windows 8 .

Được chỉnh sửa bởi danokra@frontier.com vào