X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Tor Browser won't let me set Master Password

Được đăng

Tor Browser won't let me set Master Password

Tor Browser won't let me set Master Password

Giải pháp được chọn

Thank you FredMcD for your time and effort. I spent all morning perusing the many entries in the link you provided. Unfortunately, none of them were able to solve the problem--directly.

However...

I learned so much about all the obscure and esoteric settings available and how to manipulate them that I was able to intuitively synthesize a solution:

  • First, I thoroughly removed all traces of Tor with an advanced uninstaller.
  • After reinstalling, the browser did its usual first-run routine and opened.
  • A first-time info bar near the top offered access to Privacy & Security.
  • I ACCEPTED and unchecked the first box (disabling Private Browsing).
  • The program restarted itself and I was able to set my Master Password.

Private Browsing, as well as permanent Private Browsing, can be manipulated back on and then off again at the user's convenience, depending on the needs of any particular situation. Be advised, though, that under any form of PB, password usage and storage is suppressed.

It should be noted that I did all the above steps (and many other things) throughout the course of my troubleshooting, but only AFTER I'd already started using the browser (by playing around and checking out various options), which I believe automatically set some of my Profile preferences before I could manually do so. Alternatively, it may have been a bad install in the first place (doubtful), or a combination of these factors. Either way, it worked.

As for the Support services within the Mozilla umbrella, I am impressed by the volume and diversity of information contained here, as well as the caring nature of Good Samaritans such as yourself. However, almost all of the material I've encountered is Firefox/Thunderbird-centric.

A search for Tor showed very little data, and nothing remotely similar to my case. By its very nature, a program like Tor would naturally default to an option like Private Browsing. But how many people know that doing so kills the ability to use passwords? Even though the Tor Project is based on the Mozilla engine, I think the people who run the project should either set up their own Support system or lend a hand here, and not pass the buck to well-meaning benefactors like you and your associates.

But in any event--problem solved, thanks to you and those like you lending time and advice to a perfect stranger.

Now all I have to do is find some extra time to monitor these pages so that, maybe someday, I can return the favor.

O

Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 19.0 r0

Ứng dụng

  • Firefox 38.4.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/38.4.0/WINNT/en-US/

Tiện ích mở rộng

  • HTTPS-Everywhere 5.0.7 (https-everywhere@eff.org)
  • NoScript 2.6.9.39 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Torbutton 1.9.3.5 (torbutton@torproject.org)
  • TorLauncher 0.2.7.7 (tor-launcher@torproject.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x22b1
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 8-4-2015
  • driverDate2:
  • driverVersion: 10.18.15.4248
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
FredMcD
  • Top 10 Contributor
4254 giải pháp 59582 câu trả lời
Được đăng

What happens when you try?

What happens when you try?
Được đăng

Người tạo câu hỏi

See Screenshot.

I tried with admin privileges, safe mode & "refreshed" (all add-ons removed and settings returned to default values) with no luck.

I'm running Win10.

See Screenshot. I tried with admin privileges, safe mode & "refreshed" (all add-ons removed and settings returned to default values) with no luck. I'm running Win10.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59582 câu trả lời
Được đăng

See if any of these articles can help.

See if any of these articles can help.
Được đăng

Người tạo câu hỏi

OK...

Which articles and where?

OK... Which articles and where?
FredMcD
  • Top 10 Contributor
4254 giải pháp 59582 câu trả lời
Được đăng
Opps, sorry https://support.mozilla.org/en-US/search?esab=a&w=1&q=Master%20Password
Được đăng

Giải pháp được chọn

Thank you FredMcD for your time and effort. I spent all morning perusing the many entries in the link you provided. Unfortunately, none of them were able to solve the problem--directly.

However...

I learned so much about all the obscure and esoteric settings available and how to manipulate them that I was able to intuitively synthesize a solution:

  • First, I thoroughly removed all traces of Tor with an advanced uninstaller.
  • After reinstalling, the browser did its usual first-run routine and opened.
  • A first-time info bar near the top offered access to Privacy & Security.
  • I ACCEPTED and unchecked the first box (disabling Private Browsing).
  • The program restarted itself and I was able to set my Master Password.

Private Browsing, as well as permanent Private Browsing, can be manipulated back on and then off again at the user's convenience, depending on the needs of any particular situation. Be advised, though, that under any form of PB, password usage and storage is suppressed.

It should be noted that I did all the above steps (and many other things) throughout the course of my troubleshooting, but only AFTER I'd already started using the browser (by playing around and checking out various options), which I believe automatically set some of my Profile preferences before I could manually do so. Alternatively, it may have been a bad install in the first place (doubtful), or a combination of these factors. Either way, it worked.

As for the Support services within the Mozilla umbrella, I am impressed by the volume and diversity of information contained here, as well as the caring nature of Good Samaritans such as yourself. However, almost all of the material I've encountered is Firefox/Thunderbird-centric.

A search for Tor showed very little data, and nothing remotely similar to my case. By its very nature, a program like Tor would naturally default to an option like Private Browsing. But how many people know that doing so kills the ability to use passwords? Even though the Tor Project is based on the Mozilla engine, I think the people who run the project should either set up their own Support system or lend a hand here, and not pass the buck to well-meaning benefactors like you and your associates.

But in any event--problem solved, thanks to you and those like you lending time and advice to a perfect stranger.

Now all I have to do is find some extra time to monitor these pages so that, maybe someday, I can return the favor.

O

Thank you FredMcD for your time and effort. I spent all morning perusing the many entries in the link you provided. Unfortunately, none of them were able to solve the problem--directly. However... I learned so much about all the obscure and esoteric settings available and how to manipulate them that I was able to intuitively synthesize a solution: * First, I thoroughly removed all traces of Tor with an advanced uninstaller. * After reinstalling, the browser did its usual first-run routine and opened. * A first-time info bar near the top offered access to Privacy & Security. * I ACCEPTED and unchecked the first box (disabling Private Browsing). * The program restarted itself and I was able to set my Master Password. Private Browsing, as well as permanent Private Browsing, can be manipulated back on and then off again at the user's convenience, depending on the needs of any particular situation. Be advised, though, that under any form of PB, password usage and storage is suppressed. It should be noted that I did all the above steps (and many other things) throughout the course of my troubleshooting, but only AFTER I'd already started using the browser (by playing around and checking out various options), which I believe automatically set some of my Profile preferences before I could manually do so. Alternatively, it may have been a bad install in the first place (doubtful), or a combination of these factors. Either way, it worked. As for the Support services within the Mozilla umbrella, I am impressed by the volume and diversity of information contained here, as well as the caring nature of Good Samaritans such as yourself. However, almost all of the material I've encountered is Firefox/Thunderbird-centric. A search for Tor showed very little data, and nothing remotely similar to my case. By its very nature, a program like Tor would naturally default to an option like Private Browsing. But how many people know that doing so kills the ability to use passwords? Even though the Tor Project is based on the Mozilla engine, I think the people who run the project should either set up their own Support system or lend a hand here, and not pass the buck to well-meaning benefactors like you and your associates. But in any event--problem solved, thanks to you and those like you lending time and advice to a perfect stranger. Now all I have to do is find some extra time to monitor these pages so that, maybe someday, I can return the favor. O
FredMcD
  • Top 10 Contributor
4254 giải pháp 59582 câu trả lời
Được đăng

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.
Được đăng

Người tạo câu hỏi

Done.

O

Done. O