Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why Firefox can't display the right contents that IE does well?

  • 19 trả lời
  • 3 gặp vấn đề này
  • 359 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

It's been long time. Every time firefox was directed to the page for papers (not only this one but every paper link), it appears like the screen shot. I thought it was the webpage issue until I used the IE. IE shows everything correctly but not Firefox.

What settings I did wrong?

Thanks.

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

The server is sending the content type text/css, you should not have to override it.

Are you accessing the site through any proxy that might be modifying the content-type header?

As a temporary workaround, you can have Firefox tell the server you do not accept gzip'ed output. This will increase download times for some files, but if this site is important to you, you could use it for the time being until a solution is found.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste encod and pause while the list is filtered

(3) Double-click the network.http.accept-encoding preference and delete gzip and the comma after it and click OK to save the change (to restore the default value later, you can right-click > Reset the preference)

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (19)

more options
more options

Looks fine here.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks for the tips. But none worked for this problem.

more options

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect in case security software is blocking content.

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

more options

Can you load the style sheet used by the page directly in a tab? Test by clicking this link:

http://d22izw7byeupn1.cloudfront.net/development/journals/stylesheets/prl-856a1cf6.css.gz

A successful load is a wall of text starting with:

@charset "UTF-8";/*! normalize.css v2.1.3 | MIT License |

Edit: added a screen shot

Được chỉnh sửa bởi jscher2000 vào

more options

cor-el said

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect in case security software is blocking content. You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

1. Safe mode doesn't work. 2. Web Console looks like this, seems non-zero:

more options

Hi Jones.us, cor-el meant to open the Web Console in the same tab as http://journals.aps.org/prl/abstract/10.1103/PhysRevLett.87.071301 and then click Network along the top edge of the console and reload the page so that the Network Monitor shows the results of trying to load the page.

more options

jscher2000 said

Can you load the style sheet used by the page directly in a tab? Test by clicking this link: http://d22izw7byeupn1.cloudfront.net/development/journals/stylesheets/prl-856a1cf6.css.gz A successful load is a wall of text starting with: @charset "UTF-8";/*! normalize.css v2.1.3 | MIT License | Edit: added a screen shot

The firefox has a "content type" for .gz I seem not able to remove it from the list.

more options

The entries in that list on the Applications panel are stored in the mimeTypes.rdf file, an XML-format file in your settings folder. Since it is difficult to edit, when there is a problem, we generally suggest renaming the file and allowing Firefox to rebuild it from the Windows registry. That may not help if it's coming from the registry, but I think it's worth a try:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old (or another name of your choosing, in case you decide to roll back this experiment).

Start Firefox back up again. Can Firefox now handle gzipped style sheets as intended?

more options

jscher2000 said

Hi Jones.us, cor-el meant to open the Web Console in the same tab as http://journals.aps.org/prl/abstract/10.1103/PhysRevLett.87.071301 and then click Network along the top edge of the console and reload the page so that the Network Monitor shows the results of trying to load the page.

Thanks jscher2000 and cor-el !

Attached is the screen shot. I'm not a developper and it's the first time I know this function and don't know what it is. Please help to interprete.

more options

Jones.us said

jscher2000 said
Can you load the style sheet used by the page directly in a tab? Test by clicking this link: http://d22izw7byeupn1.cloudfront.net/development/journals/stylesheets/prl-856a1cf6.css.gz A successful load is a wall of text starting with: @charset "UTF-8";/*! normalize.css v2.1.3 | MIT License | Edit: added a screen shot

The firefox has a "content type" for .gz I seem not able to remove it from the list.

I think the problem is here: see the MIME type application for .gz in attached screen shot.

The same problem to open your link endind with .gz

How to remove this .gz content type handling from Firefox's application list?

Thanks again.

more options

What do you see in Tools > Page Info > General when you open the file in a Firefox tab?

The server sends the file correctly as text/css. I see this response in the Network Monitor.

Content-Encoding: gzip
Content-Length: 31714
Content-Type: text/css
Server: AmazonS3
Via: 1.1 e604e934e9195aaf3e36195adbcb3e18.cloudfront.net (CloudFront)
X-Amz-Cf-Id: fEdm3b8vpMh1lCBk7N8V4plEJ9t_UpVliTfcgn3oqsU5ko-5Yrssvg==
X-Cache: Hit from cloudfront

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

Could you bypass the cache the next time you reload the page? You can use Ctrl+Shift+r and the "304" coded files used from cache should be replaced by "200" coded files retrieved again from the server.

Not sure that will help, though. The ones for which you have a content type of gz definitely should say css or js as in the attached screen shot and be sent with the appropriate content-type header.

Are you accessing the site through any proxy that might be modifying the content-type header?

more options

I have such an item as well and it shouldn't interfere with loading a CSS file that is used on a website. Unfortunately the applications tab doesn't show the MIME type of each entry, that would probably be application/x-gzip (see the mimeTypes.rdf file) and it would only have effect if you left-click a file link that the server sends with this content type.

more options

I think the problem is still the .gz application mime type. after rename the mimetypes.rdf the .gz type is gone but I guess it needs to manually changed to "text/css". See attached screen shot.

Can you please help on how to add this?

Thanks again.

more options

Giải pháp được chọn

The server is sending the content type text/css, you should not have to override it.

Are you accessing the site through any proxy that might be modifying the content-type header?

As a temporary workaround, you can have Firefox tell the server you do not accept gzip'ed output. This will increase download times for some files, but if this site is important to you, you could use it for the time being until a solution is found.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste encod and pause while the list is filtered

(3) Double-click the network.http.accept-encoding preference and delete gzip and the comma after it and click OK to save the change (to restore the default value later, you can right-click > Reset the preference)

more options

What does the Network tab show as the raw HTTP response headers of this file?

more options

jscher2000 said

The server is sending the content type text/css, you should not have to override it. Are you accessing the site through any proxy that might be modifying the content-type header? As a temporary workaround, you can have Firefox tell the server you do not accept gzip'ed output. This will increase download times for some files, but if this site is important to you, you could use it for the time being until a solution is found. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste encod and pause while the list is filtered (3) Double-click the network.http.accept-encoding preference and delete gzip and the comma after it and click OK to save the change (to restore the default value later, you can right-click > Reset the preference)

Thank you jscher2000, this resolved the problem. The browser pass through the university proxy. However IE too, but IE works fine.

more options

Jones.us said

The browser pass through the university proxy. However IE too, but IE works fine.

Microsoft has a strong history of "covering up" for content-type problems in IE by reading the beginning part of the content and switching its handling based on what it finds. That may be how IE is working around this issue.