Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

On startup, firefox opens a blank tab instead of my home page

  • 4 trả lời
  • 8 gặp vấn đề này
  • 38 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

My home page is set in Tools and all was working normally until I started up firefox today and a blank tab appeared instead of my home page. I've closed and opened the browser many times, also rebooted the computer, and the problem persists. The other tabs that open from the tab bar are set correctly and working normally. Is there a line in about:config that could fix this? I've used it successfully for tabs (browser.newtab.URL), but not until I researched and was confident I was doing it right.

All Replies (4)

more options

Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display. Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want displayed.

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

more options

You can update to Firefox 41 via "Help > About".

The browser.newtab.url pref is no longer supported in Firefox 41 and later, so you can no longer use this to set the new tab page.

You can look at this extension to set the new tab page:

You can set the new tab URL setting via the Options/Preferences of the extension on the about:addons page. The Classic Theme Restorer includes this feature as well, so if you have this extension then see General UI (2)

You can use these special pages for the URL of your preferred new tab page.

  • the default new tab page with the tiles is about:newtab
  • the default home page is about:home
  • for a blank page you can use about:blank

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the current Firefox profile folder:

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu.

more options

It's cool that about:preferences#general is another way than simply clicking "Tools" to bring up the same tools/options/general that I originally used to set startup to my home page. However, doing the same thing I already did does not alter the situation. I also tried "Use Bookmark" as I happen to have ixquick bookmarked, and of course it simply set the very same home page that I had at the start. So still, when I click on any version of firefox startup (task bar, startup menu, or shortcut, it brings up a blank tab. Even though in Tools, Options, General my home page is set for https://www.ixquick.com/

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.