Search Support

Firefox does not open .html files while running, but...

  • 10 trả lời
  • 1 gặp vấn đề này
  • 26 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

...it opens .html files when it's not running.

1. .html files are set to default to be opened by Firefox. 2. Click on any .html file (or a link in Thunderbird or any other program) and nothing happens. 3. Nothing happens if Firefox is running for first time since computer was started and user logged in. 4. If you close Firefox or restart it via console, then it all starts working and opens .html with no problem. 5. What is this magic and why do I need to keep restarting Firefox each time to fix this? 6. Firefox is clean installed. I did try safe boot with no addons.

All Replies (10)

more options

Open Windows Internet Explorer. Have it declared the default browser. Then close it. Open Firefox, and do the same here. Then close. After, test with a HTML file.

more options

Didn't solve it. Still had to restart Firefox to make it work again, just like everytime I boot the PC.

more options

If it helps, I tracked it down that this happens only when I run Firefox via Task Scheduler scheduled to launch on user Log in on Windows startup. So it has something to do with that.

more options

Open the Task Scheduler. Carefully copy that command. Open the Actions menu. Copy the Program/Script and the Options. And post it here.

more options

Program/Script: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" Add Arguments: "https://www.facebook.com/" "https://twitter.com/" "https://www.google.com/ncr" (to open tabs on launch)

Exported .xml:

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2015-09-21T20:49:18.54831</Date>
    <Author></Author>
  </RegistrationInfo>
  <Triggers>
    <LogonTrigger>
      <Enabled>true</Enabled>
      <UserId></UserId>
    </LogonTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <UserId></UserId>
      <LogonType>InteractiveToken</LogonType>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>false</AllowHardTerminate>
    <StartWhenAvailable>true</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>false</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
    <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>PT0S</ExecutionTimeLimit>
    <Priority>7</Priority>
    <RestartOnFailure>
      <Interval>PT1M</Interval>
      <Count>3</Count>
    </RestartOnFailure>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"</Command>
      <Arguments>"https://www.facebook.com/" "https://twitter.com/" "https://www.google.com/ncr"</Arguments>
    </Exec>
  </Actions>
</Task>

Được chỉnh sửa bởi cor-el vào

more options

rhazor said

Program/Script: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
Add Arguments: "https://www.facebook.com/" "https://twitter.com/" "https://www.google.com/ncr"

And all three open, Yes?

more options

As you saw, I do the same as you, and have had no problem. I've called the big guys to help you. Good luck.

more options

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).