X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

How do I stop Firefox from automatically trying to update without my permission, every time I open it?

Được đăng

I've selected in the update tab under the advanced options to never check for updates, none of which I will ever want to download, never had the Maintenance Service installed, and also confirmed that the values of such preferences of "app.update.auto, app.update.enabled, app.update.silent" are set to false in about:config as I was told they should be. Yet, EVERY time I open Firefox, Firefox automatically tries to update itself, prompting User Account Control to ask my permission for Firefox to make changes (the upgrade) to my computer. I do not want to have to click no every time I'm asked this because Firefox tries to update itself WITHOUT MY PERMISSION. What can I do to stop this?

I've selected in the update tab under the advanced options to never check for updates, none of which I will ever want to download, never had the Maintenance Service installed, and also confirmed that the values of such preferences of "app.update.auto, app.update.enabled, app.update.silent" are set to false in about:config as I was told they should be. Yet, EVERY time I open Firefox, Firefox automatically tries to update itself, prompting User Account Control to ask my permission for Firefox to make changes (the upgrade) to my computer. I do not want to have to click no every time I'm asked this because Firefox tries to update itself WITHOUT MY PERMISSION. What can I do to stop this?

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 18.0 r0

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4342 giải pháp 61072 câu trả lời
Được đăng

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced,''' Select '''Update.''' Check the settings.

Người tạo câu hỏi

Did you not read a thing I said in my post, FredMcD? Refer to the first sentence I wrote.

Did you not read a thing I said in my post, FredMcD? Refer to the first sentence I wrote.
FredMcD
  • Top 10 Contributor
4342 giải pháp 61072 câu trả lời
Được đăng

Because of the "age" of your version, it may be forced updating.

I've called the big guys to help you. Good luck.

Because of the "age" of your version, it may be forced updating. I've called the big guys to help you. Good luck.
the-edmeister
  • Top 25 Contributor
  • Moderator
5425 giải pháp 40502 câu trả lời
Được đăng

Based upon what you posted, Firefox shouldn't be trying to update. Have you set those prefs in all user accounts on that PC? Those prefs are unique to each Firefox Profile - one Profile with the default settings will "screw the pooch". The Maintenance Service will affect all Profiles equally - and there's two executables for it in Program Files the exe and the installer.exe.

Overall life is too short to "argue" with software that doesn't follow your preferences - Mozilla is "hell bent" on keeping their users secure by automatically installing updates to fix known security faults. Why not use a different browser that does respect your preferences?

Based upon what you posted, Firefox shouldn't be trying to update. Have you set those prefs in all user accounts on that PC? Those prefs are unique to each Firefox Profile - one Profile with the default settings will "screw the pooch". The Maintenance Service will affect all Profiles equally - and there's two executables for it in Program Files the exe and the installer.exe. Overall life is too short to "argue" with software that doesn't follow your preferences - Mozilla is "hell bent" on keeping their users secure by automatically installing updates to fix known security faults. Why not use a different browser that does respect your preferences?

Người tạo câu hỏi

It shouldn't be. However, it does, every time when I open the browser. There's only one user on my computer so different settings between more than one of could not be the cause of the problem. Firefox is simply disregarding anything I prefer it not to do. As to why I don't want to use a browser that actually respects what the user wants, the version of Firefox which I'm currently using, Firefox 31.0, is the only one I like to use after the internet abandoned Internet Explorer 7, or whichever version of that was. I'll have to settle for something else, sadly.

It shouldn't be. However, it does, every time when I open the browser. There's only one user on my computer so different settings between more than one of could not be the cause of the problem. Firefox is simply disregarding anything I prefer it not to do. As to why I don't want to use a browser that actually respects what the user wants, the version of Firefox which I'm currently using, Firefox 31.0, is the only one I like to use after the internet abandoned Internet Explorer 7, or whichever version of that was. I'll have to settle for something else, sadly.