Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Why has recent W10 integration left me without any add-ons or Privacy Window?

  • 8 trả lời
  • 2 gặp vấn đề này
  • 178 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

My recent migration to Windows 10 went without a hitch. Then Firefox had upgrades and security updates. In this process all add-ons were disabled and cannot be activated. I get a script issue notification occasionally. Also Private Window won't work. Are these issues likely to be resolved soon or do I have to take some further action?

Giải pháp được chọn

The privacy settings apply to all windows. But private windows have a separate "cookie jar" which is shared between them and emptied when you close all the private windows.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

You are on the beta track. Let me discuss add-ons first:

As you've noticed, Firefox 41 requires that extensions be signed by Mozilla, which follows a brief review process. Presumably the publishers of many of your extensions that before Firefox 41 is officially released in about 5 weeks.

Would you want to run the current release, Firefox 40.0.2, instead of the beta test release? It doesn't block unsigned extensions. You can grab that here (scroll down to your preferred language): https://www.mozilla.org/firefox/all/

Alternately, you can flip a setting that exists only in Firefox 41 to allow unsigned extensions. That can be found here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpi and pause while the list is filtered

(3) Double-click the xpinstall.signatures.required preference to switch it from true to false

Does one of those suggestions resolve the issue?

more options

Could you describe the problem with private windows in more detail? For example:

  • Can't open a new private window from the menu or using Ctrl+Shift+p
  • Right-click, Open Link in New Private Window doesn't do anything
  • Private windows open but do not load pages
  • Something else

For the script issue notification, could you make a note of what it is the next time you see it, or grab a screen shot of it?

more options

By the way, if you decide to switch to the release track, I suggest doing it this way:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 40.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\Fx41

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\Fx41

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Success?

Note: Some plugins may exist only in that Fx41 folder. If something essential is missing, look in these folders:

  • \Fx41\Plugins
  • \Fx41\browser\plugins
more options

jscher2000 said

Could you describe the problem with private windows in more detail? For example:
  • Can't open a new private window from the menu or using Ctrl+Shift+p
  • Right-click, Open Link in New Private Window doesn't do anything
  • Private windows open but do not load pages
  • Something else

I got your message that "PW opens for a few seconds then closes."

That's strange, I can't think of what would cause that. Especially if normal new window are left unmolested.

more options

Thanks, your email prompted me to look much closer at what is happening.

It is opening a duplicate FX without a tab for Private viewing with the other tabs. Same results no matter what instruction is used to request a private tab.

Does this help?

more options

That's even stranger... Is it possible that the private window is minimized or hidden behind the main Firefox window?

If you have Firefox set to start up automatically in private mode, then it does behave differently from having a regular session and opening a private window. Seems you would notice the difference, but please check your setting here just in case:

"3-bar" menu button (or Tools menu) > Options > Privacy

If the selector says "Firefox will: Never remember history" then Firefox using automatic private browsing. You can change that to "Firefox will: Use custom settings for history" and uncheck the box for automatic private browsing to switch back.

more options

OK, progress and resolution.

I was using Firefox will: Use custom settings for history but had the box checked. Unchecking it has solved the issue.

I am curious. Do the instructions on this page apply only to Private Window or generally across Firefox.

I realyy appreciate your efforts on my behalf. Sincere thanks. I rarely use Private but hate it when anyhting is unreliable.

more options

Giải pháp được chọn

The privacy settings apply to all windows. But private windows have a separate "cookie jar" which is shared between them and emptied when you close all the private windows.