Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Hardware acceleration in Windows 10 is not working - NVIDIA

  • 6 trả lời
  • 31 gặp vấn đề này
  • 2407 lượt xem
  • Trả lời mới nhất được viết bởi philipp

more options

High CPU usage on Youtube - hardware acceleration not working. (Windows 10 - NVIDIA)

about:support - http://i.imgur.com/Y8V2UoU.png?1

Firefox - http://i.imgur.com/jTXKaEt.png

Chrome - http://i.imgur.com/rquAwzL.png

Edge - http://i.imgur.com/CtFVnFk.png

Tất cả các câu trả lời (6)

more options

hi, it is unfortunate, but since this driver version is responsible for a widespread crashing issue for people updating to windows 10, it is blocklisted for hardware acceleration, until this problem is resolved...

however the issue on youtube might be of a different nature - if you look at your graphics section in about:support it says "supports hardware h264 decoding: false", which sounds a bit like bug 1178098

more options

Hi philipp,

With regard to the youtube issue, it is only that when I updated my Firefox did the problem exists. Even the appearance of fonts were affected as I think because of the DirectWrite.

Just a note. All browsers posted above used HTML5 during the test.

Thank you

more options

yes, it is expected that the change is just recognizable after the update to firefox 40, since 39 was not tweaked to process win10 specific blocklist entries yet.

in case you didn't have a crashing problem before, you might look at https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#How_to_force-enable_blocked_graphics_features in order to re-enable Direct2D/layers acceleration.

more options

I came with an interesting yet confusing result. I tried to force enable the blocked graphics features:

- webgl.force-enabled=true. - webgl.msaa-force=true. - layers.acceleration.force-enabled=true. - gfx.direct2d.force-enabled=true.

Then after restarting Firefox, it would only display a white screen with only the minimize, maximize and close buttons present. So I run Firefox into safe-mode and revert the graphics features to disabled.

- Now the "supports hardware h264 decoding: false" is set to "true" - Fonts returned to normal even if DirectWrite is still disabled in the config. - CPU usage on youtube returned to normal.

about:config - http://i.imgur.com/occz3Lo.png Normal CPU usage - http://i.imgur.com/L6tI6gR.png

However using this test produced another result -https://developer.mozilla.org/media/uploads/demos/p/a/paulrouget/8bfba7f0b6c62d877a2b82dd5e10931e/hacksmozillaorg-achi_1334270447_demo_package/HWACCEL/

Before - High CPU usage (30%+) 30-45fps After - Lower CPU usage but still higher than normal (28%) but 60fps

more options

This seems to now be fixed with the release of FF 40.0.2, when used in conjunction with Nvidia Windows 10 (355.60 for desktops) drivers.

more options

the blocklist entry for the nvidia driver was removed - this isn't tied to a particular release, since firefox installations will update the blocklist once every day...