Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Recently, My home page changes to Google search page on its own.

  • 1 trả lời
  • 1 gặp vấn đề này
  • 4 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

I have gone to the option section in the menu and re-identify CNN as my home page but it does not stick. Also I have tried copying the CNN tab to the HOME symbol but this too does not work after a period of time.

All Replies (1)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Google Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.