Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox opens automatically to MSN.com

  • 1 trả lời
  • 2 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi guigs

more options

This problem happens when I switch networks. I sometimes need to hop on my phone's hotspot to open a program, after which I switch back to my Verizon hotspot. When I switch from my phone hotspot back to the Jetpack hotspot, sometimes nothing happens, but other times, Firefox opens automatically without me clicking the icon, and it opens to MSN.com--even though I have never been to MSN.com and do not have it set as my homepage. So far, I have tried making my homepage a blank page in Options. When I open Firefox myself, I now have a blank page instead of the homepage, so I know it worked. I disabled the plugin from Cisco and that seemed to work for a while. Now it has started happening again; I do not understand why, and I do not want MSN as my homepage. I also do not want Firefox to open automatically without me doing anything. That's really creepy.

All Replies (1)

more options

It could be the homepage of the proxy that the hotspot uses to authenticate you on the network. Ask them too if you do not see any malware that would give the impression.