X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Spinner box controls not displaying

Được đăng

One installation of Firefox 38.0.5 on windows 8.1 does not display spinner box controls (see attached image). They are there but with 1 or 2 pix height as clicking the grey bar sometimes increases and sometimes decreases the numeric value.

Tried creating a new profile with no addons. Same problem. Haven't tried reinstalling Firefox yet.

This is not a problem with the website as this occurs on all sites with this type of form element.

It is also probably not a Firefox bug as I have Firefox 38.0.5 on Windows 7 at work that displays these form elements correctly.

Zoom (Ctrl +/-) does not change the erroneous appearance of the controls.

Any idea how to fix this?

One installation of Firefox 38.0.5 on windows 8.1 does not display spinner box controls (see attached image). They are there but with 1 or 2 pix height as clicking the grey bar sometimes increases and sometimes decreases the numeric value. Tried creating a new profile with no addons. Same problem. Haven't tried reinstalling Firefox yet. This is not a problem with the website as this occurs on all sites with this type of form element. It is also probably not a Firefox bug as I have Firefox 38.0.5 on Windows 7 at work that displays these form elements correctly. Zoom (Ctrl +/-) does not change the erroneous appearance of the controls. Any idea how to fix this?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can try a different Windows them is case Firefox has a problem with the theme you currently use.

Đọc câu trả lời này trong ngữ cảnh 1

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • GEPlugin
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • VLC media player Web Plugin
  • iTunes Detector Plug-in
  • npWinLessRtspCtrl

Ứng dụng

  • Firefox 38.0.5
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-GB/

Tiện ích mở rộng

  • 1Password 4.3.1 (onepassword4@agilebits.com)
  • Adblock Edge 2.1.9.1-signed ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Advanced URL Builder 1.6.29.1-signed ({31E65147-5A53-4e52-8A64-FF6EBFA36D76})
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)
  • F.B. Purity - Cleans Up Facebook 13.0.0 (fbp@fbpurity.com)
  • FavIconReloader 0.8.1-signed (FavIconReloader@mozilla.org)
  • feedly 16.0.528.1-signed (feedly@devhd)
  • HTTPS-Everywhere 5.0.5 (https-everywhere@eff.org)
  • Image Zoom 0.6.3.1-signed ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • Nuke Anything Enhanced 1.1.1-signed ({1ced4832-f06e-413f-aa14-9eb63ad40ace})
  • OmniSidebar 1.5.4.1-signed (osb@quicksaver)
  • Open in IE 1.4.1-signed (openinie@wittersworld.com)
  • Reddit Enhancement Suite 4.5.4.1-signed (jid1-xUfzOsOFlzSOXg@jetpack)
  • Show Parent Folder 2.1.1-signed (showParentFolder@alice)
  • SSL Version Control 0.4.1-signed (jid1-ZM3BerwS6FsQAg@jetpack)
  • Stylish 2.0.2.1-signed ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: AMD Radeon HD 6670
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x6758
  • adapterDeviceID2: 0x0412
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterRAM: 1024
  • adapterRAM2: Unknown
  • adapterSubsysID: 03f21043
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x1002
  • adapterVendorID2: 0x8086
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 7-4-2014
  • driverDate2: 3-16-2015
  • driverVersion: 13.251.9001.1001
  • driverVersion2: 10.18.14.4170
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6670 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
guigs 1072 giải pháp 11697 câu trả lời
Được đăng

Câu trả lời hữu ích

Hello,

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.
    Fx23MixedContentBlocker

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

Hello, Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: [[How does content that isn't secure affect my safety?]] To temporarily allow the mixed content to be displayed: *Click the '''shield icon''' [[Image:Mixed Content Shield]] in the address bar and choose '''Disable Protection on This Page''' from the dropdown menu.<br>[[Image:Fx23MixedContentBlocker|width=500]] To allow insecure content to be displayed in all secure pages, enter '''about:config''' in the address bar and double-click on this preference, to toggle it from true to false: '''security.mixed_content.block_active_content''' You can also use this add-on instead, to toggle the preference: *[https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ Toggle Mixed active content] add-on You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about. Let us know if this helps!

Người tạo câu hỏi

Thanks but it is happening on unencrypted sites.

Thanks but it is happening on unencrypted sites.
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 158001 câu trả lời
Được đăng

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if content like font files from a specific domain is blocked and has a file size 0 (zero).

Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if content like font files from a specific domain is blocked and has a file size 0 (zero). *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Tools/Network_Monitor

Người tạo câu hỏi

Thanks for the suggestions. Unfortunately the "Allow pages to choose their own fonts" box is checked and using the console to inspect the files as you described revealed that they have all downloaded ok.

Thanks for the suggestions. Unfortunately the "Allow pages to choose their own fonts" box is checked and using the console to inspect the files as you described revealed that they have all downloaded ok.
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 158001 câu trả lời
Được đăng

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Người tạo câu hỏi

Certainly, try this one: http://www.steam-engine.org/coil.asp?

Certainly, try this one: http://www.steam-engine.org/coil.asp?
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 158001 câu trả lời
Được đăng

Works fine here.

That are input elements of type=number.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Works fine here. That are input elements of type=number. *https://developer.mozilla.org/en-US/docs/Web/HTML/Element/Input ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

Trtied that already by creating a whole new profile with no addons. But just in case I restarted in safe mode with the default theme enabled. No luck the spinners still arent visible in the number fields.

Trtied that already by creating a whole new profile with no addons. But just in case I restarted in safe mode with the default theme enabled. No luck the spinners still arent visible in the number fields.
jscher2000
  • Top 10 Contributor
8704 giải pháp 71122 câu trả lời
Được đăng

Maybe one of Firefox's program files got damaged? You could try:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.5 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder, either:

64-bit Windows Vista/7/8

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

Windows XP and 32-bit Vista/7

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox display the controls normally?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Maybe one of Firefox's program files got damaged? You could try: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 38.0.5 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder, either: ''64-bit Windows Vista/7/8'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''Windows XP and 32-bit Vista/7'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Does a cleanly reinstalled Firefox display the controls normally? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins

Người tạo câu hỏi

Thanks for the suggestion. I couldn't find my (x86) program files folder until I remembered windows hides it. Renamed the Mozilla directory with my browser closed and did a fresh install. Unfortunately the controls are still not displayed.

Thanks for the suggestion. I couldn't find my (x86) program files folder until I remembered windows hides it. Renamed the Mozilla directory with my browser closed and did a fresh install. Unfortunately the controls are still not displayed.

Người tạo câu hỏi

I just made a Mozbackup of my profile, uninstalled firefox and deleted the whole mozilla folder from my [user]\AppData\Roaming directory.

I reinstalled Firefox (without restoring the backup) so this should be a brand new vanilla installation. The problem still exists! Gah!

Totally stumped.

I just made a Mozbackup of my profile, uninstalled firefox and deleted the whole mozilla folder from my [user]\AppData\Roaming directory. I reinstalled Firefox (without restoring the backup) so this should be a brand new vanilla installation. The problem still exists! Gah! Totally stumped.

Người tạo câu hỏi

Maybe some obscure registry setting that was not removed during uninstallation?

Maybe some obscure registry setting that was not removed during uninstallation?
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 158001 câu trả lời
Được đăng
This CSS file is used: *http://mxr.mozilla.org/mozilla-release/source/layout/style/number-control.css *resource://gre-resources/number-control.css *http://mxr.mozilla.org/mozilla-release/source/layout/style/nsStyleStruct.cpp#2700
cor-el
  • Top 10 Contributor
  • Moderator
17482 giải pháp 158001 câu trả lời
Được đăng

Giải pháp được chọn

You can try a different Windows them is case Firefox has a problem with the theme you currently use.

You can try a different Windows them is case Firefox has a problem with the theme you currently use.
jscher2000
  • Top 10 Contributor
8704 giải pháp 71122 câu trả lời
Được đăng

It's hard to think of a reason for the buttons to be crushed together like that. On mine, the button height is 8px, including border and padding, which is very tiny, but does not seem to vary depending on zoom. I can't tell where that is set, or why it might vary.

It's hard to think of a reason for the buttons to be crushed together like that. On mine, the button height is 8px, including border and padding, which is very tiny, but does not seem to vary depending on zoom. I can't tell where that is set, or why it might vary.

Người tạo câu hỏi

cor-el said

You can try a different Windows them is case Firefox has a problem with the theme you currently use.

Bingo! Changed to a default windows theme and the spinner controls are back. Thank you.

Very odd though. The only thing I remember changing in my last windows theme was the desktop background.

''cor-el [[#answer-740379|said]]'' <blockquote> You can try a different Windows them is case Firefox has a problem with the theme you currently use. </blockquote> Bingo! Changed to a default windows theme and the spinner controls are back. Thank you. Very odd though. The only thing I remember changing in my last windows theme was the desktop background.

Người tạo câu hỏi

More info if anyone else has this problem. I was using a Sychronised windows theme (so my other PCs had the same desktop backgrounds). Now at some stage I disabled onedrive and this theme was also from a previous windows installation. Not sure if any of that was the problem but it has now been deleted.

Thanks to all that replied for your help and suggestions.

More info if anyone else has this problem. I was using a Sychronised windows theme (so my other PCs had the same desktop backgrounds). Now at some stage I disabled onedrive and this theme was also from a previous windows installation. Not sure if any of that was the problem but it has now been deleted. Thanks to all that replied for your help and suggestions.

Người tạo câu hỏi

jscher2000 said

It's hard to think of a reason for the buttons to be crushed together like that. On mine, the button height is 8px, including border and padding, which is very tiny, but does not seem to vary depending on zoom. I can't tell where that is set, or why it might vary.

Yeah there's a bug report about the padding and spinner size.

https://bugzilla.mozilla.org/show_bug.cgi?id=1024078

Hopefully it will be rectified at some stage.

''jscher2000 [[#answer-740381|said]]'' <blockquote> It's hard to think of a reason for the buttons to be crushed together like that. On mine, the button height is 8px, including border and padding, which is very tiny, but does not seem to vary depending on zoom. I can't tell where that is set, or why it might vary. </blockquote> Yeah there's a bug report about the padding and spinner size. https://bugzilla.mozilla.org/show_bug.cgi?id=1024078 Hopefully it will be rectified at some stage.