X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

search dropdown always on top of & blocks typing, on screen keyboard annoyance

Được đăng

Hi

I use the windows On screen keyboard 95% of the time. And I like to place it generally in the middle of the window when using it. When I need to type into the search box, and even though the On screen keyboard is set to Always On Top, it always goes UNDER the dropdown search suggestions list, which blocks my ability to keep typing. I then have to stop typing and move the OSK to the right or left beyond the right or left edge of the search box, or move it to the very top of the window or very bottom out of the way of the dropdown. This then highlights the text I've already typed, forcing me to click at the end of it or start over (once I've moved the OSK out of it's way). Even if I have search suggestions turned off there is still a dropdown that blocks the OSK (the position/size/length of the search box along the top and the position of the OSK are where I like them bc of my poor vision). The address bar does the same thing. I want to know if there is a way to keep the dropdown search box UNDER the OSK while I'm typing? It's a long question I apologize, but it's a bit wordy to describe. see the photo and I'm sure you'll understand what I'm talking about. The OSK is always set to "Always On Top" in Win 7 prem.

thanks for your helpful reply mark

Hi I use the windows On screen keyboard 95% of the time. And I like to place it generally in the middle of the window when using it. When I need to type into the search box, and even though the On screen keyboard is set to Always On Top, it always goes UNDER the dropdown search suggestions list, which blocks my ability to keep typing. I then have to stop typing and move the OSK to the right or left beyond the right or left edge of the search box, or move it to the very top of the window or very bottom out of the way of the dropdown. This then highlights the text I've already typed, forcing me to click at the end of it or start over (once I've moved the OSK out of it's way). Even if I have search suggestions turned off there is still a dropdown that blocks the OSK (the position/size/length of the search box along the top and the position of the OSK are where I like them bc of my poor vision). The address bar does the same thing. I want to know if there is a way to keep the dropdown search box UNDER the OSK while I'm typing? It's a long question I apologize, but it's a bit wordy to describe. see the photo and I'm sure you'll understand what I'm talking about. The OSK is always set to "Always On Top" in Win 7 prem. thanks for your helpful reply mark

Giải pháp được chọn

looks like a work in progress for programmers. I wonder if this thread could be redirected to them? I am willing to mark this as solved for me personally as the shorter "old" drop-down behavior is easy{er} to avoid now and also provides less and less suggestions as i type in the query (which consequently alleviates my annoyance).

The OSK should, logically, remain on top, right? Ah even though it IS hard to read them with a keyboard in the way... this is defined as a conundrum for those that would, like me, to read both the helpful suggestions and the keyboard letters at the same time.
Đọc câu trả lời này trong ngữ cảnh 0

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • 4.0.50401.0
  • NPWLPG

Ứng dụng

  • Firefox 38.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/38.0.1/WINNT/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Dark YouTube Theme 1.3.1-signed (jid1-hDf2iQXGiUjzGQ@jetpack)
  • NoSquint 2.1.9.1-signed (nosquint@urandom.ca)
  • Video DownloadHelper 5.3.1.1-signed ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • YouTube High Definition 38.3.1-signed ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})
  • Avast Online Security 10.2.0.187 (wrc@avast.com) (không hoạt động)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 3672103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-4-2011
  • driverDate2:
  • driverVersion: 8.15.10.2353
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
guigs 1072 giải pháp 11697 câu trả lời
Được đăng

Hi Mark, I understand that the onscreen keyboard is not on top when the search suggestions begin to appear as you type into the Firefox search box.

If this is not something that can be tweaked in the Advanced Javascript control please let's file a bug in the Accessibility component of Firefox.

Please first see:

The mailing list for assistive technologies are as follows: [news://news.mozilla.org/mozilla.support.accessibility]

Hi Mark, I understand that the onscreen keyboard is not on top when the search suggestions begin to appear as you type into the Firefox search box. If this is not something that can be tweaked in the Advanced Javascript control please let's file a bug in the Accessibility component of Firefox. Please first see: *[https://developer.mozilla.org/en-US/docs/Mozilla/Accessibility/Accessibility_Features_in_Firefox#Keyboard_Support] However it looks like it points to the support forum for further instructions. This is confusing. The mailing list for assistive technologies are as follows: [news://news.mozilla.org/mozilla.support.accessibility]
cor-el
  • Top 10 Contributor
  • Moderator
17536 giải pháp 158571 câu trả lời
Được đăng

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
jscher2000
  • Top 10 Contributor
8772 giải pháp 71719 câu trả lời
Được đăng

I've never used the Windows 7 OSK before. I see what you mean about it being usually on top, but not staying in front of those drop-down panels.

Do you find the panels useful? If not, you may be able to reduce or minimize them. This isn't a straightforward as one might hope:

Search bar

It is possible to switch from the new design, which shows various search engine buttons for "one-off" use, back to the old design which doesn't have any drop-down when you disable search suggestions. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste search and pause while the list is filtered

(3) Double-click the browser.search.showOneOffButtons preference to switch it from true to false

This doesn't affect the current window, but each new window you open (Ctrl+n) will have the old Search bar.

I'm not sure when that will be phased out; it might only be available until the new bar is fully debugged.

URL bar (Location bar)

You can prevent Firefox from showing any suggestions from your bookmarks or history, or matching open tabs, by making a change in Options. Here's how:

"3-bar" menu button (or Tools menu) > Options > Privacy

Under the last section, Location bar, uncheck History, Bookmarks, and Open tabs. No suggestions should appear below the address bar when you type in it.

If you like the autosuggest feature but want the list to be shorter, for example, only showing 3 rows instead of 6, there might be a way to do that, but it probably would involve an add-on or a custom style rule and not using a built-in setting.

I've never used the Windows 7 OSK before. I see what you mean about it being ''usually'' on top, but not staying in front of those drop-down panels. Do you find the panels useful? If not, you may be able to reduce or minimize them. This isn't a straightforward as one might hope: '''''Search bar''''' It is possible to switch from the new design, which shows various search engine buttons for "one-off" use, back to the old design which doesn't have any drop-down when you disable search suggestions. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''search''' and pause while the list is filtered (3) Double-click the '''browser.search.showOneOffButtons''' preference to switch it from true to false This doesn't affect the current window, but each new window you open (Ctrl+n) will have the old Search bar. I'm not sure when that will be phased out; it might only be available until the new bar is fully debugged. '''''URL bar (Location bar)''''' You can prevent Firefox from showing ''any'' suggestions from your bookmarks or history, or matching open tabs, by making a change in Options. Here's how: "3-bar" menu button (or Tools menu) > Options > Privacy Under the last section, Location bar, uncheck History, Bookmarks, and Open tabs. No suggestions should appear below the address bar when you type in it. If you like the autosuggest feature but want the list to be shorter, for example, only showing 3 rows instead of 6, there might be a way to do that, but it probably would involve an add-on or a custom style rule and not using a built-in setting.

Người tạo câu hỏi

guigs2 said

Hi Mark, I understand that the onscreen keyboard is not on top when the search suggestions begin to appear as you type into the Firefox search box. If this is not something that can be tweaked in the Advanced Javascript control please let's file a bug in the Accessibility component of Firefox. Please first see:

---404 page

However it looks like it points to the support forum for further instructions. This is confusing. The mailing list for assistive technologies are as follows: [news://news.mozilla.org/mozilla.support.accessibility]

---goes to google search results with many inexact hits....

''guigs2 [[#answer-738642|said]]'' <blockquote> Hi Mark, I understand that the onscreen keyboard is not on top when the search suggestions begin to appear as you type into the Firefox search box. If this is not something that can be tweaked in the Advanced Javascript control please let's file a bug in the Accessibility component of Firefox. Please first see: *[https://developer.mozilla.org/en-US/docs/Mozilla/Accessibility/Accessibility_Features_in_Firefox#Keyboard_Support] </blockquote> ---404 page <blockquote> However it looks like it points to the support forum for further instructions. This is confusing. The mailing list for assistive technologies are as follows: [news://news.mozilla.org/mozilla.support.accessibility] </blockquote> ---goes to google search results with many inexact hits....

Người tạo câu hỏi

cor-el said

You can try to disable hardware acceleration in Firefox.
  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
You need to close and restart Firefox after toggling this setting.

---Still on top of OSK.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

---I believe I have everything up 2 date. I've looked thru the dozen or so optional ones offered and didn't see/chose any pertinent to my use.

''cor-el [[#answer-738645|said]]'' <blockquote> You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. </blockquote> ---Still on top of OSK. <blockquote> You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> ---I believe I have everything up 2 date. I've looked thru the dozen or so optional ones offered and didn't see/chose any pertinent to my use.

Người tạo câu hỏi

jscher2000 said

You can prevent Firefox from showing any suggestions from your bookmarks or history, or matching open tabs, by making a change in Options.

---this worked for the address bar, no dropdown, but i actually only really search in the adjacent search box.

If you like the autosuggest feature but want the list to be shorter, for example, only showing 3 rows instead of 6, there might be a way to do that, but it probably would involve an add-on or a custom style rule and not using a built-in setting.

---I do like it. somehow it is the simple style now (forgot if i did that or not?), just the suggestions only now, old style i guess. [Interestingly, I so far have not attempted the 3 step about:config solution above --> "browser.search.showOneOffButtons preference" yet.] sounds scary ;-/

---It does give more than six suggestions still though, just by typing in one letter even. OSK still ducts underneath it ...still annoying, but better as it seems to only give more suggestions minimally (<3 lines). after a few more letters. SEE Attached screenshot.

thanks for the 3 replys/suggestions/possible solutions. I can live with this simple behavior now i think. Any new more definitive answers to keeping the OSK on top will be welcome, as i'll keep getting your replys in my inbox. thanks! Mark

''jscher2000 [[#answer-738651|said]]'' <blockquote> You can prevent Firefox from showing ''any'' suggestions from your bookmarks or history, or matching open tabs, by making a change in Options. </blockquote> ---this worked for the address bar, no dropdown, but i actually only really search in the adjacent search box. <blockquote> If you like the autosuggest feature but want the list to be shorter, for example, only showing 3 rows instead of 6, there might be a way to do that, but it probably would involve an add-on or a custom style rule and not using a built-in setting. </blockquote> ---I do like it. somehow it is the simple style now (forgot if i did that or not?), just the suggestions only now, old style i guess. [Interestingly, I so far have not attempted the 3 step about:config solution above --> "browser.search.showOneOffButtons preference" yet.] sounds scary ;-/ ---It does give more than six suggestions still though, just by typing in one letter even. OSK still ducts underneath it ...still annoying, but better as it seems to only give more suggestions minimally (<3 lines). after a few more letters. SEE Attached screenshot. thanks for the 3 replys/suggestions/possible solutions. I can live with this simple behavior now i think. Any new more definitive answers to keeping the OSK on top will be welcome, as i'll keep getting your replys in my inbox. thanks! Mark
jscher2000
  • Top 10 Contributor
8772 giải pháp 71719 câu trả lời
Được đăng

Hi Mark, if you decide you don't want those "real time" search suggestions from Google, you can right-click the search bar and uncheck "Show Search Suggestions" on the drop-down menu. If you change your mind, it's just as simple to switch them back on, so feel free to experiment.

Edit: That is the old style search bar already in your screen shot, so no need to switch to it using about:config.

Hi Mark, if you decide you don't want those "real time" search suggestions from Google, you can right-click the search bar and ''uncheck'' "Show Search Suggestions" on the drop-down menu. If you change your mind, it's just as simple to switch them back on, so feel free to experiment. ''Edit: That is the old style search bar already in your screen shot, so no need to switch to it using about:config.''

Được chỉnh sửa bởi jscher2000 vào

Người tạo câu hỏi

"you can right-click the search bar and uncheck "Show Search Suggestions" on the drop-down menu."

i never saw/used that "show suggestions" [bottom of search drop down box] b4. but it was already unchecked. curious? checked or not, it still drops down up to 8 lines of suggestions -on top of the OSK, with one letter entered.

"you can right-click the search bar and uncheck "Show Search Suggestions" on the drop-down menu." i never saw/used that "show suggestions" [bottom of search drop down box] b4. but it was already unchecked. curious? checked or not, it still drops down up to 8 lines of suggestions -on top of the OSK, with one letter entered.

Được chỉnh sửa bởi mjimih vào

Người tạo câu hỏi

accessibility.typeaheadfind.flashBar 0 browser.cache.disk.capacity 358400 browser.cache.disk.smart_size.first_run false browser.cache.disk.smart_size.use_old_max false browser.cache.frecency_experiment 2 browser.display.document_color_use 1 browser.download.folderList 2 browser.download.importedFromSqlite true browser.places.smartBookmarksVersion 7 browser.search.suggest.enabled false browser.sessionstore.upgradeBackup.latestBuildID 20150513174244 browser.startup.homepage https://mail.google.com/mail/u/0/?pli=1#inbox browser.startup.homepage_override.buildID 20150513174244 browser.startup.homepage_override.mstone 38.0.1 browser.tabs.loadInBackground false browser.tabs.warnOnClose false browser.urlbar.autocomplete.enabled false browser.urlbar.suggest.bookmark false browser.urlbar.suggest.history false browser.urlbar.suggest.openpage false browser.zoom.siteSpecific false dom.mozApps.used true extensions.lastAppVersion 38.0.1 font.size.fixed.x-western 12 font.size.variable.x-western 12 general.autoScroll false gfx.direct2d.disabled true gfx.direct3d.last_used_feature_level_idx 0 layers.acceleration.disabled true media.gmp-eme-adobe.lastUpdate 1433173513 media.gmp-eme-adobe.version 10 media.gmp-gmpopenh264.lastUpdate 1432402817 media.gmp-gmpopenh264.version 1.4 media.gmp-manager.buildID 20150513174244 media.gmp-manager.lastCheck 1433824489 mousewheel.withcontrolkey.action 3 network.cookie.prefsMigrated true network.predictor.cleaned-up true places.database.lastMaintenance 1433857086 places.history.expiration.transient_current_max_pages 104858 plugin.disable_full_page_plugin_for_types application/pdf plugin.importedState true privacy.cpd.extensions-nosquint false privacy.donottrackheader.enabled true privacy.sanitize.migrateFx3Prefs true privacy.trackingprotection.enabled true storage.vacuum.last.index 1 storage.vacuum.last.places.sqlite 1432406611

accessibility.typeaheadfind.flashBar 0 browser.cache.disk.capacity 358400 browser.cache.disk.smart_size.first_run false browser.cache.disk.smart_size.use_old_max false browser.cache.frecency_experiment 2 browser.display.document_color_use 1 browser.download.folderList 2 browser.download.importedFromSqlite true browser.places.smartBookmarksVersion 7 browser.search.suggest.enabled false browser.sessionstore.upgradeBackup.latestBuildID 20150513174244 browser.startup.homepage https://mail.google.com/mail/u/0/?pli=1#inbox browser.startup.homepage_override.buildID 20150513174244 browser.startup.homepage_override.mstone 38.0.1 browser.tabs.loadInBackground false browser.tabs.warnOnClose false browser.urlbar.autocomplete.enabled false browser.urlbar.suggest.bookmark false browser.urlbar.suggest.history false browser.urlbar.suggest.openpage false browser.zoom.siteSpecific false dom.mozApps.used true extensions.lastAppVersion 38.0.1 font.size.fixed.x-western 12 font.size.variable.x-western 12 general.autoScroll false gfx.direct2d.disabled true gfx.direct3d.last_used_feature_level_idx 0 layers.acceleration.disabled true media.gmp-eme-adobe.lastUpdate 1433173513 media.gmp-eme-adobe.version 10 media.gmp-gmpopenh264.lastUpdate 1432402817 media.gmp-gmpopenh264.version 1.4 media.gmp-manager.buildID 20150513174244 media.gmp-manager.lastCheck 1433824489 mousewheel.withcontrolkey.action 3 network.cookie.prefsMigrated true network.predictor.cleaned-up true places.database.lastMaintenance 1433857086 places.history.expiration.transient_current_max_pages 104858 plugin.disable_full_page_plugin_for_types application/pdf plugin.importedState true privacy.cpd.extensions-nosquint false privacy.donottrackheader.enabled true privacy.sanitize.migrateFx3Prefs true privacy.trackingprotection.enabled true storage.vacuum.last.index 1 storage.vacuum.last.places.sqlite 1432406611
jscher2000
  • Top 10 Contributor
8772 giải pháp 71719 câu trả lời
Được đăng

I don't know why you still get search suggestions after turning them off. Could be that the code has changed in that area and isn't quite compatible with the "old" search bar any more.

I don't know why you still get search suggestions after turning them off. Could be that the code has changed in that area and isn't quite compatible with the "old" search bar any more.

Giải pháp được chọn

looks like a work in progress for programmers. I wonder if this thread could be redirected to them? I am willing to mark this as solved for me personally as the shorter "old" drop-down behavior is easy{er} to avoid now and also provides less and less suggestions as i type in the query (which consequently alleviates my annoyance).

The OSK should, logically, remain on top, right? Ah even though it IS hard to read them with a keyboard in the way... this is defined as a conundrum for those that would, like me, to read both the helpful suggestions and the keyboard letters at the same time.
looks like a work in progress for programmers. I wonder if this thread could be redirected to them? I am willing to mark this as solved for me personally as the shorter "old" drop-down behavior is easy{er} to avoid now and also provides less and less suggestions as i type in the query (which consequently alleviates my annoyance). The OSK should, logically, remain on top, right? Ah even though it IS hard to read them with a keyboard in the way... this is defined as a conundrum for those that would, like me, to read both the helpful suggestions and the keyboard letters at the same time.

Được chỉnh sửa bởi mjimih vào

cor-el
  • Top 10 Contributor
  • Moderator
17536 giải pháp 158571 câu trả lời
Được đăng

Câu trả lời hữu ích

You can also consider to move the search bar to the "3-bar" Firefox menu button drop-down list. The it will appear at the right end of the screen. The Ctrl+K shortcut will still open the "3-bar" Firefox menu button drop-down list with the search bar having focus.

You can also consider to move the search bar to the "3-bar" Firefox menu button drop-down list. The it will appear at the right end of the screen. The Ctrl+K shortcut will still open the "3-bar" Firefox menu button drop-down list with the search bar having focus.

Người tạo câu hỏi

cor-el said

You can also consider to move the search bar to the "3-bar" Firefox menu button drop-down list. The it will appear at the right end of the screen. The Ctrl+K shortcut will still open the "3-bar" Firefox menu button drop-down list with the search bar having focus.

Now that's very helpful. I just did that and like it. grab a beer, u deserve it. be sure to include jscher2000 & guigs2 too thanks! Mark

''cor-el [[#answer-739049|said]]'' <blockquote> You can also consider to move the search bar to the "3-bar" Firefox menu button drop-down list. The it will appear at the right end of the screen. The Ctrl+K shortcut will still open the "3-bar" Firefox menu button drop-down list with the search bar having focus. </blockquote> Now that's very helpful. I just did that and like it. grab a beer, u deserve it. be sure to include jscher2000 & guigs2 too thanks! Mark