X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox after updating to 37.0.1 doesn't play youtube videos.

Được đăng

After updating to 37.0.1 Youtube doesn't play any videos. I don't have Flash Player installed. Never had it installed. I always have used Youtube HTML5 video player and everything was ok. Unfortunately until today when I installed Firefox 37.0.1. I tried deleting hisotry, cache etc. completely but it did not help.

After updating to 37.0.1 Youtube doesn't play any videos. I don't have Flash Player installed. Never had it installed. I always have used Youtube HTML5 video player and everything was ok. Unfortunately until today when I installed Firefox 37.0.1. I tried deleting hisotry, cache etc. completely but it did not help.

Giải pháp được chọn

Is it "An error occurred, please try again later"?

When you visit YouTube's HTML5 page, does it show 5 out of 6 features with a blue checkmark box (all except the last one):

https://www.youtube.com/html5

On my Windows 7, if I have "MSE & H.264" enabled, then YT fails on HTML5 and switches to Flash.

Could you try disabling a Firefox preference and then reload the YouTube page and see whether it plays?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

Đọc câu trả lời này trong ngữ cảnh 7

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Battlelog Game Launcher (2.6.2)
  • NPWLPG

Ứng dụng

  • Firefox 37.0.1
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; rv:37.0) Gecko/20100101 Firefox/37.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/37.0.1/WINNT/pl/

Tiện ích mở rộng

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • NoScript 2.6.9.20 ({73a6fe31-595d-460b-a920-fcc0f8843232})

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: AMD Radeon R7 200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6658
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 227b1458
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 11-20-2014
  • driverDate2:
  • driverVersion: 14.501.1003.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R7 200 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Thay đổi cài đặt

Linh tinh

  • Người dùng JS: Không
  • Có thể tiếp cận: Không
jscher2000
  • Top 10 Contributor
8880 giải pháp 72665 câu trả lời
Được đăng

Giải pháp được chọn

Is it "An error occurred, please try again later"?

When you visit YouTube's HTML5 page, does it show 5 out of 6 features with a blue checkmark box (all except the last one):

https://www.youtube.com/html5

On my Windows 7, if I have "MSE & H.264" enabled, then YT fails on HTML5 and switches to Flash.

Could you try disabling a Firefox preference and then reload the YouTube page and see whether it plays?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.mediasource.mp4.enabled preference to switch it from true to false

Is it "An error occurred, please try again later"? When you visit YouTube's HTML5 page, does it show 5 out of 6 features with a blue checkmark box (all except the last one): https://www.youtube.com/html5 On my Windows 7, if I have "MSE & H.264" enabled, then YT fails on HTML5 and switches to Flash. Could you try disabling a Firefox preference and then reload the YouTube page and see whether it plays? (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.mediasource.mp4.enabled''' preference to switch it from true to false

Được chỉnh sửa bởi jscher2000 vào

cor-el
  • Top 10 Contributor
  • Moderator
17768 giải pháp 160708 câu trả lời
Được đăng

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Người tạo câu hỏi

Thank you very much for answering guys. Yes, it was "An error occurred, please try again later" error. First of all I tried running Firefox with all extensions disabled. It turned out that NoScript was causing the problem. With NoScript disabled or set to "allow all scripts" Youtube was working fine again.

Than I tried doing what jscher2000 said. I went to youtube.com/html5 and exactly as you said everything was okay except "MSE & WebM VP9" so i changed "media.mediasource.mp4.enabled" to false and Youtube is working again fine even with NoScript turned on.

Thank you again guys <3

Thank you very much for answering guys. Yes, it was "An error occurred, please try again later" error. First of all I tried running Firefox with all extensions disabled. It turned out that NoScript was causing the problem. With NoScript disabled or set to "allow all scripts" Youtube was working fine again. Than I tried doing what jscher2000 said. I went to youtube.com/html5 and exactly as you said everything was okay except "MSE & WebM VP9" so i changed "media.mediasource.mp4.enabled" to false and Youtube is working again fine even with NoScript turned on. Thank you again guys <3
jscher2000
  • Top 10 Contributor
8880 giải pháp 72665 câu trả lời
Được đăng

Câu trả lời hữu ích

I forgot about that: the NoScript menu lists mediasource: as a protocol instead of a website, so even if you have allowed scripts for youtube.com and ytimg.com, you also need to allow the mediasource: protocol. I guess I forgot that I only enabled it temporarily, so thank you for the reminder to check that.

I forgot about that: the NoScript menu lists mediasource: as a protocol instead of a website, so even if you have allowed scripts for youtube.com and ytimg.com, you also need to allow the mediasource: protocol. I guess I forgot that I only enabled it temporarily, so thank you for the reminder to check that.
Deben 0 giải pháp 1 câu trả lời
Được đăng

Câu trả lời hữu ích

I have noscript installed. HTML5 youtube video worked after allowing scripts from "googlevideo.com". I guess it should be obvious, but it took a while to notice the domain was being blocked.

I have noscript installed. HTML5 youtube video worked after allowing scripts from "googlevideo.com". I guess it should be obvious, but it took a while to notice the domain was being blocked.