Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

On some web sites, the player is covered by . . .

  • 9 trả lời
  • 8 gặp vấn đề này
  • 80 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

an invisible screen. Sometimes, I can remove it using Inspect Element. For example, on YouTube, the block is coded;

<div id="theater-background" class="player-height"></div>

After I remove the above, the block is gone. How can I get this to not be there in the first place?

Được chỉnh sửa bởi cor-el vào

Giải pháp được chọn

Add-ons are a prime suspect here, especially with your Firefox configuration of about one billion add-ons. Can you start Firefox in Safe Mode and see if this still happens? If it doesn't, then an add-on is definitely causing it.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

The code did not post properly. I'll try again

For example, on YouTube, the block is coded; I had to break the one line up to post it;


< div id="theater-background" class="player-height" > < / div >


After I remove the above, the block is gone. How can I get this to not be there in the first place?

more options

Giải pháp được chọn

Add-ons are a prime suspect here, especially with your Firefox configuration of about one billion add-ons. Can you start Firefox in Safe Mode and see if this still happens? If it doesn't, then an add-on is definitely causing it.

Được chỉnh sửa bởi user1194064 vào

more options

Now this is a surprise. I expected this to be an issue on the web page. It turns out the problem is with Flashblock. I sent them a bug report. If Flashblock is disabled, the invisible screen is gone.

Many thanks, Just-A-User, I should have thought of that myself.

more options

I have heard back from Flash Block.

In your Firefox profile folder, create this folder; chrome Inside this folder, create or edit this file with your text editor; userContent.css


Now add this code into the file;

/* Flash Block */
@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("youtube.com"){
#theater-background { display:none !important;}
}

Được chỉnh sửa bởi FredMcD vào

more options

FredMcD said

I have heard back from Flash Block. In your Firefox profile folder, create this folder; chrome Create or edit this file with your text editor; userContent.css Now add this code into the file; /* Flash Block */ @namespace url(http://www.w3.org/1999/xhtml); @-moz-document domain("youtube.com"){ #theater-background { display:none !important;} }

Glad to help! :)

Được chỉnh sửa bởi user1194064 vào

more options

FredMcD said

I have heard back from Flash Block. In your Firefox profile folder, create this folder; chrome Create or edit this file with your text editor; userContent.css Now add this code into the file; /* Flash Block */ @namespace url(http://www.w3.org/1999/xhtml); @-moz-document domain("youtube.com"){ #theater-background { display:none !important;} }

Does this issue cause the videos to not play at all, because that's what I am having. I don't know of there is an invisible shield, or what; I just see a black screen instead of a video. For a while, embedded ones worked, but now those are messed up as well.

Would love to try your fix, bt I don't know where to locate the Firefox profile folder. Where do I look for that?

more options

LadyGreenEyes said

Does this issue cause the videos to not play at all, because that's what I am having.

What happens is the player is displayed on the web page. But the "Play Arrow" does not appear when you move the mouse on the player.

I don't know where to locate the Firefox profile folder.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

In your Firefox profile folder, create this folder; chrome Inside this folder, create or edit this file with your text editor; userContent.css

Now add this code into the file;

/* Flash Block */
@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("youtube.com"){
#theater-background { display:none !important;}
}

</blockquote>

more options

Ah, that makes sense! Will give it a shot, and see if I can keep the thing activated! Appreciate the info, thanks!

more options

You're welcome. Safe surfing.