Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

How can I get <CTRL-F> to open the find dialog?

  • 4 trả lời
  • 1 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi KWire

more options

I am using Firefox V36.0.4 and when I am on the catalog site of mydoitbest.com and I press the CTRL+F to open the find dialog and it doesn't work. I contacted the authors of the site and they said:

"This is a quirk in Firefox actually, not our site. You need to either click at the top of the browser (in some blank area, like below the address bar) before pressing Ctrl+F or press Ctrl+F twice for the search bar to come up in the lower left corner. We updated our Firefox to your recent version and had the same result. If you click the top of the browser first or press Ctrl+F twice that will bring the search bar up."

I'm not sure I believe them... This is the only site that has the problem. I have tried Firefox in Safe Mode, it still doesn't work. I believe they are doing something to capture the <CTRL> key because when I press CTRL+Left Mouse Click on a link it should open a the link on a new <TAB>, but instead just opens the link in the same <TAB>.

Has anybody else reported a problem with Firefox? Any other ideas or any way for me to check the source for the page to see if they are doing something wrong?

Thanks, Keith

Tất cả các câu trả lời (4)

more options

Hello there,

This has been changed since Firefox 25 - refer to the release notes at https://www.mozilla.org/en-US/firefox/25.0/releasenotes/.

You can just continue to search in a new tab by pressing F3.

If you still face some issues then I suggest you to visit the link below: https://support.mozilla.org/en-US/questions/970088

Hope this helps!

Được chỉnh sửa bởi Machine Master vào

more options

Hi, thanks for the reply.

No, that doesn't fix the problem.

I've done some programming and have been checking out their site. They are trapping the keys so the first time I press <CTRL-F> it puts a lower case "f" in their search box. If I press <CTRL-F> again the search dialog box does open. If I click on their search box first with the mouse, then press <CTRL-F> it works as it should.

I guess I'll have to live with it, because they don't seem interested in correcting their problem.

Thanks, Keith

more options

Does this happen with other keyboard shortcuts as well?

This can happen if a plugin has focus. If that is the case then you will have to click with the mouse elsewhere on the page or in the user interface to make Firefox process key presses.

more options

Yes,

It does it for all shortcut keys. It appears they are forcing the first actual key press to their search box regardless of where focus is on the page or if there was <CTRL> of <ALT> held down.

Once focus is on their search everything works as normal.

Real PIA...

Keith