Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox hangs very frequently after upgrading to 36 on Mac OS

  • 10 trả lời
  • 11 gặp vấn đề này
  • 599 lượt xem
  • Trả lời mới nhất được viết bởi guigs

more options

I have Mac OS X 10.6.8. I recently upgraded to Firefox 36.0.1. Ever since the upgrade Firefox hangs on most of the news and other websites that I frequent.

Anything that can be done to fix this?

Giải pháp được chọn

Hello, thanks for chiming in.

Yesterday I updated Flash to the latest version, and today I still got the problem, so that is ruled out definitively as cause.

Otoh I have been using FF for 2 days without a hitch I was just browsing around), and only had the slowdown appear today after I had activated Firebug for checking http traffic on a site I am developing.

This confirms the impression I had already got on friday, that Firebug might be involved. I put a comment their tracker, issue #7771

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (10)

more options

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

I tried your suggestions. Removed hardware acceleration. Have the latest version of Shockwave Flash.

But the problem persists even in Safe Mode. Firefox just hangs when I visit sites like guardian.co.uk. I have to go to Force Quit and kill Firefox.

more options

Same on win8.1 64bits. I thought it was a compiling-js problem , but it seems to happen on more and more sites...

ps: about the 'compiling-js' thing: not being a mozilla dev, all I can say in fact is: in the past I had the experience that some releases, while adding more and more jit goodness to the js interpreter, also were subject to stop-the-world-pauses, which I pinned down to js optimization, but it might have been something else altogether, such as slowdowns from the ssd or the encrypted partition which I use on top of it (truecrypt based)

Được chỉnh sửa bởi gggeek vào

more options

ps: the latest occurrence of this was just after restarting firefox and heading to google calendar. there should be no flash involved in that

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia


Install this. Is the problem still there?

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

more options

I did not install flashblock nor restarted the laptop in safe mode, but

- I doublechecked when FF froze, that the flash plugin container was not started (using process explorer)

- I checked resource usage while FF was blocked. Not a lot of IO going on, but definitely a big CPU spike when it starts hanging, followed by a lesser spike at the moment it comes back to life

- I might have forgot to tell you that when it comes back to life, it says 'a js on this page stopped working'

- when this happened last time I clicked on 'debug the script', and it opened ga.js

- I generally only visit safe websites (I have been a web developer for 7 years, and coding for a living north of 14 years btw)

- I have traced the FF syscalls while it was stuck, using procmon. I can send you the trace, if you're interested

more options

I've called the big guys to help you. Good luck.

more options

@ggeek If you are interested in getting involved please check out the QA Get Involved page: https://wiki.mozilla.org/QA/Desktop_F.../Tasks. It also sounds like you have a different issue, please consider starting a new thread.

In the meantime, since these did not help there is another version of Flash player that came out yesterday. I recommend updating and restarting Firefox to check for any updates.

more options

Giải pháp được chọn

Hello, thanks for chiming in.

Yesterday I updated Flash to the latest version, and today I still got the problem, so that is ruled out definitively as cause.

Otoh I have been using FF for 2 days without a hitch I was just browsing around), and only had the slowdown appear today after I had activated Firebug for checking http traffic on a site I am developing.

This confirms the impression I had already got on friday, that Firebug might be involved. I put a comment their tracker, issue #7771

Được chỉnh sửa bởi gggeek vào

more options

Ok, please do post back to help other users, I will mark your post as the solution for now, and will unmark it if other issues are found.