X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

'No video with supported format and MIME type found' issue

Được đăng

Hello everyone, sorry for the long post.

For the last 3 days, I have been experiencing a very frustrating issue with videos posted ONLY on Facebook.

Every time I try to open a Facebook video, the Facebook player opens (the one where you can see comments and likes on the right side), and Firefox gives the impression that the video is loading. But after a while, a 'cross' appears in the middle of the screen, below which 'No video with supported format and MIME type found' is written [Kindly refer to the attached screenshot].

Prior to this problem, I had NEVER, in 2 years, experienced any issue whatsoever with playing ANY videos on the Web. Firefox just suddenly decided to stop playing Facebook videos.

WHAT I ALREADY TRIED: - Reload video pages and play them again (FAILED) - Clear cache, cookies and restart Firefox (FAILED) - Start Firefox in Safe Mode (FAILED) - Uninstall Flash Player, try to play videos with the default Firefox player (any video on the Web would play, but Facebook videos FAILED) - Enable the Open H264 Cisco codec (FAILED) - Changing a few values in about:config *(such as media.directshow.enabled) to true/false (FAILED) - Refresh Firefox from https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings (FAILED)

ADDITIONAL INFORMATION: - I use Firefox 35.0.1 and have no other browser (besides the default Internet Explorer 6 which I never use) - I use Windows XP SP3 Professional - I have not downloaded/installed any software/extension/add-on which could have caused this problem

I still love Firefox, and have no intention of migrating to a competitor's browser, which is why I hope a prompt solution shall be found. As well, I am not considering dropping XP SP3 anytime soon; it is very stable and fulfills my requirements.

Thanking you for your time.

Hello everyone, sorry for the long post. For the last 3 days, I have been experiencing a very frustrating issue with videos posted ONLY on Facebook. Every time I try to open a Facebook video, the Facebook player opens (the one where you can see comments and likes on the right side), and Firefox gives the impression that the video is loading. But after a while, a 'cross' appears in the middle of the screen, below which 'No video with supported format and MIME type found' is written [Kindly refer to the attached screenshot]. Prior to this problem, I had NEVER, in 2 years, experienced any issue whatsoever with playing ANY videos on the Web. Firefox just suddenly decided to stop playing Facebook videos. WHAT I ALREADY TRIED: - Reload video pages and play them again (FAILED) - Clear cache, cookies and restart Firefox (FAILED) - Start Firefox in Safe Mode (FAILED) - Uninstall Flash Player, try to play videos with the default Firefox player (any video on the Web would play, but Facebook videos FAILED) - Enable the Open H264 Cisco codec (FAILED) - Changing a few values in about:config *(such as media.directshow.enabled) to true/false (FAILED) - Refresh Firefox from https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings (FAILED) ADDITIONAL INFORMATION: - I use Firefox 35.0.1 and have no other browser (besides the default Internet Explorer 6 which I never use) - I use Windows XP SP3 Professional - I have not downloaded/installed any software/extension/add-on which could have caused this problem I still love Firefox, and have no intention of migrating to a competitor's browser, which is why I hope a prompt solution shall be found. As well, I am not considering dropping XP SP3 anytime soon; it is very stable and fulfills my requirements. Thanking you for your time.

Giải pháp được chọn

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Last resort; Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Đọc câu trả lời này trong ngữ cảnh 3

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Foxit Reader Plug-In For Firefox and Netscape
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Shockwave Flash 17.0 d0
  • Npdsplay dll

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0

Thông tin chi tiết

Được đăng

Câu trả lời hữu ích

Apologies for double post, the screenshot upload failed when I posted the question.

Apologies for double post, the screenshot upload failed when I posted the question.
cor-el
  • Top 10 Contributor
  • Moderator
17517 giải pháp 158399 câu trả lời
Được đăng

The 'No video with supported format and MIME type found' error message is about the HTML5 media player. So you do not appear to have support in Windows for playing the media file(s) in the formats that are available.

See also:

Setting media.directshow.enabled to false will disable the HTML5 media player for H.264 content and might make a website to use a Flash player as fallback. You may have to remove the cookies to make this work.

The 'No video with supported format and MIME type found' error message is about the HTML5 media player. So you do not appear to have support in Windows for playing the media file(s) in the formats that are available. See also: *https://support.mozilla.org/kb/viewing-html5-audio-and-video Setting media.directshow.enabled to false will disable the HTML5 media player for H.264 content and might make a website to use a Flash player as fallback. You may have to remove the cookies to make this work.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59575 câu trả lời
Được đăng
'''[https://www.adobe.com/software/flash/about/ Flash Player Test Page]''' '''[https://www.youtube.com/html5 YouTube Test Page: What video does this browser support]'''
capot1948 0 giải pháp 20 câu trả lời
Được đăng

I have this issue that just started today after upgrading to FF 36.0. Unlike some I'm running Ubuntu Linux however I'm not using the Ubuntu version of Firefox. This appears to be a common issue now between multiple platforms.

I have this issue that just started today after upgrading to FF 36.0. Unlike some I'm running Ubuntu Linux however I'm not using the Ubuntu version of Firefox. This appears to be a common issue now between multiple platforms.
Được đăng

Người tạo câu hỏi

Hello again everyone.

I have found a very important piece of information which might shed more light on the issue.

I found yesterday that this problem occurs ONLY when I am actively logged onto Facebook. When I have disconnected and access the page where the video is found, the video plays correctly using Flash Player.

Kindly refer to the attached screenshot which illustrates this using a random video.

Hello again everyone. I have found a very important piece of information which might shed more light on the issue. I found yesterday that this problem occurs ONLY when I am actively logged onto Facebook. When I have disconnected and access the page where the video is found, the video plays correctly using Flash Player. Kindly refer to the attached screenshot which illustrates this using a random video.
Được đăng

Người tạo câu hỏi

cor-el said

Setting media.directshow.enabled to false will disable the HTML5 media player for H.264 content and might make a website to use a Flash player as fallback. You may have to remove the cookies to make this work.

By the way, Cor-El, my reply above happens regardless of whether I have set 'media.directshow.enabled' to true or false.

''cor-el [[#answer-694730|said]]'' <blockquote> Setting media.directshow.enabled to false will disable the HTML5 media player for H.264 content and might make a website to use a Flash player as fallback. You may have to remove the cookies to make this work. </blockquote> By the way, Cor-El, my reply above happens regardless of whether I have set 'media.directshow.enabled' to true or false.
FredMcD
  • Top 10 Contributor
4254 giải pháp 59575 câu trả lời
Được đăng

Giải pháp được chọn

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Last resort; Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. ---------------------------------- Last resort; '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.
capot1948 0 giải pháp 20 câu trả lời
Được đăng

Fred, tried all of your suggestions exactly as you posted, still will not work on my FF 36.0 on my Linux box. This only seems to affect videos on Facebook. I can watch videos posted on Twitter and on other sites just not in Facebook.

Fred, tried all of your suggestions exactly as you posted, still will not work on my FF 36.0 on my Linux box. This only seems to affect videos on Facebook. I can watch videos posted on Twitter and on other sites just not in Facebook.

Được chỉnh sửa bởi capot1948 vào

FredMcD
  • Top 10 Contributor
4254 giải pháp 59575 câu trả lời
Được đăng

Câu trả lời hữu ích

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
capot1948 0 giải pháp 20 câu trả lời
Được đăng

Thanks Fred, odd that it only is affecting Facebook videos.

Thanks Fred, odd that it only is affecting Facebook videos.
cor-el
  • Top 10 Contributor
  • Moderator
17517 giải pháp 158399 câu trả lời
Được đăng

What do you see if you open the Inspector? I assume that you would see a video element.

What is the source URL of the file that is played in that second screenshot?

What do you see if you open the Inspector? I assume that you would see a video element. What is the source URL of the file that is played in that second screenshot? *https://developer.mozilla.org/Tools/Page_Inspector
Được đăng

Người tạo câu hỏi

Thank you for your response, FredMcD. I followed your recommendations:

FredMcD said

Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

Subsequently, I tried loading videos from Facebook, and I am pleased to say they started playing correctly! Therefore I had no need to go through the second part, the one with Hardware Acceleration.

Allow me to add a few details which might be of some help to you: - The videos are now playing using my Flash Player (and not the HTML5 player as we might have suspected) - My 'media.directshow.enabled' in 'about:config' is set to true - On my Add-ons page, I have set Flash Player as 'Always activate' and my OpenH264 video codec as 'Never activate'

Once again, FredMcD, I genuinely value your input and thank your for your time :)

Thank you for your response, FredMcD. I followed your recommendations: ''FredMcD [[#answer-694933|said]]'' <blockquote> Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' </blockquote> Subsequently, I tried loading videos from Facebook, and I am pleased to say they started playing correctly! Therefore I had no need to go through the second part, the one with Hardware Acceleration. Allow me to add a few details which might be of some help to you: - The videos are now playing using my Flash Player (and not the HTML5 player as we might have suspected) - My 'media.directshow.enabled' in 'about:config' is set to true - On my Add-ons page, I have set Flash Player as 'Always activate' and my OpenH264 video codec as 'Never activate' Once again, FredMcD, I genuinely value your input and thank your for your time :)
FredMcD
  • Top 10 Contributor
4254 giải pháp 59575 câu trả lời
Được đăng

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Aabaavaanan 0 giải pháp 8 câu trả lời
Được đăng

Thanks for the post

Thanks for the post

Được chỉnh sửa bởi Aabaavaanan vào

capot1948 0 giải pháp 20 câu trả lời
Được đăng

Seems to be working fine now in FF 37 - 40.

Seems to be working fine now in FF 37 - 40.